]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
8b562cbcb5e7420370087182764b99dbfa5f2e3c
[packages/busybox.git] / busybox.spec
1 # TODO:
2 # - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3 #   if it still serves a purpose
4 # - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5 # - make internal commands work even if busybox is not in /bin/busybox (initrd)
6 #   or when /proc is not mounted (static / normal)
7 #
8 # Conditional build:
9 # alternative busybox config file (replaces default one) you should
10 # define cfgfile macro, i.e.
11 #
12 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
13 #
14 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
15 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
16 %bcond_without  dynamic         # don't build dynamic (base) version
17 %bcond_without  static          # don't build static version
18 %bcond_without  initrd          # don't build initrd version
19 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
20 %bcond_with     glibc           # build glibc-based initrd and static versions
21 %bcond_without  verbose         # verbose build
22 # Options below are useful, when you want fileutils and grep providing.
23 # For example, ash package requires fileutils and grep.
24 %bcond_with     fileutl_prov    # adds fileutils providing
25 %bcond_with     grep_prov       # adds grep providing
26 # Option below is useful, when busybox is built with shell support.
27 %bcond_with     sh_prov         # adds /bin/sh providing
28 # WARNING! Shell, fileutils and grep providing may depend on config file!
29 # Fileutils, grep and shell provided with busybox have not such
30 # functionality as their GNU countenders.
31 #
32 %ifnarch %{ix86} %{x8664} ppc
33 %define with_glibc 1
34 %endif
35 Summary:        Set of common Unix utilities for embeded systems
36 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
37 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
38 Name:           busybox
39 # stable line only
40 Version:        1.22.1
41 Release:        4
42 License:        GPL v2
43 Group:          Applications
44 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
45 # Source0-md5:  337d1a15ab1cb1d4ed423168b1eb7d7e
46 Source1:        %{name}.config
47 Source2:        %{name}-initrd.config
48 %{?with_altconfig:Source3:      %{cfgfile}}
49 Patch100:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-ash.patch
50 # Patch100-md5: 538d8cddbdfc449239b25a40bc8d1575
51 Patch101:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-date.patch
52 # Patch101-md5: bc381f9ceb3824141c968f5bc4353943
53 Patch102:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-iplink.patch
54 # Patch102-md5: 24686ec2750a8703feb57fc9c6aaed1d
55 Patch103:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-nc.patch
56 # Patch103-md5: 69eecaae5f812d08655dfdf34b60503f
57 Patch104:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-lzop.patch
58 # Patch104-md5: 14fb3bf7ffaba153b3cad385677b18c3
59 Patch105:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-zcat-no-ext.patch
60 # Patch105-md5: 158c8c4c73db6d920bdd7d4b9b65b2a5
61 Patch1:         %{name}-logconsole.patch
62 Patch2:         %{name}-printf-gettext.patch
63 Patch3:         %{name}-loadfont.patch
64 Patch4:         %{name}-kernel_headers.patch
65 Patch5:         %{name}-insmod-morearchs.patch
66 Patch6:         %{name}-dhcp.patch
67 Patch7:         %{name}-fix_64_archs.patch
68 Patch9:         %{name}-ash-export-PATH.patch
69 URL:            http://www.busybox.net/
70 BuildRequires:  gcc >= 3.2
71 BuildRequires:  perl-tools-pod
72 BuildRequires:  rpmbuild(macros) >= 1.652
73 %if %{with initrd} || %{with static}
74         %if %{with dietlibc}
75 BuildRequires:  dietlibc-static
76         %else
77                 %if %{with glibc}
78 BuildRequires:  glibc-static
79                 %else
80 %if "%{_target_base_arch}" != "%{_host_base_arch}"
81 BuildRequires:  cross%{_target_base_arch}-uClibc-static
82 %else
83         %ifarch ppc %{x8664}
84 BuildRequires:  uClibc-static >= 3:0.9.30.1
85         %else
86 BuildRequires:  uClibc-static >= 3:0.9.30.1
87         %endif
88 %endif
89                 %endif
90         %endif
91 %endif
92 %{?with_sh_prov:Provides:       /bin/sh}
93 %{?with_fileutl_prov:Provides:  fileutils}
94 %{?with_grep_prov:Provides:     grep}
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         _bindir         /bin
98
99 %if "%{_target_base_arch}" != "%{_host_base_arch}"
100         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
101 %else
102         %define CrossOpts %{nil}
103 %endif
104
105 %define         filterout_ld    -Wl,-z,(combreloc|relro)
106
107 %description
108 BusyBox combines tiny versions of many common UNIX utilities into a
109 single small executable. It provides minimalist replacements for most
110 of the utilities you usually find in fileutils, shellutils, findutils,
111 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
112 POSIX environment for any small or embedded system. The utilities in
113 BusyBox generally have fewer options than their full-featured GNU
114 cousins; however, the options that are included provide the expected
115 functionality and behave very much like their GNU counterparts.
116
117 BusyBox has been written with size-optimization and limited resources
118 in mind. It is also extremely modular so you can easily include or
119 exclude commands (or features) at compile time. This makes it easy to
120 customize your embedded systems. To create a working system, just add
121 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
122 ae).
123
124 %description -l pl.UTF-8
125 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
126 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
127 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
128 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
129 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
130 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
131 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
132 (np. elvis-tiny albo ae).
133
134 %description -l pt_BR.UTF-8
135 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
136 executável, fornecendo substitutos minimalistas para muitos dos
137 executáveis encontrados em pacotes como fileutils, shellutils,
138 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
139 em geral têm menos opções que os utilitários GNU, mas as opções
140 implementadas comportam-se de maneira similar aos equivalentes GNU.
141
142 %package static
143 Summary:        Static busybox
144 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
145 Group:          Applications
146
147 %description static
148 Static busybox.
149
150 %description static -l pl.UTF-8
151 Statycznie skonsolidowany busybox.
152
153 %package initrd
154 Summary:        Static busybox for initrd
155 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
156 Group:          Base
157 Conflicts:      geninitrd < 10000.20
158
159 %description initrd
160 Static busybox for initrd.
161
162 %description initrd -l pl.UTF-8
163 Statycznie skonsolidowany busybox dla initrd.
164
165 %prep
166 %setup -q
167 %patch100 -p1
168 %patch101 -p1
169 %patch102 -p1
170 %patch103 -p1
171 %patch1 -p1
172 %patch2 -p1
173 #%patch3 -p1
174 %patch4 -p1
175 %patch5 -p1
176 %patch6 -p1
177 %patch7 -p1
178 %patch9 -p1
179
180 %build
181 install -d built
182 %if %{with initrd}
183 install %{SOURCE2} .config
184 %{__make} oldconfig
185 %{__make} \
186         %{?with_verbose:V=1} \
187         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
188         LDFLAGS="%{rpmldflags} -static" \
189 %if %{with dietlibc}
190         LIBRARIES="-lrpc" \
191         CC="diet %{__cc}"
192 %else
193 %if %{with glibc}
194         %{CrossOpts} \
195         CC="%{__cc}"
196 %else
197         %if "%{_target_base_arch}" != "%{_host_base_arch}"
198         CROSS="%{_target_cpu}-uclibc-" \
199         %endif
200         CC="%{_target_cpu}-uclibc-gcc"
201 %endif
202 %endif
203
204 mv -f busybox built/busybox.initrd
205 %{__make} clean
206 %endif
207
208 %if %{with altconfig}
209 install %{SOURCE3} .config
210 %else
211 install %{SOURCE1} .config
212 %endif
213
214 %if %{with static}
215 %{__make} oldconfig
216 %{__make} \
217         %{?with_verbose:V=1} \
218         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
219         LDFLAGS="%{rpmldflags} -static" \
220 %if %{with dietlibc}
221         LIBRARIES="-lrpc" \
222         CC="diet %{__cc}"
223 %else
224 %if %{with glibc}
225         %{CrossOpts} \
226         CC="%{__cc}"
227 %else
228         %if "%{_target_base_arch}" != "%{_host_base_arch}"
229         CROSS="%{_target_cpu}-uclibc-" \
230         %endif
231         CC="%{_target_cpu}-uclibc-gcc"
232 %endif
233 %endif
234
235 mv -f busybox built/busybox.static
236 %{__make} clean
237 %endif
238
239 %if %{with dynamic}
240 %{__make} oldconfig
241 %{__make} \
242         %{?with_verbose:V=1} \
243         %{CrossOpts} \
244         CFLAGS_EXTRA="%{rpmcflags}" \
245         LDFLAGS="%{rpmldflags}" \
246         CC="%{__cc}"
247 %{__make} busybox.links docs/busybox.1
248 %endif
249
250 %install
251 rm -rf $RPM_BUILD_ROOT
252
253 %if %{with static}
254 install -d $RPM_BUILD_ROOT%{_bindir}
255 install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
256 %endif
257
258 %if %{with initrd}
259 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
260 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
261 %endif
262
263 %if %{with dynamic}
264 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
265 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
266 install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
267
268 # install links to busybox binary, when linkfl is defined
269 %if %{with linkfl}
270 %{__make} install \
271         PREFIX=$RPM_BUILD_ROOT
272 %else
273 install busybox $RPM_BUILD_ROOT%{_bindir}
274 %endif
275 %endif
276
277 %clean
278 rm -rf $RPM_BUILD_ROOT
279
280 %if %{with dynamic}
281 %files
282 %defattr(644,root,root,755)
283 %doc AUTHORS README .config
284
285 %if %{with linkfl}
286 %attr(755,root,root) /bin/*
287 %attr(755,root,root) /sbin/*
288 %attr(755,root,root) %{_bindir}/*
289 %attr(755,root,root) %{_sbindir}/*
290 %else
291 %attr(755,root,root) %{_bindir}/busybox
292 %endif
293
294 %{_libdir}/busybox
295 %{_mandir}/man1/busybox.1*
296 %endif
297
298 %if %{with static}
299 %files static
300 %defattr(644,root,root,755)
301 %attr(755,root,root) %{_bindir}/busybox.static
302 %endif
303
304 %if %{with initrd}
305 %files initrd
306 %defattr(644,root,root,755)
307 %attr(755,root,root) %{_libdir}/initrd/busybox
308 %endif
This page took 0.061538 seconds and 2 git commands to generate.