]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- updated insmod-morearchs patch
[packages/busybox.git] / busybox.spec
1 # TODO:
2 #       - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3 #       - make internal commands work even if busybox is not in /bin/busybox
4 #
5 # Conditional build:
6 # alternative busybox config file (replaces default one) you should
7 # define cfgfile macro, i.e.
8 #
9 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
10 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
11 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
12 # Options below are useful, when you want fileutils and grep providing.
13 # For example, ash package requires fileutils and grep.
14 %bcond_with     fileutl_prov    # adds fileutils providing
15 %bcond_with     grep_prov       # adds grep providing
16 # Option below is useful, when busybox is built with shell support.
17 %bcond_with     sh_prov         # adds /bin/sh providing
18 # WARNING! Shell, fileutils and grep providing may depend on config file!
19 # Fileutils, grep and shell provided with busybox have not such
20 # functionality as their GNU countenders.
21 #
22 %bcond_without  static          # don't build static version
23 %bcond_without  initrd          # don't build initrd version
24 #%%bcond_with   dietlibc        # build dietlibc-based initrd version
25 %bcond_with     glibc           # build glibc-based initrd version
26 #
27 %ifnarch %{ix86} %{x8664} ppc
28 %define with_glibc 1
29 %endif
30 %ifarch ppc
31 %undefine       with_dietlibc
32 %endif
33 Summary:        Set of common unix utils for embeded systems
34 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
35 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
36 Name:           busybox
37 Version:        1.2.0
38 Release:        1
39 License:        GPL
40 Group:          Applications
41 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
42 # Source0-md5:  0a3e5d47adc4debda22726295f40a6f2
43 Source1:        %{name}.config
44 Source2:        %{name}-initrd.config
45 %{?with_altconfig:Source3:      %{cfgfile}}
46 Patch0:         %{name}-fixes.patch
47 Patch1:         %{name}-logconsole.patch
48 Patch2:         %{name}-printf-gettext.patch
49 Patch3:         %{name}-loadfont.patch
50 Patch4:         %{name}-ash_exec.patch
51 Patch5:         %{name}-kernel_headers.patch
52 Patch6:         %{name}-insmod-morearchs.patch
53 Patch7:         %{name}-dhcp.patch
54 Patch8:         %{name}-fix_64_archs.patch
55 URL:            http://www.busybox.net/
56 BuildRequires:  gcc >= 3.2
57 %{?with_static:BuildRequires:   glibc-static}
58 %if %{with initrd}
59         %if %{with dietlibc}
60 BuildRequires:  dietlibc-static
61         %else
62                 %if %{with glibc}
63 BuildRequires:  glibc-static
64                 %else
65 %ifarch ppc %{x8664}
66 BuildRequires:  uClibc-static >= 2:0.9.29
67 %else
68 BuildRequires:  uClibc-static >= 2:0.9.21
69 %endif
70                 %endif
71         %endif
72 %endif
73 %{?with_fileutl_prov:Provides:  fileutils}
74 %{?with_grep_prov:Provides:     grep}
75 %{?with_sh_prov:Provides:       /bin/sh}
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78
79 %define         _bindir         /bin
80 %define         _initrd_bindir  /bin
81
82 %description
83 BusyBox combines tiny versions of many common UNIX utilities into a
84 single small executable. It provides minimalist replacements for most
85 of the utilities you usually find in fileutils, shellutils, findutils,
86 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
87 POSIX environment for any small or embedded system. The utilities in
88 BusyBox generally have fewer options than their full-featured GNU
89 cousins; however, the options that are included provide the expected
90 functionality and behave very much like their GNU counterparts.
91
92 BusyBox has been written with size-optimization and limited resources
93 in mind. It is also extremely modular so you can easily include or
94 exclude commands (or features) at compile time. This makes it easy to
95 customize your embedded systems. To create a working system, just add
96 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
97 ae).
98
99 %description -l pl
100 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
101 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
102 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
103 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
104 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
105 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
106 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
107 (np. elvis-tiny albo ae).
108
109 %description -l pt_BR
110 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
111 executável, fornecendo substitutos minimalistas para muitos dos
112 executáveis encontrados em pacotes como fileutils, shellutils,
113 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
114 em geral têm menos opções que os utilitários GNU, mas as opções
115 implementadas comportam-se de maneira similar aos equivalentes GNU.
116
117 %package static
118 Summary:        Static busybox
119 Summary(pl):    Statycznie skonsolidowany busybox
120 Group:          Applications
121
122 %description static
123 Static busybox.
124
125 %description static -l pl
126 Statycznie skonsolidowany busybox.
127
128 %package initrd
129 Summary:        Static busybox for initrd
130 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
131 Group:          Applications
132 Conflicts:      geninitrd < 3075
133
134 %description initrd
135 Static busybox for initrd.
136
137 %description initrd -l pl
138 Statycznie skonsolidowany busybox dla initrd.
139
140 %prep
141 %setup -q
142 %patch0 -p0
143 %patch1 -p1
144 %patch2 -p1
145 %patch3 -p1
146 %patch4 -p1
147 %patch5 -p1
148 %patch6 -p1
149 %patch7 -p1
150 %patch8 -p1
151
152 %build
153 install %{SOURCE1} .config
154
155 %if %{with initrd}
156 install %{SOURCE2} .config
157 %{__make} oldconfig
158 %{__make} \
159         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
160         LDFLAGS="%{rpmldflags} -static" \
161 %if %{with dietlibc}
162         LIBRARIES="-lrpc" \
163         CC="diet gcc"
164 %else
165 %if %{with glibc}
166         CC="%{__cc}"
167 %else
168         CC="%{_target_cpu}-uclibc-gcc"
169 %endif
170 %endif
171
172 mv -f busybox busybox.initrd
173 %{__make} clean
174 install %{SOURCE1} .config
175 %endif
176
177 %if %{with altconfig}
178 install %{SOURCE3} .config
179 %endif
180
181 %if %{with static}
182 %{__make} oldconfig
183 %{__make} \
184         CFLAGS_EXTRA="%{rpmcflags}" \
185         LDFLAGS="%{rpmldflags} -static" \
186         CC="%{__cc}"
187 mv -f busybox busybox.static
188 %{__make} clean
189 %endif
190
191 %{__make} oldconfig
192 %{__make} \
193         CFLAGS_EXTRA="%{rpmcflags}" \
194         LDFLAGS="%{rpmldflags}" \
195         CC="%{__cc}"
196
197 %install
198 rm -rf $RPM_BUILD_ROOT
199 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
200
201 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
202 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
203
204 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
205 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
206 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
207
208 # install links to busybox binary, when linkfl is defined
209 %if %{with linkfl}
210 %{__make} install \
211         PREFIX=$RPM_BUILD_ROOT
212 %else
213 install busybox $RPM_BUILD_ROOT%{_bindir}
214 %endif
215
216 %clean
217 rm -rf $RPM_BUILD_ROOT
218
219 %files
220 %defattr(644,root,root,755)
221 %doc AUTHORS README .config
222
223 %if %{with linkfl}
224 %attr(755,root,root) /bin/*
225 %attr(755,root,root) /sbin/*
226 %attr(755,root,root) %{_bindir}/*
227 %attr(755,root,root) %{_sbindir}/*
228 %else
229 %attr(755,root,root) %{_bindir}/busybox
230 %endif
231
232 %{_libdir}/busybox
233 %{_mandir}/man1/*
234
235 %if %{with static}
236 %files static
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{_bindir}/busybox.static
239 %endif
240
241 %if %{with initrd}
242 %files initrd
243 %defattr(644,root,root,755)
244 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
245 %endif
This page took 0.067637 seconds and 3 git commands to generate.