]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- rel 3; show usage help in initrd applets when wrongly called
[packages/busybox.git] / busybox.spec
1 # TODO:
2 # - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3 #   if it still serves a purpose
4 # - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5 # - make internal commands work even if busybox is not in /bin/busybox (initrd)
6 #   or when /proc is not mounted (static / normal)
7 #
8 # Conditional build:
9 # alternative busybox config file (replaces default one) you should
10 # define cfgfile macro, i.e.
11 #
12 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
13 #
14 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
15 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
16 %bcond_without  static          # don't build static version
17 %bcond_without  initrd          # don't build initrd version
18 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
19 %bcond_with     glibc           # build glibc-based initrd and static versions
20 %bcond_with     verbose         # verbose build
21 # Options below are useful, when you want fileutils and grep providing.
22 # For example, ash package requires fileutils and grep.
23 %bcond_with     fileutl_prov    # adds fileutils providing
24 %bcond_with     grep_prov       # adds grep providing
25 # Option below is useful, when busybox is built with shell support.
26 %bcond_with     sh_prov         # adds /bin/sh providing
27 # WARNING! Shell, fileutils and grep providing may depend on config file!
28 # Fileutils, grep and shell provided with busybox have not such
29 # functionality as their GNU countenders.
30 #
31 %ifnarch %{ix86} %{x8664} ppc
32 %define with_glibc 1
33 %endif
34 Summary:        Set of common Unix utilities for embeded systems
35 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
36 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
37 Name:           busybox
38 # stable line only
39 Version:        1.18.3
40 Release:        3
41 License:        GPL
42 Group:          Applications
43 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
44 # Source0-md5:  660af4d44661d32b22025a66f4f78df2
45 Source1:        %{name}.config
46 Source2:        %{name}-initrd.config
47 %{?with_altconfig:Source3:      %{cfgfile}}
48 Patch100:       busybox-1.18.3-buildsys.patch
49 Patch101:       busybox-1.18.3-modutils24.patch
50 Patch102:       busybox-1.18.3-wget.patch
51 Patch1:         %{name}-logconsole.patch
52 Patch2:         %{name}-printf-gettext.patch
53 Patch3:         %{name}-loadfont.patch
54 Patch4:         %{name}-kernel_headers.patch
55 Patch5:         %{name}-insmod-morearchs.patch
56 Patch6:         %{name}-dhcp.patch
57 Patch7:         %{name}-fix_64_archs.patch
58 Patch9:         %{name}-ash-export-PATH.patch
59 URL:            http://www.busybox.net/
60 BuildRequires:  gcc >= 3.2
61 BuildRequires:  perl-tools-pod
62 BuildRequires:  rpmbuild(macros) >= 1.333
63 %if %{with initrd} || %{with static}
64         %if %{with dietlibc}
65 BuildRequires:  dietlibc-static
66         %else
67                 %if %{with glibc}
68 BuildRequires:  glibc-static
69                 %else
70 %if "%{_target_base_arch}" != "%{_arch}"
71 BuildRequires:  cross%{_target_base_arch}-uClibc-static
72 %else
73         %ifarch ppc %{x8664}
74 BuildRequires:  uClibc-static >= 3:0.9.30.1
75         %else
76 BuildRequires:  uClibc-static >= 3:0.9.30.1
77         %endif
78 %endif
79                 %endif
80         %endif
81 %endif
82 %{?with_sh_prov:Provides:       /bin/sh}
83 %{?with_fileutl_prov:Provides:  fileutils}
84 %{?with_grep_prov:Provides:     grep}
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %define         _bindir         /bin
88
89 %if "%{_target_base_arch}" != "%{_arch}"
90         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
91 %else
92         %define CrossOpts %{nil}
93 %endif
94
95 %define         filterout_ld    -Wl,-z,(combreloc|relro)
96
97 %description
98 BusyBox combines tiny versions of many common UNIX utilities into a
99 single small executable. It provides minimalist replacements for most
100 of the utilities you usually find in fileutils, shellutils, findutils,
101 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
102 POSIX environment for any small or embedded system. The utilities in
103 BusyBox generally have fewer options than their full-featured GNU
104 cousins; however, the options that are included provide the expected
105 functionality and behave very much like their GNU counterparts.
106
107 BusyBox has been written with size-optimization and limited resources
108 in mind. It is also extremely modular so you can easily include or
109 exclude commands (or features) at compile time. This makes it easy to
110 customize your embedded systems. To create a working system, just add
111 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
112 ae).
113
114 %description -l pl.UTF-8
115 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
116 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
117 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
118 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
119 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
120 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
121 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
122 (np. elvis-tiny albo ae).
123
124 %description -l pt_BR.UTF-8
125 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
126 executável, fornecendo substitutos minimalistas para muitos dos
127 executáveis encontrados em pacotes como fileutils, shellutils,
128 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
129 em geral têm menos opções que os utilitários GNU, mas as opções
130 implementadas comportam-se de maneira similar aos equivalentes GNU.
131
132 %package static
133 Summary:        Static busybox
134 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
135 Group:          Applications
136
137 %description static
138 Static busybox.
139
140 %description static -l pl.UTF-8
141 Statycznie skonsolidowany busybox.
142
143 %package initrd
144 Summary:        Static busybox for initrd
145 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
146 Group:          Base
147 Conflicts:      geninitrd < 10000.20
148
149 %description initrd
150 Static busybox for initrd.
151
152 %description initrd -l pl.UTF-8
153 Statycznie skonsolidowany busybox dla initrd.
154
155 %prep
156 %setup -q
157 %patch100 -p1
158 %patch101 -p1
159 %patch102 -p1
160 %patch1 -p1
161 %patch2 -p1
162 #%patch3 -p1
163 %patch4 -p1
164 %patch5 -p1
165 %patch6 -p1
166 %patch7 -p1
167 %patch9 -p1
168
169 %build
170 install -d built
171 %if %{with initrd}
172 install %{SOURCE2} .config
173 %{__make} oldconfig
174 %{__make} \
175         %{?with_verbose:V=1} \
176         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
177         LDFLAGS="%{ld_rpmldflags} -static" \
178 %if %{with dietlibc}
179         LIBRARIES="-lrpc" \
180         CC="diet %{__cc}"
181 %else
182 %if %{with glibc}
183         %{CrossOpts} \
184         CC="%{__cc}"
185 %else
186         %if "%{_target_base_arch}" != "%{_arch}"
187         CROSS="%{_target_cpu}-uclibc-" \
188         %endif
189         CC="%{_target_cpu}-uclibc-gcc"
190 %endif
191 %endif
192
193 mv -f busybox built/busybox.initrd
194 %{__make} clean
195 %endif
196
197
198 %if %{with altconfig}
199 install %{SOURCE3} .config
200 %else
201 install %{SOURCE1} .config
202 %endif
203
204 %if %{with static}
205 %{__make} oldconfig
206 %{__make} \
207         %{?with_verbose:V=1} \
208         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
209         LDFLAGS="%{ld_rpmldflags} -static" \
210 %if %{with dietlibc}
211         LIBRARIES="-lrpc" \
212         CC="diet %{__cc}"
213 %else
214 %if %{with glibc}
215         %{CrossOpts} \
216         CC="%{__cc}"
217 %else
218         %if "%{_target_base_arch}" != "%{_arch}"
219         CROSS="%{_target_cpu}-uclibc-" \
220         %endif
221         CC="%{_target_cpu}-uclibc-gcc"
222 %endif
223 %endif
224
225 mv -f busybox built/busybox.static
226 %{__make} clean
227 %endif
228
229 %{__make} oldconfig
230 %{__make} \
231         %{?with_verbose:V=1} \
232         %{CrossOpts} \
233         CFLAGS_EXTRA="%{rpmcflags}" \
234         LDFLAGS="%{ld_rpmldflags}" \
235         CC="%{__cc}"
236 %{__make} busybox.links docs/busybox.1
237
238 %install
239 rm -rf $RPM_BUILD_ROOT
240 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
241
242 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
243 %if %{with initrd}
244 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
245 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
246 %endif
247
248 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
249 install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
250
251 # install links to busybox binary, when linkfl is defined
252 %if %{with linkfl}
253 %{__make} install \
254         PREFIX=$RPM_BUILD_ROOT
255 %else
256 install busybox $RPM_BUILD_ROOT%{_bindir}
257 %endif
258
259 %clean
260 rm -rf $RPM_BUILD_ROOT
261
262 %files
263 %defattr(644,root,root,755)
264 %doc AUTHORS README .config
265
266 %if %{with linkfl}
267 %attr(755,root,root) %{_bindir}/*
268 %attr(755,root,root) /sbin/*
269 %attr(755,root,root) %{_bindir}/*
270 %attr(755,root,root) %{_sbindir}/*
271 %else
272 %attr(755,root,root) %{_bindir}/busybox
273 %endif
274
275 %{_libdir}/busybox
276 %{_mandir}/man1/*
277
278 %if %{with static}
279 %files static
280 %defattr(644,root,root,755)
281 %attr(755,root,root) %{_bindir}/busybox.static
282 %endif
283
284 %if %{with initrd}
285 %files initrd
286 %defattr(644,root,root,755)
287 %attr(755,root,root) %{_libdir}/initrd/busybox
288 %endif
This page took 0.074434 seconds and 3 git commands to generate.