]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- up to 1.4.2
[packages/busybox.git] / busybox.spec
1 # TODO:
2 #       - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3 #       - make internal commands work even if busybox is not in /bin/busybox (initrd)
4 #         or when /proc is not mounted (static / normal)
5 #
6 # Conditional build:
7 # alternative busybox config file (replaces default one) you should
8 # define cfgfile macro, i.e.
9 #
10 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
11 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
12 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
13 # Options below are useful, when you want fileutils and grep providing.
14 # For example, ash package requires fileutils and grep.
15 %bcond_with     fileutl_prov    # adds fileutils providing
16 %bcond_with     grep_prov       # adds grep providing
17 # Option below is useful, when busybox is built with shell support.
18 %bcond_with     sh_prov         # adds /bin/sh providing
19 # WARNING! Shell, fileutils and grep providing may depend on config file!
20 # Fileutils, grep and shell provided with busybox have not such
21 # functionality as their GNU countenders.
22 #
23 %bcond_without  static          # don't build static version
24 %bcond_without  initrd          # don't build initrd version
25 #%%bcond_with   dietlibc        # build dietlibc-based initrd version
26 %bcond_with     glibc           # build glibc-based initrd version
27 #
28 %ifnarch %{ix86} %{x8664} ppc sparc64
29 %define with_glibc 1
30 %endif
31 %ifarch ppc
32 %undefine       with_dietlibc
33 %endif
34 Summary:        Set of common unix utils for embeded systems
35 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
36 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
37 Name:           busybox
38 Version:        1.4.2
39 Release:        1
40 License:        GPL
41 Group:          Applications
42 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
43 # Source0-md5:  b4c61fb15642be9dde20e8493788c585
44 Source1:        %{name}.config
45 Source2:        %{name}-initrd.config
46 %{?with_altconfig:Source3:      %{cfgfile}}
47 Patch1:         %{name}-logconsole.patch
48 Patch2:         %{name}-printf-gettext.patch
49 Patch3:         %{name}-loadfont.patch
50 Patch4:         %{name}-ash_exec.patch
51 Patch5:         %{name}-kernel_headers.patch
52 Patch6:         %{name}-insmod-morearchs.patch
53 Patch7:         %{name}-dhcp.patch
54 Patch8:         %{name}-fix_64_archs.patch
55 Patch9:         %{name}-noerror.patch
56 URL:            http://www.busybox.net/
57 BuildRequires:  gcc >= 3.2
58 BuildRequires:  perl-tools-pod
59 BuildRequires:  rpmbuild(macros) >= 1.333
60 %{?with_static:BuildRequires:   glibc-static}
61 %if %{with initrd}
62         %if %{with dietlibc}
63 BuildRequires:  dietlibc-static
64         %else
65                 %if %{with glibc}
66 BuildRequires:  glibc-static
67                 %else
68 %if "%{_target_base_arch}" != "%{_arch}"
69 BuildRequires:  cross%{_target_base_arch}-uClibc-static
70 %else
71         %ifarch ppc %{x8664}
72 BuildRequires:  uClibc-static >= 2:0.9.29
73         %else
74 BuildRequires:  uClibc-static >= 2:0.9.21
75         %endif
76 %endif
77                 %endif
78         %endif
79 %endif
80 %{?with_fileutl_prov:Provides:  fileutils}
81 %{?with_grep_prov:Provides:     grep}
82 %{?with_sh_prov:Provides:       /bin/sh}
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %define         _bindir         /bin
86 %define         _initrd_bindir  /bin
87
88 %if "%{_target_base_arch}" != "%{_arch}"
89         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
90 %else
91         %define CrossOpts %{nil}
92 %endif
93
94 %description
95 BusyBox combines tiny versions of many common UNIX utilities into a
96 single small executable. It provides minimalist replacements for most
97 of the utilities you usually find in fileutils, shellutils, findutils,
98 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
99 POSIX environment for any small or embedded system. The utilities in
100 BusyBox generally have fewer options than their full-featured GNU
101 cousins; however, the options that are included provide the expected
102 functionality and behave very much like their GNU counterparts.
103
104 BusyBox has been written with size-optimization and limited resources
105 in mind. It is also extremely modular so you can easily include or
106 exclude commands (or features) at compile time. This makes it easy to
107 customize your embedded systems. To create a working system, just add
108 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
109 ae).
110
111 %description -l pl.UTF-8
112 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
113 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
114 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
115 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
116 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
117 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
118 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
119 (np. elvis-tiny albo ae).
120
121 %description -l pt_BR.UTF-8
122 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
123 executável, fornecendo substitutos minimalistas para muitos dos
124 executáveis encontrados em pacotes como fileutils, shellutils,
125 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
126 em geral têm menos opções que os utilitários GNU, mas as opções
127 implementadas comportam-se de maneira similar aos equivalentes GNU.
128
129 %package static
130 Summary:        Static busybox
131 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
132 Group:          Applications
133
134 %description static
135 Static busybox.
136
137 %description static -l pl.UTF-8
138 Statycznie skonsolidowany busybox.
139
140 %package initrd
141 Summary:        Static busybox for initrd
142 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
143 Group:          Applications
144 Conflicts:      geninitrd < 3075
145
146 %description initrd
147 Static busybox for initrd.
148
149 %description initrd -l pl.UTF-8
150 Statycznie skonsolidowany busybox dla initrd.
151
152 %prep
153 %setup -q
154 %patch1 -p1
155 %patch2 -p1
156 %patch3 -p1
157 %patch4 -p1
158 %patch5 -p1
159 %patch6 -p1
160 %patch7 -p1
161 %patch8 -p1
162 %patch9 -p1
163
164 %build
165 install -d built
166 %if %{with initrd}
167 install %{SOURCE2} .config
168 %{__make} oldconfig
169 %{__make} \
170         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
171         LDFLAGS="%{ld_rpmldflags} -static" \
172 %if %{with dietlibc}
173         LIBRARIES="-lrpc" \
174         CC="diet gcc"
175 %else
176 %if %{with glibc}
177         %{CrossOpts} \
178         CC="%{__cc}"
179 %else
180     %if "%{_target_base_arch}" != "%{_arch}"
181         CROSS="%{_target_cpu}-uclibc-" \
182     %endif
183         CC="%{_target_cpu}-uclibc-gcc"
184 %endif
185 %endif
186
187 mv -f busybox built/busybox.initrd
188 %{__make} clean
189 %endif
190
191
192 %if %{with altconfig}
193 install %{SOURCE3} .config
194 %else
195 install %{SOURCE1} .config
196 %endif
197
198 %if %{with static}
199 %{__make} oldconfig
200 %{__make} \
201         %{CrossOpts} \
202         CFLAGS_EXTRA="%{rpmcflags}" \
203         LDFLAGS="%{ld_rpmldflags} -static" \
204         CC="%{__cc}"
205 mv -f busybox built/busybox.static
206 %{__make} clean
207 %endif
208
209 %{__make} oldconfig
210 %{__make} \
211         %{CrossOpts} \
212         CFLAGS_EXTRA="%{rpmcflags}" \
213         LDFLAGS="%{ld_rpmldflags}" \
214         CC="%{__cc}"
215 %{__make} busybox.links docs/BusyBox.1
216
217 %install
218 rm -rf $RPM_BUILD_ROOT
219 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
220
221 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
222 %{?with_initrd:install built/busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
223
224 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
225 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
226 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
227
228 # install links to busybox binary, when linkfl is defined
229 %if %{with linkfl}
230 %{__make} install \
231         PREFIX=$RPM_BUILD_ROOT
232 %else
233 install busybox $RPM_BUILD_ROOT%{_bindir}
234 %endif
235
236 %clean
237 rm -rf $RPM_BUILD_ROOT
238
239 %files
240 %defattr(644,root,root,755)
241 %doc AUTHORS README .config
242
243 %if %{with linkfl}
244 %attr(755,root,root) /bin/*
245 %attr(755,root,root) /sbin/*
246 %attr(755,root,root) %{_bindir}/*
247 %attr(755,root,root) %{_sbindir}/*
248 %else
249 %attr(755,root,root) %{_bindir}/busybox
250 %endif
251
252 %{_libdir}/busybox
253 %{_mandir}/man1/*
254
255 %if %{with static}
256 %files static
257 %defattr(644,root,root,755)
258 %attr(755,root,root) %{_bindir}/busybox.static
259 %endif
260
261 %if %{with initrd}
262 %files initrd
263 %defattr(644,root,root,755)
264 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
265 %endif
This page took 0.042777 seconds and 3 git commands to generate.