]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- BR uClibc-static >= 3:0.9.30.1 (it has combreloc|relro filtering built in)
[packages/busybox.git] / busybox.spec
1 # TODO:
2 #       - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3 #       - make internal commands work even if busybox is not in /bin/busybox (initrd)
4 #         or when /proc is not mounted (static / normal)
5 #
6 # Conditional build:
7 # alternative busybox config file (replaces default one) you should
8 # define cfgfile macro, i.e.
9 #
10 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
11 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
12 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
13 %bcond_without  static          # don't build static version
14 %bcond_without  initrd          # don't build initrd version
15 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
16 %bcond_with     glibc           # build glibc-based initrd and static versions
17 %bcond_with     verbose         # verbose build
18 #
19 # Options below are useful, when you want fileutils and grep providing.
20 # For example, ash package requires fileutils and grep.
21 %bcond_with     fileutl_prov    # adds fileutils providing
22 %bcond_with     grep_prov       # adds grep providing
23 # Option below is useful, when busybox is built with shell support.
24 %bcond_with     sh_prov         # adds /bin/sh providing
25 # WARNING! Shell, fileutils and grep providing may depend on config file!
26 # Fileutils, grep and shell provided with busybox have not such
27 # functionality as their GNU countenders.
28 #
29 %ifnarch %{ix86} %{x8664} ppc
30 %define with_glibc 1
31 %endif
32 Summary:        Set of common Unix utilities for embeded systems
33 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
34 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
35 Name:           busybox
36 # stable line only
37 Version:        1.13.3
38 Release:        0.1
39 License:        GPL
40 Group:          Applications
41 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
42 # Source0-md5:  0cde6d2790e790837d6d7e82faae3ca1
43 Source1:        %{name}.config
44 Source2:        %{name}-initrd.config
45 %{?with_altconfig:Source3:      %{cfgfile}}
46 Patch1:         %{name}-logconsole.patch
47 Patch2:         %{name}-printf-gettext.patch
48 Patch3:         %{name}-loadfont.patch
49 Patch4:         %{name}-kernel_headers.patch
50 Patch5:         %{name}-insmod-morearchs.patch
51 Patch6:         %{name}-dhcp.patch
52 Patch7:         %{name}-fix_64_archs.patch
53 Patch9:         %{name}-ash-export-PATH.patch
54 URL:            http://www.busybox.net/
55 BuildRequires:  gcc >= 3.2
56 BuildRequires:  perl-tools-pod
57 BuildRequires:  rpmbuild(macros) >= 1.333
58 %if %{with initrd} || %{with static}
59         %if %{with dietlibc}
60 BuildRequires:  dietlibc-static
61         %else
62                 %if %{with glibc}
63 BuildRequires:  glibc-static
64                 %else
65 %if "%{_target_base_arch}" != "%{_arch}"
66 BuildRequires:  cross%{_target_base_arch}-uClibc-static
67 %else
68         %ifarch ppc %{x8664}
69 BuildRequires:  uClibc-static >= 3:0.9.30.1
70         %else
71 BuildRequires:  uClibc-static >= 3:0.9.30.1
72         %endif
73 %endif
74                 %endif
75         %endif
76 %endif
77 %{?with_fileutl_prov:Provides:  fileutils}
78 %{?with_grep_prov:Provides:     grep}
79 %{?with_sh_prov:Provides:       /bin/sh}
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %define         _bindir         /bin
83 %define         _initrd_bindir  /bin
84
85 %if "%{_target_base_arch}" != "%{_arch}"
86         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
87 %else
88         %define CrossOpts %{nil}
89 %endif
90
91 %description
92 BusyBox combines tiny versions of many common UNIX utilities into a
93 single small executable. It provides minimalist replacements for most
94 of the utilities you usually find in fileutils, shellutils, findutils,
95 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
96 POSIX environment for any small or embedded system. The utilities in
97 BusyBox generally have fewer options than their full-featured GNU
98 cousins; however, the options that are included provide the expected
99 functionality and behave very much like their GNU counterparts.
100
101 BusyBox has been written with size-optimization and limited resources
102 in mind. It is also extremely modular so you can easily include or
103 exclude commands (or features) at compile time. This makes it easy to
104 customize your embedded systems. To create a working system, just add
105 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
106 ae).
107
108 %description -l pl.UTF-8
109 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
110 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
111 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
112 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
113 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
114 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
115 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
116 (np. elvis-tiny albo ae).
117
118 %description -l pt_BR.UTF-8
119 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
120 executável, fornecendo substitutos minimalistas para muitos dos
121 executáveis encontrados em pacotes como fileutils, shellutils,
122 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
123 em geral têm menos opções que os utilitários GNU, mas as opções
124 implementadas comportam-se de maneira similar aos equivalentes GNU.
125
126 %package static
127 Summary:        Static busybox
128 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
129 Group:          Applications
130
131 %description static
132 Static busybox.
133
134 %description static -l pl.UTF-8
135 Statycznie skonsolidowany busybox.
136
137 %package initrd
138 Summary:        Static busybox for initrd
139 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
140 Group:          Applications
141 Conflicts:      geninitrd < 3075
142
143 %description initrd
144 Static busybox for initrd.
145
146 %description initrd -l pl.UTF-8
147 Statycznie skonsolidowany busybox dla initrd.
148
149 %prep
150 %setup -q
151 %patch1 -p1
152 %patch2 -p1
153 %patch3 -p1
154 %patch4 -p1
155 %patch5 -p1
156 %patch6 -p1
157 %patch7 -p1
158 %patch9 -p1
159
160 %build
161 install -d built
162 %if %{with initrd}
163 install %{SOURCE2} .config
164 %{__make} oldconfig
165 %{__make} \
166         %{?with_verbose:V=1} \
167         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
168         LDFLAGS="%{ld_rpmldflags} -static" \
169 %if %{with dietlibc}
170         LIBRARIES="-lrpc" \
171         CC="diet gcc"
172 %else
173 %if %{with glibc}
174         %{CrossOpts} \
175         CC="%{__cc}"
176 %else
177     %if "%{_target_base_arch}" != "%{_arch}"
178         CROSS="%{_target_cpu}-uclibc-" \
179     %endif
180         CC="%{_target_cpu}-uclibc-gcc"
181 %endif
182 %endif
183
184 mv -f busybox built/busybox.initrd
185 %{__make} clean
186 %endif
187
188
189 %if %{with altconfig}
190 install %{SOURCE3} .config
191 %else
192 install %{SOURCE1} .config
193 %endif
194
195 %if %{with static}
196 %{__make} oldconfig
197 %{__make} \
198         %{?with_verbose:V=1} \
199         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
200         LDFLAGS="%{ld_rpmldflags} -static" \
201 %if %{with dietlibc}
202         LIBRARIES="-lrpc" \
203         CC="diet gcc"
204 %else
205 %if %{with glibc}
206         %{CrossOpts} \
207         CC="%{__cc}"
208 %else
209     %if "%{_target_base_arch}" != "%{_arch}"
210         CROSS="%{_target_cpu}-uclibc-" \
211     %endif
212         CC="%{_target_cpu}-uclibc-gcc"
213 %endif
214 %endif
215
216 mv -f busybox built/busybox.static
217 %{__make} clean
218 %endif
219
220 %{__make} oldconfig
221 %{__make} \
222         %{?with_verbose:V=1} \
223         %{CrossOpts} \
224         CFLAGS_EXTRA="%{rpmcflags}" \
225         LDFLAGS="%{ld_rpmldflags}" \
226         CC="%{__cc}"
227 %{__make} busybox.links docs/BusyBox.1
228
229 %install
230 rm -rf $RPM_BUILD_ROOT
231 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
232
233 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
234 %{?with_initrd:install built/busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
235
236 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
237 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
238 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
239
240 # install links to busybox binary, when linkfl is defined
241 %if %{with linkfl}
242 %{__make} install \
243         PREFIX=$RPM_BUILD_ROOT
244 %else
245 install busybox $RPM_BUILD_ROOT%{_bindir}
246 %endif
247
248 %clean
249 rm -rf $RPM_BUILD_ROOT
250
251 %files
252 %defattr(644,root,root,755)
253 %doc AUTHORS README .config
254
255 %if %{with linkfl}
256 %attr(755,root,root) /bin/*
257 %attr(755,root,root) /sbin/*
258 %attr(755,root,root) %{_bindir}/*
259 %attr(755,root,root) %{_sbindir}/*
260 %else
261 %attr(755,root,root) %{_bindir}/busybox
262 %endif
263
264 %{_libdir}/busybox
265 %{_mandir}/man1/*
266
267 %if %{with static}
268 %files static
269 %defattr(644,root,root,755)
270 %attr(755,root,root) %{_bindir}/busybox.static
271 %endif
272
273 %if %{with initrd}
274 %files initrd
275 %defattr(644,root,root,755)
276 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
277 %endif
This page took 0.051821 seconds and 3 git commands to generate.