]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
19918fda34ebcf84bdf397e8d00d56a3a8404783
[packages/busybox.git] / busybox.spec
1 # TODO:
2 # - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3 #   if it still serves a purpose
4 # - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5 # - make internal commands work even if busybox is not in /bin/busybox (initrd)
6 #   or when /proc is not mounted (static / normal)
7 #
8 # Conditional build:
9 # alternative busybox config file (replaces default one) you should
10 # define cfgfile macro, i.e.
11 #
12 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
13 #
14 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
15 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
16 %bcond_without  dynamic         # don't build dynamic (base) version
17 %bcond_without  static          # don't build static version
18 %bcond_without  initrd          # don't build initrd version
19 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
20 %bcond_with     glibc           # build glibc-based initrd and static versions
21 %bcond_with     verbose         # verbose build
22 # Options below are useful, when you want fileutils and grep providing.
23 # For example, ash package requires fileutils and grep.
24 %bcond_with     fileutl_prov    # adds fileutils providing
25 %bcond_with     grep_prov       # adds grep providing
26 # Option below is useful, when busybox is built with shell support.
27 %bcond_with     sh_prov         # adds /bin/sh providing
28 # WARNING! Shell, fileutils and grep providing may depend on config file!
29 # Fileutils, grep and shell provided with busybox have not such
30 # functionality as their GNU countenders.
31 #
32 %ifnarch %{ix86} %{x8664} ppc
33 %define with_glibc 1
34 %endif
35 Summary:        Set of common Unix utilities for embeded systems
36 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
37 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
38 Name:           busybox
39 # stable line only
40 Version:        1.19.3
41 Release:        1
42 License:        GPL v2
43 Group:          Applications
44 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
45 # Source0-md5:  c3938e1ac59602387009bbf1dd1af7f6
46 Source1:        %{name}.config
47 Source2:        %{name}-initrd.config
48 %{?with_altconfig:Source3:      %{cfgfile}}
49 Patch100:       http://busybox.net/downloads/fixes-1.19.3/busybox-1.19.3-getty.patch
50 # Patch100-md5: 5ed72ca85b8fba4598d64a550210b31f
51 Patch101:       http://busybox.net/downloads/fixes-1.19.3/busybox-1.19.3-modinfo.patch
52 # Patch101-md5: 41636628e481f22b8774b6bee1eebfb1
53 Patch102:       http://busybox.net/downloads/fixes-1.19.3/busybox-1.19.3-wget.patch
54 # Patch102-md5: cb48bffc0e1e3be527cd4ff67324a2a2
55 Patch0:         %{name}-git.patch
56 Patch1:         %{name}-logconsole.patch
57 Patch2:         %{name}-printf-gettext.patch
58 Patch3:         %{name}-loadfont.patch
59 Patch4:         %{name}-kernel_headers.patch
60 Patch5:         %{name}-insmod-morearchs.patch
61 Patch6:         %{name}-dhcp.patch
62 Patch7:         %{name}-fix_64_archs.patch
63 Patch9:         %{name}-ash-export-PATH.patch
64 URL:            http://www.busybox.net/
65 BuildRequires:  gcc >= 3.2
66 BuildRequires:  perl-tools-pod
67 BuildRequires:  rpmbuild(macros) >= 1.333
68 %if %{with initrd} || %{with static}
69         %if %{with dietlibc}
70 BuildRequires:  dietlibc-static
71         %else
72                 %if %{with glibc}
73 BuildRequires:  glibc-static
74                 %else
75 %if "%{_target_base_arch}" != "%{_arch}"
76 BuildRequires:  cross%{_target_base_arch}-uClibc-static
77 %else
78         %ifarch ppc %{x8664}
79 BuildRequires:  uClibc-static >= 3:0.9.30.1
80         %else
81 BuildRequires:  uClibc-static >= 3:0.9.30.1
82         %endif
83 %endif
84                 %endif
85         %endif
86 %endif
87 %{?with_sh_prov:Provides:       /bin/sh}
88 %{?with_fileutl_prov:Provides:  fileutils}
89 %{?with_grep_prov:Provides:     grep}
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         _bindir         /bin
93
94 %if "%{_target_base_arch}" != "%{_arch}"
95         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
96 %else
97         %define CrossOpts %{nil}
98 %endif
99
100 %define         filterout_ld    -Wl,-z,(combreloc|relro)
101
102 %description
103 BusyBox combines tiny versions of many common UNIX utilities into a
104 single small executable. It provides minimalist replacements for most
105 of the utilities you usually find in fileutils, shellutils, findutils,
106 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
107 POSIX environment for any small or embedded system. The utilities in
108 BusyBox generally have fewer options than their full-featured GNU
109 cousins; however, the options that are included provide the expected
110 functionality and behave very much like their GNU counterparts.
111
112 BusyBox has been written with size-optimization and limited resources
113 in mind. It is also extremely modular so you can easily include or
114 exclude commands (or features) at compile time. This makes it easy to
115 customize your embedded systems. To create a working system, just add
116 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
117 ae).
118
119 %description -l pl.UTF-8
120 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
121 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
122 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
123 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
124 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
125 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
126 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
127 (np. elvis-tiny albo ae).
128
129 %description -l pt_BR.UTF-8
130 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
131 executável, fornecendo substitutos minimalistas para muitos dos
132 executáveis encontrados em pacotes como fileutils, shellutils,
133 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
134 em geral têm menos opções que os utilitários GNU, mas as opções
135 implementadas comportam-se de maneira similar aos equivalentes GNU.
136
137 %package static
138 Summary:        Static busybox
139 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
140 Group:          Applications
141
142 %description static
143 Static busybox.
144
145 %description static -l pl.UTF-8
146 Statycznie skonsolidowany busybox.
147
148 %package initrd
149 Summary:        Static busybox for initrd
150 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
151 Group:          Base
152 Conflicts:      geninitrd < 10000.20
153
154 %description initrd
155 Static busybox for initrd.
156
157 %description initrd -l pl.UTF-8
158 Statycznie skonsolidowany busybox dla initrd.
159
160 %prep
161 %setup -q
162 %patch100 -p1
163 %patch101 -p1
164 %patch102 -p1
165 %patch0 -p1
166 %patch1 -p1
167 %patch2 -p1
168 #%patch3 -p1
169 %patch4 -p1
170 %patch5 -p1
171 %patch6 -p1
172 %patch7 -p1
173 %patch9 -p1
174
175 %build
176 install -d built
177 %if %{with initrd}
178 install %{SOURCE2} .config
179 %{__make} oldconfig
180 %{__make} \
181         %{?with_verbose:V=1} \
182         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
183         LDFLAGS="%{rpmldflags} -static" \
184 %if %{with dietlibc}
185         LIBRARIES="-lrpc" \
186         CC="diet %{__cc}"
187 %else
188 %if %{with glibc}
189         %{CrossOpts} \
190         CC="%{__cc}"
191 %else
192         %if "%{_target_base_arch}" != "%{_arch}"
193         CROSS="%{_target_cpu}-uclibc-" \
194         %endif
195         CC="%{_target_cpu}-uclibc-gcc"
196 %endif
197 %endif
198
199 mv -f busybox built/busybox.initrd
200 %{__make} clean
201 %endif
202
203 %if %{with altconfig}
204 install %{SOURCE3} .config
205 %else
206 install %{SOURCE1} .config
207 %endif
208
209 %if %{with static}
210 %{__make} oldconfig
211 %{__make} \
212         %{?with_verbose:V=1} \
213         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
214         LDFLAGS="%{rpmldflags} -static" \
215 %if %{with dietlibc}
216         LIBRARIES="-lrpc" \
217         CC="diet %{__cc}"
218 %else
219 %if %{with glibc}
220         %{CrossOpts} \
221         CC="%{__cc}"
222 %else
223         %if "%{_target_base_arch}" != "%{_arch}"
224         CROSS="%{_target_cpu}-uclibc-" \
225         %endif
226         CC="%{_target_cpu}-uclibc-gcc"
227 %endif
228 %endif
229
230 mv -f busybox built/busybox.static
231 %{__make} clean
232 %endif
233
234 %if %{with dynamic}
235 %{__make} oldconfig
236 %{__make} \
237         %{?with_verbose:V=1} \
238         %{CrossOpts} \
239         CFLAGS_EXTRA="%{rpmcflags}" \
240         LDFLAGS="%{rpmldflags}" \
241         CC="%{__cc}"
242 %{__make} busybox.links docs/busybox.1
243 %endif
244
245 %install
246 rm -rf $RPM_BUILD_ROOT
247
248 %if %{with static}
249 install -d $RPM_BUILD_ROOT%{_bindir}
250 install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
251 %endif
252
253 %if %{with initrd}
254 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
255 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
256 %endif
257
258 %if %{with dynamic}
259 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
260 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
261 install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
262
263 # install links to busybox binary, when linkfl is defined
264 %if %{with linkfl}
265 %{__make} install \
266         PREFIX=$RPM_BUILD_ROOT
267 %else
268 install busybox $RPM_BUILD_ROOT%{_bindir}
269 %endif
270 %endif
271
272 %clean
273 rm -rf $RPM_BUILD_ROOT
274
275 %if %{with dynamic}
276 %files
277 %defattr(644,root,root,755)
278 %doc AUTHORS README .config
279
280 %if %{with linkfl}
281 %attr(755,root,root) %{_bindir}/*
282 %attr(755,root,root) /sbin/*
283 %attr(755,root,root) %{_bindir}/*
284 %attr(755,root,root) %{_sbindir}/*
285 %else
286 %attr(755,root,root) %{_bindir}/busybox
287 %endif
288
289 %{_libdir}/busybox
290 %{_mandir}/man1/*
291 %endif
292
293 %if %{with static}
294 %files static
295 %defattr(644,root,root,755)
296 %attr(755,root,root) %{_bindir}/busybox.static
297 %endif
298
299 %if %{with initrd}
300 %files initrd
301 %defattr(644,root,root,755)
302 %attr(755,root,root) %{_libdir}/initrd/busybox
303 %endif
This page took 0.763154 seconds and 2 git commands to generate.