]> git.pld-linux.org Git - packages/bush.git/blob - bush.spec
- %%doc section fixed
[packages/bush.git] / bush.spec
1 #
2 ##
3 Summary:        Business Shell (BUSH)
4 Summary(pl):    Pow³oka Biznesowa (BUSH)
5 Name:           bush
6 Version:        0.9.3
7 Release:        1
8 License:        GPL
9 Group:          Applications/Shells
10 Source0:        http://tardis.dyn.dhs.org/smiab_download/other_projects/%{name}-%{version}-src.tgz
11 # Source0-md5:  05f4719e91b7e0f3194d8c4a16c2720d
12 Patch0:         %{name}-Makefile.patch
13 URL:            http://www.pegasoft.ca/bush.html
14 BuildRequires:  gcc-ada
15 BuildRequires:  postgresql-devel
16 Requires(post,preun):   grep
17 Requires(preun):        fileutils
18 Requires:       libgnat
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 BUSH, the Business Shell, is a powerful Linux/UNIX shell for designing secure,
23 reliable scripts that can be later compiled as a fast executable programs.
24 It can also be used an an interactive login shell or to generate
25 Java Virtual Machine or .Net applications. BUSH is a robust and readable
26 alternative to BASH, CSH, and (to a certain extent) Python and PERL.
27 BUSH comes with 12 built-in packages including numerics, string processing,
28 sound and database access. 
29
30 %description -l pl
31 BUSH, Pow³oka Biznesowa jest pow³ok± dla systemów Linux/UNIX o bogatych
32 mo¿liwo¶ciach. Stworzona jest z my¶l± o konstruowaniu bezpiecznych i
33 niezawodnych skryptów, które mog± potem zostaæ skompilowane do postaci
34 szybkich programów wykonywalnych. Mo¿e byæ ona równie¿ u¿ywana jako
35 pow³oka zg³oszeniowa, lub u¿yta do generowania aplikacji Java Virtual Machine
36 lub .Net. BUSH jest mocn± i czyteln± alternatyw± w stosunku do pow³ok
37 BASH, CSH, a tak¿e (w pewnym sensie) do jêzyków takich jak Python czy PERL.
38 BUSH zawiera 12 wbudowanych pakietów w³±czaj±c w to operacje na
39 liczbach, przetwarzanie ci±gów znaków, d¼wiêki, oraz dostêp do baz danych.
40
41 %prep
42 %setup -q
43 %patch0 -p1
44
45 %build
46 make linux
47 %{__make} \
48         CC="%{__cc}" CFLAGS="%{rpmcflags}"
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT/bin
53
54 mv -f doc html
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post
63 umask 022
64 if [ ! -f /etc/shells ]; then
65         echo "/bin/bush" > /etc/shells
66 else
67         if ! grep -q '^/bin/bush$' /etc/shells; then
68                 echo "/bin/bush" >> /etc/shells
69         fi
70 fi
71
72 %preun
73 if [ "$1" = "0" ]; then
74         umask 022
75         grep -v /bin/bush /etc/shells > /etc/shells.new
76         mv -f /etc/shells.new /etc/shells
77 fi
78
79 %files
80 %defattr(644,root,root,755)
81 %doc TODO README COPYING html
82
83 %attr(755,root,root) /bin/bush
This page took 0.052601 seconds and 3 git commands to generate.