]> git.pld-linux.org Git - packages/bttv.git/blob - bttv.spec
- added depmod options so modules can be installed for kernel other than running
[packages/bttv.git] / bttv.spec
1 #
2 # Conditional build:
3 # _without_dist_kernel          without kernel from distribution
4 #
5 # TODO: UP/SMP (if this spec is useful for something now?)
6 #
7 %define         _kernel_ver     %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
8 %define         _kernel_ver_str %(echo %{_kernel_ver} | sed s/-/_/g)
9 %define         smpstr  %{?_with_smp:-smp}
10 %define         smp     %{?_with_smp:1}%{!?_with_smp:0}
11
12 Summary:        BrookTree TV tuner driver
13 Summary(pl):    Sterownik dla kart TV na chipsecie BrookTree
14 Name:           bttv
15 Version:        0.7.87
16 Release:        1
17 License:        GPL
18 Group:          Base/Kernel
19 Source0:        http://www.strusel007.de/linux/bttv/%{name}-%{version}.tar.gz
20 Patch0:         %{name}-Makefile.patch
21 URL:            http://www.strusel007.de/linux/bttv/
22 %{!?_without_dist_kernel:BuildPrereq:   kernel-source}
23 ExclusiveArch:  %{ix86}
24 Requires:       i2c
25 PreReq:         modutils
26 BuildRequires:  i2c-devel
27 BuildConflicts: kernel-source < 2.2.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Kernel modules which add support for TV cards based on BrookTree BT
32 848 and 878 chips.
33
34 %description -l pl
35 Modu³y j±dra dodaj±ce obs³ugê kart TV na uk³adach BrookTree BT 848 i
36 878.
37
38 %package -n kernel%{smpstr}-misc-bttv
39 Summary:        Kernel modules for BrookTree TV tuner
40 Summary(pl):    Modu³y j±dra do obs³ugi tunerów TV BrookTree
41 Group:          Base/Kernel
42 Release:        %{release}@%{_kernel_ver_str}
43 PreReq:         modutils >= 2.4.6-4
44 %{!?_without_dist_kernel:Conflicts:     kernel < %{_kernel_ver}, kernel > %{_kernel_ver}}
45 %{!?_without_dist_kernel:Conflicts:     kernel-%{?_with_smp:up}%{!?_with_smp:smp}}
46 Requires:       %{name} = %{version}
47 Obsoletes:      bttv
48
49 %description -n kernel%{smpstr}-misc-bttv
50 Kernel modules which add support for TV cards based on BrookTree BT
51 848 and 878 chips.
52
53 %description -n kernel%{smpstr}-misc-bttv -l pl
54 Modu³y j±dra dodaj±ce obs³ugê kart TV na uk³adach BrookTree BT 848 i
55 878.
56
57 %package devel
58 Summary:        Header files for bttv
59 Summary(pl):    Pliki nag³ówkowe bttv
60 Group:          Development
61
62 %description devel
63 Header files for bttv.
64
65 %description devel -l pl
66 Pliki nag³ówkowe bttv.
67
68 %prep
69 %setup  -q
70 %patch0 -p1
71
72 %build
73 %{__make} EXTRA_CFLAGS="%{rpmcflags}"
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} -C driver install DESTDIR=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -n kernel%{smpstr}-misc-bttv
84 /sbin/depmod -a -F /boot/System.map-%{_kernel_ver} %{_kernel_ver}
85
86 %postun -n kernel%{smpstr}-misc-bttv
87 /sbin/depmod -a -F /boot/System.map-%{_kernel_ver} %{_kernel_ver}
88
89 %files -n kernel%{smpstr}-misc-bttv
90 %defattr(644,root,root,755)
91 /lib/modules/*/misc/*
92
93 %files
94 %defattr(644,root,root,755)
95 %doc CARDLIST Changes Insmod-options README* Sound-FAQ Specs Cards
96
97 #%files devel
98 #%defattr(644,root,root,755)
99 #/usr/src/linux/drivers/char/*
This page took 0.050305 seconds and 3 git commands to generate.