]> git.pld-linux.org Git - packages/btsco.git/blob - btsco.spec
- release 20
[packages/btsco.git] / btsco.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # without kernel from distribution
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  userspace       # don't build userspace utilities
6 %bcond_with     verbose         # verbose build (V=1)
7 #
8 %define         rel     20
9 Summary:        Bluetooth-alsa Project
10 Summary(pl.UTF-8):      Projekt Bluetooth-alsa
11 Name:           btsco
12 Version:        0.5
13 Release:        %{rel}
14 License:        GPL
15 Group:          Applications/Sound
16 Source0:        http://dl.sourceforge.net/bluetooth-alsa/%{name}-%{version}.tgz
17 # Source0-md5:  d9fdd63a9e22ba839a41c8a9b89c2dda
18 Patch0:         %{name}-readme-pl.diff
19 Patch1:         %{name}-kernel.patch
20 URL:            http://sourceforge.net/projects/bluetooth-alsa/
21 %if %{with kernel}
22 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
23 %endif
24 %if %{with userspace}
25 BuildRequires:  alsa-driver-devel >= 1.0.9-1
26 BuildRequires:  alsa-lib-devel >= 1.0.9-1
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  bluez-libs-devel >= 2.21-1
30 BuildRequires:  libao-devel >= 0.8.6-1
31 BuildRequires:  libtool
32 BuildRequires:  rpmbuild(macros) >= 1.379
33 %endif
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 This project provides a way to use a bluetooth headset with Linux. We
38 do this currently by making an alsa kernel driver which uses bluez to
39 reach the headset. It works well enough now to get voice-quality audio
40 to and from most headsets.
41
42 %description -l pl.UTF-8
43 Dzięki temu oprogramowaniu można używać zestawów słuchawkowych
44 Bluetooth Headset z Linuksem. Osiągnięto to dzięki zbudowaniu alsowego
45 modułu do jądra, który to używa systemu bluez do komunikacji z takim
46 zestawem. Współpracuje z większością zestawów, ograniczeniem w
47 komunikacji jest często urządzenie USB, które to może mieć
48 nieobsługiwane częściowo protokoły, wskazówka: hciconfig hciXXX
49 revision. W skrajnym wypadku można próbować użyć innego urządzenia
50 USB.
51
52 %package -n kernel%{_alt_kernel}-char-btsco
53 Summary:        Linux ALSA kernel driver for Bluetooth Headset
54 Summary(pl.UTF-8):      Sterownik ALSA do jądra Linuksa dla Bluetooth Headset
55 Release:        %{rel}@%{_kernel_ver_str}
56 Group:          Base/Kernel
57 %{?with_dist_kernel:%requires_releq_kernel}
58 Requires(post,postun):  /sbin/depmod
59 Requires:       kernel%{_alt_kernel}-sound-alsa
60
61 %description -n kernel%{_alt_kernel}-char-btsco
62 Linux ALSA kernel driver for Bluetooth Headset named snd_bt_sco.
63
64 %description -n kernel%{_alt_kernel}-char-btsco -l pl.UTF-8
65 Sterownik ALSA do jądra Linuksa dla Bluetooth Headset o nazwie
66 snd_bt_sco.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71 %patch1 -p1
72
73 %build
74 %if %{with userspace}
75 %{__libtoolize}
76 %{__aclocal}
77 %{__autoconf}
78 %{__autoheader}
79 %{__automake}
80 %configure
81 %{__make}
82 %endif
83
84 %if %{with kernel}
85 %build_kernel_modules -m snd-bt-sco -C kernel
86 %endif
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %if %{with userspace}
92 install -d $RPM_BUILD_ROOT%{_bindir}
93
94 for file in avdtp/avtest sbc/rcplay sbc/sbcenc sbc/sbcinfo a2play btsco2 btsco ; do
95         install $file $RPM_BUILD_ROOT%{_bindir}
96 done
97 %endif
98
99 %if %{with kernel}
100 %install_kernel_modules -m kernel/snd-bt-sco -d misc
101 %endif
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post -n kernel%{_alt_kernel}-char-btsco
107 %depmod %{_kernel_ver}
108 echo "after install this package, remember add lines like this:"
109 echo "alias snd-card-1 snd-bt-sco"
110 echo "alias sound-slot-1 snd-bt-sco"
111 echo "to %{_sysconfdir}/modprobe.conf"
112
113 %postun -n kernel%{_alt_kernel}-char-btsco
114 %depmod %{_kernel_ver}
115
116 %if %{with userspace}
117 %files
118 %defattr(644,root,root,755)
119 %doc README README.PL.txt
120 %attr(755,root,root) %{_bindir}/*
121 %endif
122
123 %if %{with kernel}
124 %files -n kernel%{_alt_kernel}-char-btsco
125 %defattr(644,root,root,755)
126 /lib/modules/%{_kernel_ver}/misc/snd-bt-sco.ko.gz
127 %endif
This page took 0.0674 seconds and 3 git commands to generate.