]> git.pld-linux.org Git - packages/btrfs-progs.git/commitdiff
- updated to 3.14.2 auto/th/btrfs-progs-3.14.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 15 Jun 2014 19:44:05 +0000 (21:44 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 15 Jun 2014 19:44:05 +0000 (21:44 +0200)
- removed obsolete arg_strtou64 patch
- added man patch (manpage symlink fix)

btrfs-progs-arg_strtou64.patch [deleted file]
btrfs-progs-man.patch [new file with mode: 0644]
btrfs-progs.spec

diff --git a/btrfs-progs-arg_strtou64.patch b/btrfs-progs-arg_strtou64.patch
deleted file mode 100644 (file)
index f86ae43..0000000
+++ /dev/null
@@ -1,136 +0,0 @@
-From f555e06e2d266f52cdeb12218f8175eba2a17020 Mon Sep 17 00:00:00 2001
-From: David Sterba <dste...@suse.cz>
-Date: Fri, 11 Apr 2014 13:22:50 +0200
-Subject: [PATCH] btrfs-progs: move arg_strtou64 to a separate file for library
-
-Linking with libbtrfs fails because arg_strtou64 is not defined and we
-cannot just add utils.o to library objects because it's not
-library-clean.
-
-Reported-by: Arvin Schnell <aschn...@suse.com>
-Signed-off-by: David Sterba <dste...@suse.cz>
----
- Makefile   |  5 +++--
- libutils.c | 43 +++++++++++++++++++++++++++++++++++++++++++
- utils.c    | 33 ---------------------------------
- 3 files changed, 46 insertions(+), 35 deletions(-)
- create mode 100644 libutils.c
-
-diff --git a/Makefile b/Makefile
-index da0519766443..9ae7115d23a3 100644
---- btrfs-progs-v3.14.1/Makefile.orig  2014-04-19 23:01:20.255226683 +0200
-+++ btrfs-progs-v3.14.1/Makefile       2014-04-19 23:01:24.018559938 +0200
-@@ -9,14 +9,15 @@
- objects = ctree.o disk-io.o radix-tree.o extent-tree.o print-tree.o \
-         root-tree.o dir-item.o file-item.o inode-item.o inode-map.o \
-         extent-cache.o extent_io.o volumes.o utils.o repair.o \
--        qgroup.o raid6.o free-space-cache.o list_sort.o props.o
-+        qgroup.o raid6.o free-space-cache.o list_sort.o props.o \
-+        libutils.o
- cmds_objects = cmds-subvolume.o cmds-filesystem.o cmds-device.o cmds-scrub.o \
-              cmds-inspect.o cmds-balance.o cmds-send.o cmds-receive.o \
-              cmds-quota.o cmds-qgroup.o cmds-replace.o cmds-check.o \
-              cmds-restore.o cmds-rescue.o chunk-recover.o super-recover.o \
-              cmds-property.o
- libbtrfs_objects = send-stream.o send-utils.o rbtree.o btrfs-list.o crc32c.o \
--                 uuid-tree.o
-+                 uuid-tree.o libutils.o
- libbtrfs_headers = send-stream.h send-utils.h send.h rbtree.h btrfs-list.h \
-              crc32c.h list.h kerncompat.h radix-tree.h extent-cache.h \
-              extent_io.h ioctl.h ctree.h btrfsck.h
-diff --git a/libutils.c b/libutils.c
-new file mode 100644
-index 000000000000..074f771e0b6e
---- /dev/null
-+++ b/libutils.c
-@@ -0,0 +1,43 @@
-+#define _GNU_SOURCE
-+
-+#include "kerncompat.h"
-+#include <unistd.h>
-+#include <stdlib.h>
-+#include <limits.h>
-+
-+#if BTRFS_FLAT_INCLUDES
-+#else
-+#endif /* BTRFS_FLAT_INCLUDES */
-+
-+/*
-+ * This function should be only used when parsing
-+ * command arg, it won't return error to it's
-+ * caller and rather exit directly just like usage().
-+ */
-+u64 arg_strtou64(const char *str)
-+{
-+      u64 value;
-+      char *ptr_parse_end = NULL;
-+
-+      value = strtoull(str, &ptr_parse_end, 0);
-+      if (ptr_parse_end && *ptr_parse_end != '\0') {
-+              fprintf(stderr, "ERROR: %s is not a valid numeric value.\n",
-+                      str);
-+              exit(1);
-+      }
-+      /*
-+       * if we pass a negative number to strtoull,
-+       * it will return an unexpected number to us,
-+       * so let's do the check ourselves.
-+       */
-+      if (str[0] == '-') {
-+              fprintf(stderr, "ERROR: %s: negative value is invalid.\n",
-+                      str);
-+              exit(1);
-+      }
-+      if (value == ULLONG_MAX) {
-+              fprintf(stderr, "ERROR: %s is too large.\n", str);
-+              exit(1);
-+      }
-+      return value;
-+}
-+
-diff --git a/utils.c b/utils.c
-index 3e9c527a492c..134f43a76fe9 100644
---- btrfs-progs-v3.14.1/utils.c.orig   2014-04-19 22:59:57.785228402 +0200
-+++ btrfs-progs-v3.14.1/utils.c        2014-04-19 23:03:03.918557853 +0200
-@@ -1539,39 +1539,6 @@
-       return 0;
- }
--/*
-- * This function should be only used when parsing
-- * command arg, it won't return error to it's
-- * caller and rather exit directly just like usage().
-- */
--u64 arg_strtou64(const char *str)
--{
--      u64 value;
--      char *ptr_parse_end = NULL;
--
--      value = strtoull(str, &ptr_parse_end, 0);
--      if (ptr_parse_end && *ptr_parse_end != '\0') {
--              fprintf(stderr, "ERROR: %s is not a valid numeric value.\n",
--                      str);
--              exit(1);
--      }
--      /*
--       * if we pass a negative number to strtoull,
--       * it will return an unexpected number to us,
--       * so let's do the check ourselves.
--       */
--      if (str[0] == '-') {
--              fprintf(stderr, "ERROR: %s: negative value is invalid.\n",
--                      str);
--              exit(1);
--      }
--      if (value == ULLONG_MAX) {
--              fprintf(stderr, "ERROR: %s is too large.\n", str);
--              exit(1);
--      }
--      return value;
--}
--
- u64 parse_size(char *s)
- {
-       int i;
--- 
-1.9.0
diff --git a/btrfs-progs-man.patch b/btrfs-progs-man.patch
new file mode 100644 (file)
index 0000000..8d74f81
--- /dev/null
@@ -0,0 +1,11 @@
+--- btrfs-progs-v3.14.2/Documentation/Makefile.orig    2014-05-30 02:56:59.000000000 +0200
++++ btrfs-progs-v3.14.2/Documentation/Makefile 2014-06-15 20:37:16.269541245 +0200
+@@ -74,7 +74,7 @@
+ install-man: man
+       $(INSTALL) -d -m 755 $(DESTDIR)$(man8dir)
+       $(INSTALL) -m 644 $(GZ_MAN8) $(DESTDIR)$(man8dir)
+-      $(LNS) btrfs-check.8.gz $(DESTDIR)$(man8dir)
++      $(LNS) btrfs-check.8 $(DESTDIR)$(man8dir)/btrfsck.8
+ clean:
+       $(RM) *.xml *.xml+ *.8 *.8.gz
index ddf260e04e2d9d07c828158f88b973988ba4e059..5026082bba6530c635c7cb63a086a1d47babe6ad 100644 (file)
@@ -1,13 +1,13 @@
 Summary:       Utilities belonging to the btrfs filesystem
 Summary(pl.UTF-8):     Narzędzia należące do systemu plików btrfs
 Name:          btrfs-progs
-Version:       3.14.1
+Version:       3.14.2
 Release:       1
 License:       GPL v2
 Group:         Applications/System
 Source0:       https://www.kernel.org/pub/linux/kernel/people/mason/btrfs-progs/%{name}-v%{version}.tar.xz
-# Source0-md5: 761d07cfe5b468ec733e90a57b413e5c
-Patch0:                %{name}-arg_strtou64.patch
+# Source0-md5: 18dadb86a668c3fe26b2bcb57bbdf59e
+Patch0:                %{name}-man.patch
 URL:           http://btrfs.wiki.kernel.org/
 BuildRequires: acl-devel
 BuildRequires: e2fsprogs-devel
@@ -100,18 +100,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_sbindir}/btrfs-show-super
 %attr(755,root,root) %{_libdir}/libbtrfs.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libbtrfs.so.0
-%{_mandir}/man8/btrfs-image.8*
-%{_mandir}/man8/btrfsck.8*
-%{_mandir}/man8/mkfs.btrfs.8*
 %{_mandir}/man8/btrfs.8*
-%{_mandir}/man8/btrfs-convert.8*
-%{_mandir}/man8/btrfs-debug-tree.8*
-%{_mandir}/man8/btrfs-find-root.8*
-%{_mandir}/man8/btrfs-map-logical.8*
-%{_mandir}/man8/btrfs-show-super.8*
-%{_mandir}/man8/btrfs-zero-log.8*
+%{_mandir}/man8/btrfs-*.8*
+%{_mandir}/man8/btrfsck.8*
 %{_mandir}/man8/btrfstune.8*
 %{_mandir}/man8/fsck.btrfs.8*
+%{_mandir}/man8/mkfs.btrfs.8*
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.290329 seconds and 4 git commands to generate.