]> git.pld-linux.org Git - packages/brltty.git/commitdiff
- updated to 4.5 (brlapi 0.6.0, new soname) auto/th/brltty-4.5-1 auto/ti/brltty-4.5-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 7 Apr 2013 18:38:04 +0000 (20:38 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 7 Apr 2013 18:38:04 +0000 (20:38 +0200)
- added java patch (fix jni.h detection)
- added speech-dispatcher patch (build with speech-dispatcher 0.8+)

brltty-java.patch [new file with mode: 0644]
brltty-speech-dispatcher.patch [new file with mode: 0644]
brltty.spec

diff --git a/brltty-java.patch b/brltty-java.patch
new file mode 100644 (file)
index 0000000..ddf63ba
--- /dev/null
@@ -0,0 +1,11 @@
+--- brltty-4.5/Bindings/Java/bindings.m4.orig  2013-03-27 23:51:37.000000000 +0100
++++ brltty-4.5/Bindings/Java/bindings.m4       2013-04-07 18:39:56.903678323 +0200
+@@ -63,7 +63,7 @@
+    JAVA_JNI_INC="${JAVA_ROOT}/include"
+    JAVA_JNI_HDR="jni.h"
+    JAVA_JNI_FLAGS=""
+-   AC_CHECK_HEADER([${JAVA_JNI_HDR}], [], [AC_CHECK_FILE(["${JAVA_JNI_INC}/${JAVA_JNI_HDR}"], [JAVA_JNI_FLAGS="-I${JAVA_JNI_INC}"], [JAVA_OK=false])])
++   AC_CHECK_HEADER([${JAVA_JNI_HDR}], [], [AC_CHECK_FILE(["${JAVA_JNI_INC}/${JAVA_JNI_HDR}"], [JAVA_JNI_FLAGS="-I${JAVA_JNI_INC} -I${JAVA_JNI_INC}/linux"], [JAVA_OK=false])])
+    AC_SUBST([JAVA_JNI_HDR])
+    AC_SUBST([JAVA_JNI_INC])
+    AC_SUBST([JAVA_JNI_FLAGS])
diff --git a/brltty-speech-dispatcher.patch b/brltty-speech-dispatcher.patch
new file mode 100644 (file)
index 0000000..3b2f949
--- /dev/null
@@ -0,0 +1,31 @@
+--- brltty-4.5/configure.ac.orig       2013-03-27 23:54:58.000000000 +0100
++++ brltty-4.5/configure.ac    2013-04-07 19:04:31.636980920 +0200
+@@ -1516,7 +1516,7 @@
+    BRLTTY_SPEECH_DRIVER([fv], [Festival])
+    BRLTTY_SPEECH_DRIVER([gs], [GenericSay])
+    BRLTTY_IF_PACKAGE([Mikropuhe], [mikropuhe], [mpwrfile.h], [BRLTTY_IF_PTHREADS([BRLTTY_SPEECH_DRIVER([mp], [Mikropuhe], [-L$(MPLINUX_ROOT) -lmplinux])])])
+-   BRLTTY_IF_PACKAGE([speech-dispatcher], [speechd], [include/libspeechd.h], [BRLTTY_SPEECH_DRIVER([sd], [SpeechDispatcher], [-L$(SPEECHD_ROOT)/lib -lspeechd])])
++   BRLTTY_IF_PACKAGE([speech-dispatcher], [speechd], [include/speech-dispatcher/libspeechd.h], [BRLTTY_SPEECH_DRIVER([sd], [SpeechDispatcher], [-lspeechd])])
+    BRLTTY_IF_PACKAGE([Swift], [swift], [include/swift.h], [BRLTTY_SPEECH_DRIVER([sw], [Swift], [-L$(SWIFT_ROOT)/lib -lswift -lm])])
+    BRLTTY_IF_PACKAGE([Theta], [theta], [include/theta.h], [BRLTTY_SPEECH_DRIVER([th], [Theta], [-L$(THETA_ROOT)/lib -ltheta])])
+    BRLTTY_IF_PACKAGE([ViaVoice], [viavoice], [include/eci.h], [BRLTTY_SPEECH_DRIVER([vv], [ViaVoice], [-L$(VIAVOICE_ROOT)/lib -libmeci50])])
+#--- brltty-4.5/Drivers/Speech/SpeechDispatcher/Makefile.in.orig       2013-03-27 23:51:36.000000000 +0100
+#+++ brltty-4.5/Drivers/Speech/SpeechDispatcher/Makefile.in    2013-04-07 19:41:55.110267490 +0200
+#@@ -25,5 +25,5 @@
+# include $(SRC_TOP)speech.mk
+# 
+# speech.$O:
+#-     $(CC) $(SPK_CFLAGS) -I$(SPEECHD_ROOT)/include -c $(SRC_DIR)/speech.c
+#+     $(CC) $(SPK_CFLAGS) -I$$(pkg-config --cflags speech-dispatcher) -c $(SRC_DIR)/speech.c
+# 
+--- brltty-4.5/Drivers/Speech/SpeechDispatcher/speech.c.orig   2013-03-27 23:51:36.000000000 +0100
++++ brltty-4.5/Drivers/Speech/SpeechDispatcher/speech.c        2013-04-07 19:56:47.340248894 +0200
+@@ -38,7 +38,7 @@
+ #define SPK_HAVE_PUNCTUATION
+ #include "spk_driver.h"
+-#include <libspeechd.h>
++#include <speech-dispatcher/libspeechd.h>
+ static SPDConnection *connectionHandle = NULL;
+ static const char *moduleName;
index 5b23db5f56a678516bf7a0b8eea180f8c8952d30..26978c73301022ce59a9c1bda721d683dc47770b 100644 (file)
 %bcond_without at_spi                  # AtSpi screen driver
 %bcond_without at_spi2                 # AtSpi2 screen driver
 #
-%define                brlapi_ver      0.5.7
+%define                brlapi_ver      0.6.0
 #
 %include       /usr/lib/rpm/macros.java
 Summary:       Braille display driver for Linux/Unix
 Summary(pl.UTF-8):     Sterownik do wyƛwietlaczy Braille'a
 Name:          brltty
-Version:       4.4
-Release:       3
+Version:       4.5
+Release:       1
 Group:         Daemons
 License:       GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
 Source0:       http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
-# Source0-md5: 8ebe96efe679f5f6ccff08928fec5b26
+# Source0-md5: 7b52fa7746fed41ed344a1f75ce55951
 Patch0:                %{name}-stat.patch
+Patch1:                %{name}-java.patch
+Patch2:                %{name}-speech-dispatcher.patch
 URL:           http://mielke.cc/brltty/
 BuildRequires: alsa-lib-devel
 %{?with_at_spi:BuildRequires:  at-spi-devel}
@@ -47,6 +49,7 @@ BuildRequires:        bluez-libs-devel
 %{?with_flite:BuildRequires:   flite-devel}
 %{?with_gpm:BuildRequires:     gpm-devel}
 %{?with_java:BuildRequires:    jdk}
+%{?with_java:BuildRequires:    jpackage-utils}
 %{?with_libbraille:BuildRequires:      libbraille-devel}
 BuildRequires: libicu-devel
 BuildRequires: ncurses-devel
@@ -55,7 +58,7 @@ BuildRequires:        pkgconfig
 %{?with_python:BuildRequires:  python-Pyrex}
 %{?with_java:BuildRequires:    rpm-javaprov}
 %{?with_python:BuildRequires:  rpm-pythonprov}
-%{?with_speech_dispatcher:BuildRequires:       speech-dispatcher-devel}
+%{?with_speech_dispatcher:BuildRequires:       speech-dispatcher-devel >= 0.8}
 %{?with_tcl:BuildRequires:     tcl-devel}
 %if %{with x}
 BuildRequires: xorg-lib-libX11-devel
@@ -229,10 +232,14 @@ Biblioteka BrlAPI dla Tcl.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
+%{__autoconf}
 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
 %configure \
+       %{?with_java:JAVA_HOME=%{java_home}} \
        --with-install-root="$RPM_BUILD_ROOT" \
        %{!?with_libbraille:--without-libbraille} \
        %{!?with_espeak:--without-espeak} \
@@ -580,13 +587,13 @@ exit 0
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
+%attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
-%attr(755,root,root) %{_libdir}/brltty/libbrlttybil.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
@@ -637,7 +644,7 @@ exit 0
 %files -n brlapi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.5
+%attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.6
 
 %files -n brlapi-devel
 %defattr(644,root,root,755)
This page took 0.165255 seconds and 4 git commands to generate.