]> git.pld-linux.org Git - packages/brltty.git/blobdiff - brltty.spec
- updated to 5.3 (brlapi 0.6.4)
[packages/brltty.git] / brltty.spec
index fd7b12fee4c5d2dcaa9dfe876fb66543d2f8baaf..4a6d78bdb7e333089c3cd5b9eb9481286a5d4be2 100644 (file)
 %bcond_with    swift                   # Swift synthesizer driver [commercial, from Cepstral]
 %bcond_with    theta                   # Theta synthesizer driver [commercial, from Cepstral]
 %bcond_with    viavoice                # IBM ViaVoice synthesizer driver [commercial]
-%bcond_without at_spi                  # AtSpi screen driver
+%bcond_with    at_spi                  # AtSpi screen driver
 %bcond_without at_spi2                 # AtSpi2 screen driver
-#
-%define                brlapi_ver      0.6.2
-#
+
+%define                brlapi_ver      0.6.4
 %include       /usr/lib/rpm/macros.java
 Summary:       Braille display driver for Linux/Unix
 Summary(pl.UTF-8):     Sterownik do wyświetlaczy Braille'a
 Name:          brltty
-Version:       5.1
-Release:       3
-Group:         Daemons
+Version:       5.3
+Release:       1
 License:       GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
+Group:         Daemons
 Source0:       http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
-# Source0-md5: 938769dd1c3c3baf0d6dfafeb11581ec
-Patch0:                %{name}-java.patch
+# Source0-md5: 19fbcb1fefc42cea81f560de0a1f539f
+Patch0:                %{name}-format.patch
 Patch1:                %{name}-speech-dispatcher.patch
 Patch2:                %{name}-python.patch
 URL:           http://mielke.cc/brltty/
 BuildRequires: alsa-lib-devel
 %{?with_at_spi:BuildRequires:  at-spi-devel}
-BuildRequires: autoconf >= 2.62
+BuildRequires: autoconf >= 2.64
 BuildRequires: automake
 BuildRequires: bison
+BuildRequires: rpmbuild(macros) >= 1.710
 # just headers
 BuildRequires: bluez-libs-devel
 %{?with_at_spi2:BuildRequires: dbus-devel >= 1.0}
@@ -70,11 +70,11 @@ BuildRequires:      xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXt-devel
 BuildRequires: xorg-lib-libXtst-devel
 %endif
-BuildRequires: xz
 #%{?with_mikropuhe:BuildRequires:      Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
 #%{?with_swift:BuildRequires:  Swift-devel (-lswift <swift.h>)}
 #%{?with_theta:BuildRequires:  Theta-devel (-ltheta <theta.h>)}
 #%{?with_viavoice:BuildRequires:       ViaVoice-devel (-libmeci50 <eci.h>)}
+BuildRequires: xz
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -157,14 +157,17 @@ Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
 Summary:       BrlAPI documentation
 Summary(pl.UTF-8):     Documentacja BrlAPI
 Group:         Documentation
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description -n brlapi-apidocs
-Documentation for BrlAPI in HTML format generated from brltty
-sources by doxygen.
+Documentation for BrlAPI in HTML format generated from brltty sources
+by doxygen.
 
 %description -n brlapi-apidocs -l pl.UTF-8
-Dokumentacja BrlAPI w formacie HTML generowane ze
-źrodeł brltty przez doxygen.
+Dokumentacja BrlAPI w formacie HTML generowane ze źrodeł brltty przez
+doxygen.
 
 %package -n java-brlapi
 Summary:       BrlAPI library for Java
@@ -272,10 +275,15 @@ CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
 
 %{__make} -j1
 
+%if %{with python}
+cd Bindings/Python
+%py_build
+cd ../..
+%endif
+
 %if %{with python3}
 cd Bindings/Python
-%{__python3} setup.py build \
-       -b build-3
+%py3_build
 cd ../..
 %endif
 
@@ -293,15 +301,18 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -j1 install \
        OCAML_INSTALL_TARGET=install-without-findlib
 
+# findlib-specific, useless in rpm
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
+
+%if %{with python}
+cd Bindings/Python
+%py_install
+cd ../..
+%endif
+
 %if %{with python3}
 cd Bindings/Python
-%{__python3} setup.py \
-       build \
-               -b build-3 \
-       install \
-               --optimize=2 \
-               --skip-build \
-               --root=$RPM_BUILD_ROOT
+%py3_install
 cd ../..
 %endif
 
@@ -608,13 +619,15 @@ exit 0
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
-%doc doc/{Bindings,Bootdisks,Drivers,Patches,Tables,README,nsistrings.txt}
+%doc doc/{Bindings,Bootdisks,Drivers,Patches,Tables,README}
 %attr(755,root,root) %{_bindir}/brltty
+%attr(755,root,root) %{_bindir}/brltty-atb
 %attr(755,root,root) %{_bindir}/brltty-config
 %attr(755,root,root) %{_bindir}/brltty-ctb
-%attr(755,root,root) %{_bindir}/brltty-install
+%attr(755,root,root) %{_bindir}/brltty-ktb
 %attr(755,root,root) %{_bindir}/brltty-trtxt
 %attr(755,root,root) %{_bindir}/brltty-ttb
+%attr(755,root,root) %{_bindir}/brltty-tune
 %attr(755,root,root) %{_bindir}/eutp
 %attr(755,root,root) %{_bindir}/vstp
 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
@@ -625,6 +638,7 @@ exit 0
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
+%attr(755,root,root) %{_libdir}/brltty/libbrlttybbg.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
@@ -633,6 +647,7 @@ exit 0
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
+%attr(755,root,root) %{_libdir}/brltty/libbrlttybhd.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
@@ -677,7 +692,7 @@ exit 0
 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
 %{_sysconfdir}/brltty
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
-/usr/lib/tmpfiles.d/brltty.conf
+%{systemdtmpfilesdir}/brltty.conf
 %dir /var/lib/BrlAPI
 %dir /var/run/brltty
 %{_mandir}/man1/brltty.1*
@@ -724,7 +739,6 @@ exit 0
 %files -n ocaml-brlapi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
-%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
 
 %files -n ocaml-brlapi-devel
 %defattr(644,root,root,755)
This page took 0.123166 seconds and 4 git commands to generate.