]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
5fbf17879d8d124a43be459feb23f12a39e45c75
[packages/brltty.git] / brltty.spec
1 # TODO:
2 #       - what is that huge %post script?
3 #
4 # Conditional build:
5 %bcond_without  apidocs                 # documentation generated with doxygen
6 %bcond_without  java                    # Java bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  python3                 # Python 3.x bindings
10 %bcond_without  tcl                     # Tcl bindings
11 %bcond_without  x                       # X11-based utilities
12 %bcond_without  gpm                     # mouse tracking via GPM
13 %bcond_without  libbraille              # libbraille Braille driver
14 %bcond_without  espeak                  # eSpeak synthesizer driver
15 %bcond_without  flite                   # Flite synthesizer driver
16 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
17 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
18 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
19 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
20 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
21 %bcond_with     at_spi                  # AtSpi screen driver
22 %bcond_without  at_spi2                 # AtSpi2 screen driver
23 #
24 %define         brlapi_ver      0.6.3
25 #
26 %include        /usr/lib/rpm/macros.java
27 Summary:        Braille display driver for Linux/Unix
28 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
29 Name:           brltty
30 Version:        5.2
31 Release:        7
32 Group:          Daemons
33 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
34 Source0:        http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
35 # Source0-md5:  b484343461b5a45f95fedfb21d1ceca3
36 Patch0:         %{name}-java.patch
37 Patch1:         %{name}-speech-dispatcher.patch
38 Patch2:         %{name}-python.patch
39 URL:            http://mielke.cc/brltty/
40 BuildRequires:  alsa-lib-devel
41 %{?with_at_spi:BuildRequires:   at-spi-devel}
42 BuildRequires:  autoconf >= 2.62
43 BuildRequires:  automake
44 BuildRequires:  bison
45 # just headers
46 BuildRequires:  bluez-libs-devel
47 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
48 %{?with_apidocs:BuildRequires:  doxygen}
49 %{?with_espeak:BuildRequires:   espeak-devel}
50 %{?with_flite:BuildRequires:    flite-devel}
51 %{?with_gpm:BuildRequires:      gpm-devel}
52 %{?with_java:BuildRequires:     jdk}
53 %{?with_java:BuildRequires:     jpackage-utils}
54 %{?with_libbraille:BuildRequires:       libbraille-devel}
55 BuildRequires:  libicu-devel
56 BuildRequires:  ncurses-devel
57 %{?with_ocaml:BuildRequires:    ocaml}
58 BuildRequires:  pkgconfig
59 %{?with_python:BuildRequires:   python-Cython}
60 %{?with_python3:BuildRequires:  python3-Cython}
61 %{?with_java:BuildRequires:     rpm-javaprov}
62 %{?with_python:BuildRequires:   rpm-pythonprov}
63 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
64 BuildRequires:  tar >= 1:1.22
65 %{?with_tcl:BuildRequires:      tcl-devel >= 8.5}
66 %if %{with x}
67 BuildRequires:  xorg-lib-libX11-devel
68 BuildRequires:  xorg-lib-libXaw-devel
69 BuildRequires:  xorg-lib-libXext-devel
70 BuildRequires:  xorg-lib-libXt-devel
71 BuildRequires:  xorg-lib-libXtst-devel
72 %endif
73 BuildRequires:  xz
74 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
75 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
76 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
77 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 BRLTTY is a background process (daemon) which provides access to the
82 Linux/Unix console (when in text mode) for a blind person using a
83 refreshable Braille display. It drives the Braille display, and
84 provides complete screen review functionality. Some speech capability
85 has also been incorporated.
86
87 %description -l pl.UTF-8
88 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
89 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
90 odświeżaniem (refreshable Braille display). BRLTTY steruje
91 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
92 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
93 mowy.
94
95 %package -n brlapi
96 Summary:        Application Programming Interface for BRLTTY
97 Summary(pl.UTF-8):      API do BRLTTY
98 License:        LGPL v2.1+
99 Group:          Libraries
100
101 %description -n brlapi
102 This package provides the run-time support for the Application
103 Programming Interface to BRLTTY.
104
105 Install this package if you have an application which directly
106 accesses a refreshable Braille display.
107
108 %description -n brlapi -l pl.UTF-8
109 Ten pakiet zawiera środowisko uruchomieniowe dla programów
110 korzystających z API BRLTTY.
111
112 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
113 wyświetlacza Braille'a z odświeżaniem.
114
115 %package -n brlapi-devel
116 Summary:        Headers and documentation for BrlAPI
117 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
118 License:        LGPL v2.1+
119 Group:          Development/Libraries
120 Requires:       brlapi = %{version}-%{release}
121
122 %description -n brlapi-devel
123 This package provides the header files, shared object linker
124 reference, and reference documentation for BrlAPI (the Application
125 Programming Interface to BRLTTY). It enables the implementation of
126 applications which take direct advantage of a refreshable Braille
127 display in order to present information in ways which are more
128 appropriate for blind users and/or to provide user interfaces which
129 are more specifically atuned to their needs.
130
131 Install this package if you're developing or maintaining an
132 application which directly accesses a refreshable Braille display.
133
134 %description -n brlapi-devel -l pl.UTF-8
135 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
136 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
137 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
138 bardziej przystosowany dla osób niewidomych.
139
140 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
141 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
142
143 %package -n brlapi-static
144 Summary:        Static BrlAPI library
145 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
146 License:        LGPL v2.1+
147 Group:          Development/Libraries
148 Requires:       brlapi-devel = %{version}-%{release}
149
150 %description -n brlapi-static
151 This is package with static BrlAPI library.
152
153 %description -n brlapi-static -l pl.UTF-8
154 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
155
156 %package -n brlapi-apidocs
157 Summary:        BrlAPI documentation
158 Summary(pl.UTF-8):      Documentacja BrlAPI
159 Group:          Documentation
160
161 %description -n brlapi-apidocs
162 Documentation for BrlAPI in HTML format generated from brltty
163 sources by doxygen.
164
165 %description -n brlapi-apidocs -l pl.UTF-8
166 Dokumentacja BrlAPI w formacie HTML generowane ze
167 źrodeł brltty przez doxygen.
168
169 %package -n java-brlapi
170 Summary:        BrlAPI library for Java
171 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
172 License:        LGPL v2.1+
173 Group:          Libraries
174 Requires:       brlapi = %{version}-%{release}
175
176 %description -n java-brlapi
177 BrlAPI library for Java.
178
179 %description -n java-brlapi -l pl.UTF-8
180 Biblioteka BrlAPI dla Javy.
181
182 %package -n ocaml-brlapi
183 Summary:        OCaml binding for BrlAPI
184 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
185 License:        LGPL v2.1+
186 Group:          Libraries
187 Requires:       brlapi = %{version}-%{release}
188 %requires_eq    ocaml-runtime
189
190 %description -n ocaml-brlapi
191 OCaml binding for BrlAPI.
192
193 %description -n ocaml-brlapi -l pl.UTF-8
194 Wiązania OCamla do BrlAPI.
195
196 %package -n ocaml-brlapi-devel
197 Summary:        OCaml binding for BrlAPI - development files
198 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
199 License:        LGPL v2.1+
200 Group:          Libraries
201 Requires:       ocaml-brlapi = %{version}-%{release}
202 %requires_eq    ocaml
203
204 %description -n ocaml-brlapi-devel
205 OCaml binding for BrlAPI - development files.
206
207 %description -n ocaml-brlapi-devel -l pl.UTF-8
208 Wiązania OCamla do BrlAPI - pliki programistyczne.
209
210 %package -n python-brlapi
211 Summary:        Python 2.x interface to BrlAPI
212 Summary(pl.UTF-8):      Interfejs Pythona 2.x do BrlAPI
213 License:        LGPL v2.1+
214 Group:          Libraries
215 Requires:       brlapi = %{version}-%{release}
216
217 %description -n python-brlapi
218 Python 2.x interface to BrlAPI.
219
220 %description -n python-brlapi -l pl.UTF-8
221 Interfejs Pythona 2.x do BrlAPI.
222
223 %package -n python3-brlapi
224 Summary:        Python 3.x interface to BrlAPI
225 Summary(pl.UTF-8):      Interfejs Pythona 3.x do BrlAPI
226 License:        LGPL v2.1+
227 Group:          Libraries
228 Requires:       brlapi = %{version}-%{release}
229
230 %description -n python3-brlapi
231 Python 3.x interface to BrlAPI.
232
233 %description -n python3-brlapi -l pl.UTF-8
234 Interfejs Pythona 3.x do BrlAPI.
235
236 %package -n brlapi-tcl
237 Summary:        BrlAPI library for Tcl
238 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
239 License:        LGPL v2.1+
240 Group:          Libraries
241 Requires:       brlapi = %{version}-%{release}
242
243 %description -n brlapi-tcl
244 BrlAPI library for Tcl.
245
246 %description -n brlapi-tcl -l pl.UTF-8
247 Biblioteka BrlAPI dla Tcl.
248
249 %prep
250 %setup -q
251 %patch0 -p1
252 %patch1 -p1
253 %patch2 -p1
254
255 %build
256 %{__autoconf}
257 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
258 %configure \
259         %{?with_java:JAVA_HOME=%{java_home}} \
260         --with-install-root="$RPM_BUILD_ROOT" \
261         %{!?with_libbraille:--without-libbraille} \
262         %{!?with_espeak:--without-espeak} \
263         %{!?with_flite:--without-flite} \
264         %{!?with_speech_dispatcher:--without-speechd} \
265         %{!?with_ocaml:--disable-caml-bindings} \
266         %{!?with_gpm:--disable-gpm} \
267         %{!?with_java:--disable-java-bindings} \
268         %{!?with_python:--disable-python-bindings} \
269         %{!?with_tcl:--disable-tcl-bindings} \
270         %{!?with_x:--disable-x} \
271         --enable-api
272
273 %{__make} -j1
274
275 %if %{with python3}
276 cd Bindings/Python
277 %py3_build \
278         -b build-3
279 cd ../..
280 %endif
281
282 directory="doc"
283 mkdir -p "$directory"
284 for file in `find . \( -path "./$directory" -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print`
285 do
286         mkdir -p "$directory/${file%/*}"
287         cp -rp "$file" "$directory/$file"
288 done
289
290 %install
291 rm -rf $RPM_BUILD_ROOT
292
293 %{__make} -j1 install \
294         OCAML_INSTALL_TARGET=install-without-findlib
295
296 # findlib-specific, useless in rpm
297 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
298
299 %if %{with python3}
300 cd Bindings/Python
301 %{__python3} setup.py \
302         build \
303                 -b build-3 \
304         install \
305                 --optimize=2 \
306                 --skip-build \
307                 --root=$RPM_BUILD_ROOT
308 cd ../..
309 %endif
310
311 %if %{_lib} != "lib"
312         # Fix java plugin install path on 64-bit archs
313         install -d $RPM_BUILD_ROOT%{_libdir}/java
314         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
315 %endif
316
317 install Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
318
319 install -d $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
320 cat >$RPM_BUILD_ROOT/usr/lib/tmpfiles.d/brltty.conf <<EOF
321 d /var/run/brltty 0755 root root -
322 EOF
323
324 # no sign in source wheter it is zh_CN or zh_TW so just remove it
325 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh
326
327 %find_lang %{name}
328
329 %clean
330 rm -rf $RPM_BUILD_ROOT
331
332 %pre
333 # The pre-install scriptlet.
334
335 # If a configuration file already exists then rpm installs the new one as
336 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
337 # already exists.
338
339 # There's no explicit way to tell if a configuration file has been installed
340 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
341 # erasing the .rpmnew file now so that we can see if it gets created later.
342 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
343
344 %post
345 # The post-install scriptlet.
346
347 # If BRLTTY's boot parameter has been specified then update the just installed
348 # configuration file template to reflect the options supplied thereby.
349
350 # First, we need to determine which file to update. If there's a .rpmnew file
351 # then update it since a previous configuration file must already have existed.
352 file="%{_sysconfdir}/brltty.conf"
353 new="${file}.rpmnew"
354 [ -f "${new}" ] && file="${new}"
355
356 # Update the configuration file template via the Bootdisks/bp2cf script.
357 # Include it right within this scriptlet so that it needn't be installed.
358 # Imbed it within a subshell to ensure that it won't impact this scriptlet.
359 (
360         # First, set bp2cf's command line arguments.
361         set -- -u -f "${file}"
362
363 #!/bin/sh
364 ###############################################################################
365 # BRLTTY - A background process providing access to the Linux console (when in
366 #          text mode) for a blind person using a refreshable Braille display.
367 #
368 # Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
369 #
370 # BRLTTY comes with ABSOLUTELY NO WARRANTY.
371 #
372 # This is free software, placed under the terms of the
373 # GNU General Public License, as published by the Free Software
374 # Foundation.  Please see the file COPYING for details.
375 #
376 # Web Page: http://mielke.cc/brltty/
377 #
378 # This software is maintained by Dave Mielke <dave@mielke.cc>.
379 ###############################################################################
380
381 # Convert the boot parameter to configuration file directives.
382 # If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
383 # If /proc is not mounted then use the brltty environment variable.
384 # Invoke with -h for usage information.
385
386 programName="${0##*/}"
387 programMessage()
388 {
389         echo 2>&1 "${programName}: ${1}"
390 }
391 syntaxError()
392 {
393         programMessage "${1}"
394         exit 2
395 }
396 internalError()
397 {
398         programMessage "${1}"
399         exit 3
400 }
401
402 configurationFile=""
403 requestedAction=create
404 deviceTranslation=none
405 requestedParameter=""
406 OPTIND=1
407 while getopts ":f:cundop:h" option
408 do
409         case "${option}" in
410             f) configurationFile="${OPTARG}";;
411             c) requestedAction=create;;
412             u) requestedAction=update;;
413             n) deviceTranslation=none;;
414             d) deviceTranslation=devfs;;
415             o) deviceTranslation=old;;
416             p) requestedParameter="${OPTARG}";;
417             h)
418                 cat <<EOF
419 Usage: ${programName} [option ...]
420 -f file  The configuration file to create/update.
421 -c       Create the configuration file (write to stdout if no -f).
422 -u       Update the configuration file (copying from stdin to stdout if no -f).
423 -n       Do not translate device paths.
424 -d       Do old-style to devfs device path translation.
425 -o       Do devfs to old-style device path translation.
426 -p [driver][,[device][,[table]]]
427          Explicitly specify the boot parameter.
428 -h       Display this usage summary.
429 EOF
430                 exit 0
431                 ;;
432             \?) syntaxError "unknown option: -${OPTARG}";;
433             :) syntaxError "missing value: -${OPTARG}";;
434             *) internalError "unimplemented option: -${option}";;
435         esac
436 done
437 shift "`expr $OPTIND - 1`"
438 [ "${#}" -eq 0 ] || syntaxError "too many parameters."
439
440 case "${requestedAction}" in
441     create)
442         putConfigurationLine()
443         {
444                 echo "${1}" || exit 4
445         }
446         startConfigurationFile()
447         {
448                 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
449                 putConfigurationLine "`makeHeaderLine Created`"
450                 putConfigurationLine "`makeParameterLine`"
451                 putConfigurationLine ""
452         }
453         putConfigurationDirective()
454         {
455                 putConfigurationLine "${1} ${2}"
456         }
457         finalizeConfigurationFile()
458         {
459                 :
460         }
461         ;;
462     update)
463         putSedCommand()
464         {
465                 sedScript="${sedScript}
466 ${1}"
467         }
468         startConfigurationFile()
469         {
470                 if [ -n "${configurationFile}" ]; then
471                         [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
472                         [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
473                         [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
474                         [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
475                         outputFile="${configurationFile}.new"
476                         exec <"${configurationFile}" >"${outputFile}"
477                 fi
478                 sedScript=""
479                 putSedCommand "1i\\
480 `makeHeaderLine Updated`\\
481 `makeParameterLine`\\
482 "
483         }
484         putConfigurationDirective()
485         {
486                 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
487                 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
488                 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
489         }
490         finalizeConfigurationFile()
491         {
492                 sed -e "${sedScript}"
493                 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
494         }
495         ;;
496     *) internalError "unimplemented action: ${requestedAction}";;
497 esac
498
499 translateDevice_none()
500 {
501         :
502 }
503 translateDevice_devfs()
504 {
505         minor="${device#ttyS}"
506         if [ "${minor}" != "${device}" ]; then
507                 device="tts/${minor}"
508                 return 0
509         fi
510         minor="${device#lp}"
511         if [ "${minor}" != "${device}" ]; then
512                 device="printers/${minor}"
513                 return 0
514         fi
515         programMessage "unsupported old-style device: ${device}"
516 }
517 translateDevice_old()
518 {
519         major="${device%%/*}"
520         if [ "${major}" != "${device}" ]; then
521                 minor="${device#*/}"
522                 case "${major}" in
523                     tts) devfs="ttyS${minor}";;
524                     printers) devfs="lp${minor}";;
525                 esac
526         fi
527         if [ -n "${devfs}" ]; then
528                 device="${devfs}"
529         else
530                 programMessage "unsupported devfs device: ${device}"
531         fi
532 }
533
534 makeHeaderLine()
535 {
536         echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
537 }
538 makeParameterLine()
539 {
540         echo "# Boot Parameter:${bootParameter}"
541 }
542 putConfigurationFile()
543 {
544         startConfigurationFile
545         [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
546         [ -n "${brailleDevice}" ] && {
547         device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
548         if [ "${device#/}" = "${device}" ]; then
549                 translateDevice_${deviceTranslation}
550         fi
551         putConfigurationDirective "braille-device" "${device}"
552         }
553         [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
554         finalizeConfigurationFile
555 }
556 parseBootParameter()
557 {
558         bootParameter="${bootParameter} ${1}"
559         number=1
560         while [ "${number}" -le 3 ]; do
561                 cut="cut -d, -f${number}"
562                 [ "${number}" -gt 1 ] && cut="${cut} -s"
563                 operand="`echo ${1} | ${cut}`"
564                 if [ -n "${operand}" ]; then
565                         case "${number}" in
566                             1) brailleDriver="${operand}";;
567                             2) brailleDevice="${operand}";;
568                             3) textTable="${operand}";;
569                         esac
570                 fi
571                 number="`expr ${number} + 1`"
572         done
573 }
574 putBootParameter()
575 {
576         parseBootParameter "${1}"
577         putConfigurationFile
578 }
579 parseBootCommand()
580 {
581         found=false
582         while [ "${#}" -gt 0 ]; do
583                 case "${1}" in
584                     "brltty="*)
585                         found=true
586                         parseBootParameter "${1#*=}"
587                         ;;
588                 esac
589                 shift
590         done
591         "${found}" && putConfigurationFile
592 }
593
594 brailleDriver=""
595 brailleDevice=""
596 textTable=""
597 bootCommandFile="/proc/cmdline"
598 if [ -n "${requestedParameter}" ]; then
599         putBootParameter "${requestedParameter}"
600 elif [ -f "${bootCommandFile}" ]; then
601         parseBootCommand `cat "${bootCommandFile}"`
602 elif [ -n "${brltty}" ]; then
603         putBootParameter "${brltty}"
604 fi
605 exit 0
606 )
607
608 %post   -n brlapi -p /sbin/ldconfig
609 %postun -n brlapi -p /sbin/ldconfig
610
611 %files -f %{name}.lang
612 %defattr(644,root,root,755)
613 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
614 %doc doc/{Bindings,Bootdisks,Drivers,Patches,Tables,README}
615 %attr(755,root,root) %{_bindir}/brltty
616 %attr(755,root,root) %{_bindir}/brltty-config
617 %attr(755,root,root) %{_bindir}/brltty-ctb
618 %attr(755,root,root) %{_bindir}/brltty-trtxt
619 %attr(755,root,root) %{_bindir}/brltty-ttb
620 %attr(755,root,root) %{_bindir}/eutp
621 %attr(755,root,root) %{_bindir}/vstp
622 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
623 %dir %{_libdir}/brltty
624 # Braille drivers
625 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
626 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
627 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
628 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
629 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
630 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
631 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
632 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
633 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
634 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
635 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
636 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
637 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
638 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhd.so
639 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
640 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
641 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
642 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
643 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
644 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
645 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
646 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
647 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
648 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
649 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
650 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
651 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
652 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
653 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
654 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
655 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
656 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
657 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
658 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
659 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
660 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
661 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
662 # speech synthesizer drivers
663 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
664 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
665 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
666 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
667 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
668 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
669 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
670 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
671 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
672 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
673 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
674 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
675 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
676 # screen drivers
677 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
678 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
679 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
680 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
681 %{_sysconfdir}/brltty
682 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
683 /usr/lib/tmpfiles.d/brltty.conf
684 %dir /var/lib/BrlAPI
685 %dir /var/run/brltty
686 %{_mandir}/man1/brltty.1*
687 %{_mandir}/man1/eutp.1*
688 %{_mandir}/man1/vstp.1*
689 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
690
691 %if %{with x}
692 # gdm autostart - subpackage?
693 #%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
694 %endif
695
696 %files -n brlapi
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
699 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.6
700
701 %files -n brlapi-devel
702 %defattr(644,root,root,755)
703 %doc Documents/Manual-BrlAPI/English/BrlAPI*
704 %attr(755,root,root) %{_libdir}/libbrlapi.so
705 %{_includedir}/brltty
706 %{_includedir}/brlapi*.h
707 %{_mandir}/man3/brlapi_*.3*
708
709 %files -n brlapi-static
710 %defattr(644,root,root,755)
711 %{_libdir}/libbrlapi.a
712
713 %if %{with apidocs}
714 %files -n brlapi-apidocs
715 %defattr(644,root,root,755)
716 %doc Documents/BrlAPIref/html/*
717 %endif
718
719 %if %{with java}
720 %files -n java-brlapi
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
723 %{_javadir}/brlapi.jar
724 %endif
725
726 %if %{with ocaml}
727 %files -n ocaml-brlapi
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
730
731 %files -n ocaml-brlapi-devel
732 %defattr(644,root,root,755)
733 %dir %{_libdir}/ocaml/brlapi
734 %{_libdir}/ocaml/brlapi/META
735 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
736 %{_libdir}/ocaml/brlapi/brlapi.mli
737 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
738 %endif
739
740 %if %{with python}
741 %files -n python-brlapi
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{py_sitedir}/brlapi.so
744 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
745
746 %if %{with python3}
747 %files -n python3-brlapi
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{py3_sitedir}/brlapi.cpython-*.so
750 %{py3_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
751 %endif
752 %endif
753
754 %if %{with tcl}
755 %files -n brlapi-tcl
756 %defattr(644,root,root,755)
757 %dir %{_libdir}/brlapi-%{brlapi_ver}
758 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
759 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
760 %endif
This page took 0.081223 seconds and 2 git commands to generate.