]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
589d9837c530efcbdd9c197ba459053ee95409dc
[packages/brltty.git] / brltty.spec
1 # TODO:
2 #       - what is that huge %post script?
3 #
4 # Conditional build:
5 %bcond_without  apidocs                 # documentation generated with doxygen
6 %bcond_without  java                    # Java bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  tcl                     # Tcl bindings
10 %bcond_without  x                       # X11-based utilities
11 %bcond_without  gpm                     # mouse tracking via GPM
12 %bcond_without  libbraille              # libbraille Braille driver
13 %bcond_without  espeak                  # eSpeak synthesizer driver
14 %bcond_without  flite                   # Flite synthesizer driver
15 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
16 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
17 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
18 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
19 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
20 %bcond_without  at_spi                  # AtSpi screen driver
21 %bcond_without  at_spi2                 # AtSpi2 screen driver
22 #
23 %define         brlapi_ver      0.6.0
24 #
25 %include        /usr/lib/rpm/macros.java
26 Summary:        Braille display driver for Linux/Unix
27 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
28 Name:           brltty
29 Version:        4.5
30 Release:        2
31 Group:          Daemons
32 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
33 Source0:        http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
34 # Source0-md5:  7b52fa7746fed41ed344a1f75ce55951
35 Patch0:         %{name}-stat.patch
36 Patch1:         %{name}-java.patch
37 Patch2:         %{name}-speech-dispatcher.patch
38 URL:            http://mielke.cc/brltty/
39 BuildRequires:  alsa-lib-devel
40 %{?with_at_spi:BuildRequires:   at-spi-devel}
41 BuildRequires:  autoconf >= 2.62
42 BuildRequires:  automake
43 BuildRequires:  bison
44 # just headers
45 BuildRequires:  bluez-libs-devel
46 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
47 %{?with_apidocs:BuildRequires:  doxygen}
48 %{?with_espeak:BuildRequires:   espeak-devel}
49 %{?with_flite:BuildRequires:    flite-devel}
50 %{?with_gpm:BuildRequires:      gpm-devel}
51 %{?with_java:BuildRequires:     jdk}
52 %{?with_java:BuildRequires:     jpackage-utils}
53 %{?with_libbraille:BuildRequires:       libbraille-devel}
54 BuildRequires:  libicu-devel
55 BuildRequires:  ncurses-devel
56 %{?with_ocaml:BuildRequires:    ocaml}
57 BuildRequires:  pkgconfig
58 %{?with_python:BuildRequires:   python-Pyrex}
59 %{?with_java:BuildRequires:     rpm-javaprov}
60 %{?with_python:BuildRequires:   rpm-pythonprov}
61 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
62 %{?with_tcl:BuildRequires:      tcl-devel}
63 %if %{with x}
64 BuildRequires:  xorg-lib-libX11-devel
65 BuildRequires:  xorg-lib-libXaw-devel
66 BuildRequires:  xorg-lib-libXext-devel
67 BuildRequires:  xorg-lib-libXt-devel
68 BuildRequires:  xorg-lib-libXtst-devel
69 %endif
70 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
71 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
72 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
73 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 BRLTTY is a background process (daemon) which provides access to the
78 Linux/Unix console (when in text mode) for a blind person using a
79 refreshable Braille display. It drives the Braille display, and
80 provides complete screen review functionality. Some speech capability
81 has also been incorporated.
82
83 %description -l pl.UTF-8
84 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
85 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
86 odświeżaniem (refreshable Braille display). BRLTTY steruje
87 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
88 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
89 mowy.
90
91 %package -n brlapi
92 Summary:        Application Programming Interface for BRLTTY
93 Summary(pl.UTF-8):      API do BRLTTY
94 License:        LGPL v2.1+
95 Group:          Libraries
96
97 %description -n brlapi
98 This package provides the run-time support for the Application
99 Programming Interface to BRLTTY.
100
101 Install this package if you have an application which directly
102 accesses a refreshable Braille display.
103
104 %description -n brlapi -l pl.UTF-8
105 Ten pakiet zawiera środowisko uruchomieniowe dla programów
106 korzystających z API BRLTTY.
107
108 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
109 wyświetlacza Braille'a z odświeżaniem.
110
111 %package -n brlapi-devel
112 Summary:        Headers and documentation for BrlAPI
113 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
114 License:        LGPL v2.1+
115 Group:          Development/Libraries
116 Requires:       brlapi = %{version}-%{release}
117
118 %description -n brlapi-devel
119 This package provides the header files, shared object linker
120 reference, and reference documentation for BrlAPI (the Application
121 Programming Interface to BRLTTY). It enables the implementation of
122 applications which take direct advantage of a refreshable Braille
123 display in order to present information in ways which are more
124 appropriate for blind users and/or to provide user interfaces which
125 are more specifically atuned to their needs.
126
127 Install this package if you're developing or maintaining an
128 application which directly accesses a refreshable Braille display.
129
130 %description -n brlapi-devel -l pl.UTF-8
131 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
132 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
133 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
134 bardziej przystosowany dla osób niewidomych.
135
136 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
137 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
138
139 %package -n brlapi-static
140 Summary:        Static BrlAPI library
141 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
142 License:        LGPL v2.1+
143 Group:          Development/Libraries
144 Requires:       brlapi-devel = %{version}-%{release}
145
146 %description -n brlapi-static
147 This is package with static BrlAPI library.
148
149 %description -n brlapi-static -l pl.UTF-8
150 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
151
152 %package -n brlapi-apidocs
153 Summary:        BrlAPI documentation
154 Summary(pl.UTF-8):      Documentacja BrlAPI
155 Group:          Documentation
156
157 %description -n brlapi-apidocs
158 Documentation for BrlAPI in HTML format generated from brltty
159 sources by doxygen.
160
161 %description -n brlapi-apidocs -l pl.UTF-8
162 Dokumentacja BrlAPI w formacie HTML generowane ze
163 źrodeł brltty przez doxygen.
164
165 %package -n java-brlapi
166 Summary:        BrlAPI library for Java
167 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
168 License:        LGPL v2.1+
169 Group:          Libraries
170 Requires:       brlapi = %{version}-%{release}
171
172 %description -n java-brlapi
173 BrlAPI library for Java.
174
175 %description -n java-brlapi -l pl.UTF-8
176 Biblioteka BrlAPI dla Javy.
177
178 %package -n ocaml-brlapi
179 Summary:        OCaml binding for BrlAPI
180 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
181 License:        LGPL v2.1+
182 Group:          Libraries
183 Requires:       brlapi = %{version}-%{release}
184 %requires_eq    ocaml-runtime
185
186 %description -n ocaml-brlapi
187 OCaml binding for BrlAPI.
188
189 %description -n ocaml-brlapi -l pl.UTF-8
190 Wiązania OCamla do BrlAPI.
191
192 %package -n ocaml-brlapi-devel
193 Summary:        OCaml binding for BrlAPI - development files
194 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
195 License:        LGPL v2.1+
196 Group:          Libraries
197 Requires:       ocaml-brlapi = %{version}-%{release}
198 %requires_eq    ocaml
199
200 %description -n ocaml-brlapi-devel
201 OCaml binding for BrlAPI - development files.
202
203 %description -n ocaml-brlapi-devel -l pl.UTF-8
204 Wiązania OCamla do BrlAPI - pliki programistyczne.
205
206 %package -n python-brlapi
207 Summary:        Python interface to BrlAPI
208 Summary(pl.UTF-8):      Pythonowy interfejs do BrlAPI
209 License:        LGPL v2.1+
210 Group:          Libraries
211 Requires:       brlapi = %{version}-%{release}
212
213 %description -n python-brlapi
214 Python interface to BrlAPI.
215
216 %description -n python-brlapi -l pl.UTF-8
217 Pythonowy interfejs do BrlAPI.
218
219 %package -n brlapi-tcl
220 Summary:        BrlAPI library for Tcl
221 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
222 License:        LGPL v2.1+
223 Group:          Libraries
224 Requires:       brlapi = %{version}-%{release}
225
226 %description -n brlapi-tcl
227 BrlAPI library for Tcl.
228
229 %description -n brlapi-tcl -l pl.UTF-8
230 Biblioteka BrlAPI dla Tcl.
231
232 %prep
233 %setup -q
234 %patch0 -p1
235 %patch1 -p1
236 %patch2 -p1
237
238 %build
239 %{__autoconf}
240 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
241 %configure \
242         %{?with_java:JAVA_HOME=%{java_home}} \
243         --with-install-root="$RPM_BUILD_ROOT" \
244         %{!?with_libbraille:--without-libbraille} \
245         %{!?with_espeak:--without-espeak} \
246         %{!?with_flite:--without-flite} \
247         %{!?with_speech_dispatcher:--without-speechd} \
248         %{!?with_ocaml:--disable-caml-bindings} \
249         %{!?with_gpm:--disable-gpm} \
250         %{!?with_java:--disable-java-bindings} \
251         %{!?with_python:--disable-python-bindings} \
252         %{!?with_tcl:--disable-tcl-bindings} \
253         %{!?with_x:--disable-x} \
254         --enable-api
255
256 %{__make} -j1
257
258 directory="doc"
259 mkdir -p "$directory"
260 for file in `find . \( -path "./$directory" -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print`
261 do
262         mkdir -p "$directory/${file%/*}"
263         cp -rp "$file" "$directory/$file"
264 done
265
266 %install
267 rm -rf $RPM_BUILD_ROOT
268
269 %{__make} -j1 install \
270         OCAML_INSTALL_TARGET=install-without-findlib
271
272 %if %{_lib} != "lib"
273         # Fix java plugin install path on 64-bit archs
274         install -d $RPM_BUILD_ROOT%{_libdir}/java
275         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
276 %endif
277
278 install Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
279
280 install -d $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
281 cat >$RPM_BUILD_ROOT/usr/lib/tmpfiles.d/brltty.conf <<EOF
282 d /var/run/brltty 0755 root root -
283 EOF
284
285 %clean
286 rm -rf $RPM_BUILD_ROOT
287
288 %pre
289 # The pre-install scriptlet.
290
291 # If a configuration file already exists then rpm installs the new one as
292 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
293 # already exists.
294
295 # There's no explicit way to tell if a configuration file has been installed
296 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
297 # erasing the .rpmnew file now so that we can see if it gets created later.
298 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
299
300 %post
301 # The post-install scriptlet.
302
303 # If BRLTTY's boot parameter has been specified then update the just installed
304 # configuration file template to reflect the options supplied thereby.
305
306 # First, we need to determine which file to update. If there's a .rpmnew file
307 # then update it since a previous configuration file must already have existed.
308 file="%{_sysconfdir}/brltty.conf"
309 new="${file}.rpmnew"
310 [ -f "${new}" ] && file="${new}"
311
312 # Update the configuration file template via the Bootdisks/bp2cf script.
313 # Include it right within this scriptlet so that it needn't be installed.
314 # Imbed it within a subshell to ensure that it won't impact this scriptlet.
315 (
316         # First, set bp2cf's command line arguments.
317         set -- -u -f "${file}"
318
319 #!/bin/sh
320 ###############################################################################
321 # BRLTTY - A background process providing access to the Linux console (when in
322 #          text mode) for a blind person using a refreshable Braille display.
323 #
324 # Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
325 #
326 # BRLTTY comes with ABSOLUTELY NO WARRANTY.
327 #
328 # This is free software, placed under the terms of the
329 # GNU General Public License, as published by the Free Software
330 # Foundation.  Please see the file COPYING for details.
331 #
332 # Web Page: http://mielke.cc/brltty/
333 #
334 # This software is maintained by Dave Mielke <dave@mielke.cc>.
335 ###############################################################################
336
337 # Convert the boot parameter to configuration file directives.
338 # If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
339 # If /proc is not mounted then use the brltty environment variable.
340 # Invoke with -h for usage information.
341
342 programName="${0##*/}"
343 programMessage()
344 {
345         echo 2>&1 "${programName}: ${1}"
346 }
347 syntaxError()
348 {
349         programMessage "${1}"
350         exit 2
351 }
352 internalError()
353 {
354         programMessage "${1}"
355         exit 3
356 }
357
358 configurationFile=""
359 requestedAction=create
360 deviceTranslation=none
361 requestedParameter=""
362 OPTIND=1
363 while getopts ":f:cundop:h" option
364 do
365         case "${option}" in
366             f) configurationFile="${OPTARG}";;
367             c) requestedAction=create;;
368             u) requestedAction=update;;
369             n) deviceTranslation=none;;
370             d) deviceTranslation=devfs;;
371             o) deviceTranslation=old;;
372             p) requestedParameter="${OPTARG}";;
373             h)
374                 cat <<EOF
375 Usage: ${programName} [option ...]
376 -f file  The configuration file to create/update.
377 -c       Create the configuration file (write to stdout if no -f).
378 -u       Update the configuration file (copying from stdin to stdout if no -f).
379 -n       Do not translate device paths.
380 -d       Do old-style to devfs device path translation.
381 -o       Do devfs to old-style device path translation.
382 -p [driver][,[device][,[table]]]
383          Explicitly specify the boot parameter.
384 -h       Display this usage summary.
385 EOF
386                 exit 0
387                 ;;
388             \?) syntaxError "unknown option: -${OPTARG}";;
389             :) syntaxError "missing value: -${OPTARG}";;
390             *) internalError "unimplemented option: -${option}";;
391         esac
392 done
393 shift "`expr $OPTIND - 1`"
394 [ "${#}" -eq 0 ] || syntaxError "too many parameters."
395
396 case "${requestedAction}" in
397     create)
398         putConfigurationLine()
399         {
400                 echo "${1}" || exit 4
401         }
402         startConfigurationFile()
403         {
404                 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
405                 putConfigurationLine "`makeHeaderLine Created`"
406                 putConfigurationLine "`makeParameterLine`"
407                 putConfigurationLine ""
408         }
409         putConfigurationDirective()
410         {
411                 putConfigurationLine "${1} ${2}"
412         }
413         finalizeConfigurationFile()
414         {
415                 :
416         }
417         ;;
418     update)
419         putSedCommand()
420         {
421                 sedScript="${sedScript}
422 ${1}"
423         }
424         startConfigurationFile()
425         {
426                 if [ -n "${configurationFile}" ]; then
427                         [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
428                         [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
429                         [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
430                         [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
431                         outputFile="${configurationFile}.new"
432                         exec <"${configurationFile}" >"${outputFile}"
433                 fi
434                 sedScript=""
435                 putSedCommand "1i\\
436 `makeHeaderLine Updated`\\
437 `makeParameterLine`\\
438 "
439         }
440         putConfigurationDirective()
441         {
442                 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
443                 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
444                 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
445         }
446         finalizeConfigurationFile()
447         {
448                 sed -e "${sedScript}"
449                 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
450         }
451         ;;
452     *) internalError "unimplemented action: ${requestedAction}";;
453 esac
454
455 translateDevice_none()
456 {
457         :
458 }
459 translateDevice_devfs()
460 {
461         minor="${device#ttyS}"
462         if [ "${minor}" != "${device}" ]; then
463                 device="tts/${minor}"
464                 return 0
465         fi
466         minor="${device#lp}"
467         if [ "${minor}" != "${device}" ]; then
468                 device="printers/${minor}"
469                 return 0
470         fi
471         programMessage "unsupported old-style device: ${device}"
472 }
473 translateDevice_old()
474 {
475         major="${device%%/*}"
476         if [ "${major}" != "${device}" ]; then
477                 minor="${device#*/}"
478                 case "${major}" in
479                     tts) devfs="ttyS${minor}";;
480                     printers) devfs="lp${minor}";;
481                 esac
482         fi
483         if [ -n "${devfs}" ]; then
484                 device="${devfs}"
485         else
486                 programMessage "unsupported devfs device: ${device}"
487         fi
488 }
489
490 makeHeaderLine()
491 {
492         echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
493 }
494 makeParameterLine()
495 {
496         echo "# Boot Parameter:${bootParameter}"
497 }
498 putConfigurationFile()
499 {
500         startConfigurationFile
501         [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
502         [ -n "${brailleDevice}" ] && {
503         device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
504         if [ "${device#/}" = "${device}" ]; then
505                 translateDevice_${deviceTranslation}
506         fi
507         putConfigurationDirective "braille-device" "${device}"
508         }
509         [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
510         finalizeConfigurationFile
511 }
512 parseBootParameter()
513 {
514         bootParameter="${bootParameter} ${1}"
515         number=1
516         while [ "${number}" -le 3 ]; do
517                 cut="cut -d, -f${number}"
518                 [ "${number}" -gt 1 ] && cut="${cut} -s"
519                 operand="`echo ${1} | ${cut}`"
520                 if [ -n "${operand}" ]; then
521                         case "${number}" in
522                             1) brailleDriver="${operand}";;
523                             2) brailleDevice="${operand}";;
524                             3) textTable="${operand}";;
525                         esac
526                 fi
527                 number="`expr ${number} + 1`"
528         done
529 }
530 putBootParameter()
531 {
532         parseBootParameter "${1}"
533         putConfigurationFile
534 }
535 parseBootCommand()
536 {
537         found=false
538         while [ "${#}" -gt 0 ]; do
539                 case "${1}" in
540                     "brltty="*)
541                         found=true
542                         parseBootParameter "${1#*=}"
543                         ;;
544                 esac
545                 shift
546         done
547         "${found}" && putConfigurationFile
548 }
549
550 brailleDriver=""
551 brailleDevice=""
552 textTable=""
553 bootCommandFile="/proc/cmdline"
554 if [ -n "${requestedParameter}" ]; then
555         putBootParameter "${requestedParameter}"
556 elif [ -f "${bootCommandFile}" ]; then
557         parseBootCommand `cat "${bootCommandFile}"`
558 elif [ -n "${brltty}" ]; then
559         putBootParameter "${brltty}"
560 fi
561 exit 0
562 )
563
564 %post   -n brlapi -p /sbin/ldconfig
565 %postun -n brlapi -p /sbin/ldconfig
566
567 %files
568 %defattr(644,root,root,755)
569 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
570 %doc doc/{Bindings,Bootdisks,Drivers,Patches,Tables,README,nsistrings.txt}
571 %attr(755,root,root) %{_bindir}/brltty
572 %attr(755,root,root) %{_bindir}/brltty-config
573 %attr(755,root,root) %{_bindir}/brltty-ctb
574 %attr(755,root,root) %{_bindir}/brltty-install
575 %attr(755,root,root) %{_bindir}/brltty-trtxt
576 %attr(755,root,root) %{_bindir}/brltty-ttb
577 %attr(755,root,root) %{_bindir}/vstp
578 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
579 %dir %{_libdir}/brltty
580 # Braille drivers
581 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
582 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
583 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
584 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
585 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
586 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
587 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
588 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
589 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
590 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
591 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
592 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
593 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
594 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
595 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
596 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
597 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
598 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
599 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
600 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
601 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
602 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
603 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
604 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
605 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
606 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
607 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
608 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
609 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
610 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
611 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
612 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
613 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
614 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
615 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
616 # speech synthesizer drivers
617 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
618 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
619 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
620 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
621 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
622 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
623 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
624 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
625 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
626 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
627 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
628 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
629 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
630 # screen drivers
631 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
632 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
633 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
634 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
635 %{_sysconfdir}/brltty
636 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
637 /usr/lib/tmpfiles.d/brltty.conf
638 %dir /var/lib/BrlAPI
639 %dir /var/run/brltty
640 %{_mandir}/man1/brltty.1*
641 %{_mandir}/man1/vstp.1*
642 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
643
644 %files -n brlapi
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
647 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.6
648
649 %files -n brlapi-devel
650 %defattr(644,root,root,755)
651 %doc Documents/Manual-BrlAPI/English/BrlAPI*
652 %attr(755,root,root) %{_libdir}/libbrlapi.so
653 %{_includedir}/brltty
654 %{_includedir}/brlapi*.h
655 %{_mandir}/man3/brlapi_*.3*
656
657 %files -n brlapi-static
658 %defattr(644,root,root,755)
659 %{_libdir}/libbrlapi.a
660
661 %if %{with apidocs}
662 %files -n brlapi-apidocs
663 %defattr(644,root,root,755)
664 %doc Documents/BrlAPIref/html/*
665 %endif
666
667 %if %{with java}
668 %files -n java-brlapi
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
671 %{_javadir}/brlapi.jar
672 %endif
673
674 %if %{with ocaml}
675 %files -n ocaml-brlapi
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
678 %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
679
680 %files -n ocaml-brlapi-devel
681 %defattr(644,root,root,755)
682 %dir %{_libdir}/ocaml/brlapi
683 %{_libdir}/ocaml/brlapi/META
684 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
685 %{_libdir}/ocaml/brlapi/brlapi.mli
686 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
687 %endif
688
689 %if %{with python}
690 %files -n python-brlapi
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{py_sitedir}/brlapi.so
693 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
694 %endif
695
696 %if %{with tcl}
697 %files -n brlapi-tcl
698 %defattr(644,root,root,755)
699 %dir %{_libdir}/brlapi-%{brlapi_ver}
700 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
701 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
702 %endif
This page took 0.084479 seconds and 2 git commands to generate.