]> git.pld-linux.org Git - packages/brltty.git/blame - brltty.spec
- fix python binding build error:
[packages/brltty.git] / brltty.spec
CommitLineData
3704768a 1# TODO:
e6a1be7c 2# - what is that huge %post script?
42577d78 3#
608626ec 4# Conditional build:
82b1c71c 5%bcond_without apidocs # documentation generated with doxygen
3dcc4a01 6%bcond_without java # Java bindings
82b1c71c
JB
7%bcond_without ocaml # OCaml bindings
8%bcond_without python # Python bindings
9%bcond_without tcl # Tcl bindings
10%bcond_without x # X11-based utilities
11%bcond_without gpm # mouse tracking via GPM
509de961 12%bcond_without libbraille # libbraille Braille driver
82b1c71c
JB
13%bcond_without espeak # eSpeak synthesizer driver
14%bcond_without flite # Flite synthesizer driver
dfe38ff6 15%bcond_with mikropuhe # Mikropuhe synthesizer driver [commercial, Finnish]
82b1c71c 16%bcond_without speech_dispatcher # Speech Dispatcher synthesizer driver
dfe38ff6
JB
17%bcond_with swift # Swift synthesizer driver [commercial, from Cepstral]
18%bcond_with theta # Theta synthesizer driver [commercial, from Cepstral]
19%bcond_with viavoice # IBM ViaVoice synthesizer driver [commercial]
509de961
JB
20%bcond_without at_spi # AtSpi screen driver
21%bcond_without at_spi2 # AtSpi2 screen driver
22#
0b1afa7b 23%define brlapi_ver 0.6.0
608626ec 24#
332e4348 25%include /usr/lib/rpm/macros.java
9b20373a 26Summary: Braille display driver for Linux/Unix
8731bfde 27Summary(pl.UTF-8): Sterownik do wyświetlaczy Braille'a
91162002 28Name: brltty
0b1afa7b 29Version: 4.5
9c5b0c32 30Release: 3
9b20373a 31Group: Daemons
3dcc4a01 32License: GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
91162002 33Source0: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
0b1afa7b 34# Source0-md5: 7b52fa7746fed41ed344a1f75ce55951
6c9c25b1 35Patch0: %{name}-stat.patch
0b1afa7b
JB
36Patch1: %{name}-java.patch
37Patch2: %{name}-speech-dispatcher.patch
9c5b0c32 38Patch3: %{name}-python.patch
1a7665e9 39URL: http://mielke.cc/brltty/
82b1c71c
JB
40BuildRequires: alsa-lib-devel
41%{?with_at_spi:BuildRequires: at-spi-devel}
42577d78 42BuildRequires: autoconf >= 2.62
664a738b 43BuildRequires: automake
91162002 44BuildRequires: bison
82b1c71c
JB
45# just headers
46BuildRequires: bluez-libs-devel
47%{?with_at_spi2:BuildRequires: dbus-devel >= 1.0}
608626ec 48%{?with_apidocs:BuildRequires: doxygen}
ed3025fe 49%{?with_espeak:BuildRequires: espeak-devel}
dfe38ff6 50%{?with_flite:BuildRequires: flite-devel}
82b1c71c 51%{?with_gpm:BuildRequires: gpm-devel}
09255552 52%{?with_java:BuildRequires: jdk}
0b1afa7b 53%{?with_java:BuildRequires: jpackage-utils}
dfe38ff6 54%{?with_libbraille:BuildRequires: libbraille-devel}
82b1c71c 55BuildRequires: libicu-devel
eb77b64b 56BuildRequires: ncurses-devel
6913fe15 57%{?with_ocaml:BuildRequires: ocaml}
ac744b8d 58BuildRequires: pkgconfig
0bb357f1 59%{?with_python:BuildRequires: python-Pyrex}
332e4348 60%{?with_java:BuildRequires: rpm-javaprov}
0bb357f1 61%{?with_python:BuildRequires: rpm-pythonprov}
0b1afa7b 62%{?with_speech_dispatcher:BuildRequires: speech-dispatcher-devel >= 0.8}
5fa6377b 63%{?with_tcl:BuildRequires: tcl-devel}
82b1c71c
JB
64%if %{with x}
65BuildRequires: xorg-lib-libX11-devel
66BuildRequires: xorg-lib-libXaw-devel
67BuildRequires: xorg-lib-libXext-devel
68BuildRequires: xorg-lib-libXt-devel
69BuildRequires: xorg-lib-libXtst-devel
70%endif
dfe38ff6
JB
71#%{?with_mikropuhe:BuildRequires: Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
72#%{?with_swift:BuildRequires: Swift-devel (-lswift <swift.h>)}
73#%{?with_theta:BuildRequires: Theta-devel (-ltheta <theta.h>)}
74#%{?with_viavoice:BuildRequires: ViaVoice-devel (-libmeci50 <eci.h>)}
91162002 75BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77%description
78BRLTTY is a background process (daemon) which provides access to the
79Linux/Unix console (when in text mode) for a blind person using a
33e3c5f9 80refreshable Braille display. It drives the Braille display, and
3b0ec988 81provides complete screen review functionality. Some speech capability
91162002 82has also been incorporated.
83
54f59947
JR
84%description -l pl.UTF-8
85BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
86trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
87odświeżaniem (refreshable Braille display). BRLTTY steruje
88wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
89przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
9b20373a 90mowy.
91162002 91
92%package -n brlapi
9b20373a 93Summary: Application Programming Interface for BRLTTY
8731bfde 94Summary(pl.UTF-8): API do BRLTTY
3dcc4a01
JB
95License: LGPL v2.1+
96Group: Libraries
91162002 97
98%description -n brlapi
99This package provides the run-time support for the Application
100Programming Interface to BRLTTY.
101
9b20373a 102Install this package if you have an application which directly
103accesses a refreshable Braille display.
91162002 104
54f59947
JR
105%description -n brlapi -l pl.UTF-8
106Ten pakiet zawiera środowisko uruchomieniowe dla programów
107korzystających z API BRLTTY.
91162002 108
54f59947
JR
109Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
110wyświetlacza Braille'a z odświeżaniem.
91162002 111
112%package -n brlapi-devel
9b20373a 113Summary: Headers and documentation for BrlAPI
8731bfde 114Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do BrlAPI
3dcc4a01 115License: LGPL v2.1+
3b0ec988 116Group: Development/Libraries
664a738b 117Requires: brlapi = %{version}-%{release}
91162002 118
119%description -n brlapi-devel
9b20373a 120This package provides the header files, shared object linker
121reference, and reference documentation for BrlAPI (the Application
3b0ec988 122Programming Interface to BRLTTY). It enables the implementation of
9b20373a 123applications which take direct advantage of a refreshable Braille
124display in order to present information in ways which are more
125appropriate for blind users and/or to provide user interfaces which
126are more specifically atuned to their needs.
91162002 127
3b0ec988 128Install this package if you're developing or maintaining an
129application which directly accesses a refreshable Braille display.
91162002 130
54f59947
JR
131%description -n brlapi-devel -l pl.UTF-8
132Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
133do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
134korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
135bardziej przystosowany dla osób niewidomych.
91162002 136
54f59947
JR
137Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
138korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
91162002 139
140%package -n brlapi-static
9b20373a 141Summary: Static BrlAPI library
8731bfde 142Summary(pl.UTF-8): Statyczna biblioteka BrlAPI
3dcc4a01 143License: LGPL v2.1+
3b0ec988 144Group: Development/Libraries
664a738b 145Requires: brlapi-devel = %{version}-%{release}
91162002 146
147%description -n brlapi-static
9b20373a 148This is package with static BrlAPI library.
91162002 149
54f59947
JR
150%description -n brlapi-static -l pl.UTF-8
151Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
91162002 152
608626ec
SS
153%package -n brlapi-apidocs
154Summary: BrlAPI documentation
155Summary(pl.UTF-8): Documentacja BrlAPI
156Group: Documentation
157
158%description -n brlapi-apidocs
159Documentation for BrlAPI in HTML format generated from brltty
160sources by doxygen.
161
162%description -n brlapi-apidocs -l pl.UTF-8
163Dokumentacja BrlAPI w formacie HTML generowane ze
164źrodeł brltty przez doxygen.
165
332e4348 166%package -n java-brlapi
09255552
SS
167Summary: BrlAPI library for Java
168Summary(pl.UTF-8): Biblioteka BrlAPI dla Javy
3dcc4a01 169License: LGPL v2.1+
09255552
SS
170Group: Libraries
171Requires: brlapi = %{version}-%{release}
172
332e4348 173%description -n java-brlapi
09255552
SS
174BrlAPI library for Java.
175
332e4348 176%description -n java-brlapi -l pl.UTF-8
09255552
SS
177Biblioteka BrlAPI dla Javy.
178
82b1c71c
JB
179%package -n ocaml-brlapi
180Summary: OCaml binding for BrlAPI
181Summary(pl.UTF-8): Wiązania OCamla do BrlAPI
3dcc4a01 182License: LGPL v2.1+
82b1c71c
JB
183Group: Libraries
184Requires: brlapi = %{version}-%{release}
185%requires_eq ocaml-runtime
186
187%description -n ocaml-brlapi
188OCaml binding for BrlAPI.
189
190%description -n ocaml-brlapi -l pl.UTF-8
191Wiązania OCamla do BrlAPI.
192
193%package -n ocaml-brlapi-devel
194Summary: OCaml binding for BrlAPI - development files
195Summary(pl.UTF-8): Wiązania OCamla do BrlAPI - pliki programistyczne
3dcc4a01 196License: LGPL v2.1+
82b1c71c
JB
197Group: Libraries
198Requires: ocaml-brlapi = %{version}-%{release}
199%requires_eq ocaml
200
201%description -n ocaml-brlapi-devel
202OCaml binding for BrlAPI - development files.
203
204%description -n ocaml-brlapi-devel -l pl.UTF-8
205Wiązania OCamla do BrlAPI - pliki programistyczne.
206
0bb357f1
SS
207%package -n python-brlapi
208Summary: Python interface to BrlAPI
209Summary(pl.UTF-8): Pythonowy interfejs do BrlAPI
3dcc4a01 210License: LGPL v2.1+
0bb357f1
SS
211Group: Libraries
212Requires: brlapi = %{version}-%{release}
213
214%description -n python-brlapi
215Python interface to BrlAPI.
216
217%description -n python-brlapi -l pl.UTF-8
218Pythonowy interfejs do BrlAPI.
219
220%package -n brlapi-tcl
221Summary: BrlAPI library for Tcl
222Summary(pl.UTF-8): Biblioteka BrlAPI dla Tcl
3dcc4a01 223License: LGPL v2.1+
0bb357f1
SS
224Group: Libraries
225Requires: brlapi = %{version}-%{release}
226
227%description -n brlapi-tcl
228BrlAPI library for Tcl.
229
230%description -n brlapi-tcl -l pl.UTF-8
231Biblioteka BrlAPI dla Tcl.
232
91162002 233%prep
234%setup -q
6c9c25b1 235%patch0 -p1
0b1afa7b
JB
236%patch1 -p1
237%patch2 -p1
9c5b0c32 238%patch3 -p1
91162002 239
240%build
0b1afa7b 241%{__autoconf}
915167f5 242CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
664a738b 243%configure \
0b1afa7b 244 %{?with_java:JAVA_HOME=%{java_home}} \
664a738b 245 --with-install-root="$RPM_BUILD_ROOT" \
509de961 246 %{!?with_libbraille:--without-libbraille} \
82b1c71c
JB
247 %{!?with_espeak:--without-espeak} \
248 %{!?with_flite:--without-flite} \
249 %{!?with_speech_dispatcher:--without-speechd} \
250 %{!?with_ocaml:--disable-caml-bindings} \
251 %{!?with_gpm:--disable-gpm} \
f50dc761 252 %{!?with_java:--disable-java-bindings} \
82b1c71c
JB
253 %{!?with_python:--disable-python-bindings} \
254 %{!?with_tcl:--disable-tcl-bindings} \
255 %{!?with_x:--disable-x} \
91162002 256 --enable-api
245bd38d
JR
257
258%{__make} -j1
91162002 259
260directory="doc"
261mkdir -p "$directory"
262for file in `find . \( -path "./$directory" -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print`
263do
9b20373a 264 mkdir -p "$directory/${file%/*}"
265 cp -rp "$file" "$directory/$file"
91162002 266done
267
268%install
269rm -rf $RPM_BUILD_ROOT
82b1c71c
JB
270
271%{__make} -j1 install \
272 OCAML_INSTALL_TARGET=install-without-findlib
273
538473c2
JR
274%if %{_lib} != "lib"
275 # Fix java plugin install path on 64-bit archs
276 install -d $RPM_BUILD_ROOT%{_libdir}/java
277 %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
278%endif
279
3b0ec988 280install Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
91162002 281
82b1c71c
JB
282install -d $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
283cat >$RPM_BUILD_ROOT/usr/lib/tmpfiles.d/brltty.conf <<EOF
284d /var/run/brltty 0755 root root -
285EOF
286
91162002 287%clean
288rm -rf $RPM_BUILD_ROOT
289
290%pre
291# The pre-install scriptlet.
292
293# If a configuration file already exists then rpm installs the new one as
294# <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
295# already exists.
296
297# There's no explicit way to tell if a configuration file has been installed
298# as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
3b0ec988 299# erasing the .rpmnew file now so that we can see if it gets created later.
91162002 300rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
301
302%post
303# The post-install scriptlet.
304
305# If BRLTTY's boot parameter has been specified then update the just installed
306# configuration file template to reflect the options supplied thereby.
307
308# First, we need to determine which file to update. If there's a .rpmnew file
309# then update it since a previous configuration file must already have existed.
310file="%{_sysconfdir}/brltty.conf"
311new="${file}.rpmnew"
312[ -f "${new}" ] && file="${new}"
313
314# Update the configuration file template via the Bootdisks/bp2cf script.
315# Include it right within this scriptlet so that it needn't be installed.
316# Imbed it within a subshell to ensure that it won't impact this scriptlet.
317(
c247b245 318 # First, set bp2cf's command line arguments.
319 set -- -u -f "${file}"
91162002 320
321#!/bin/sh
322###############################################################################
323# BRLTTY - A background process providing access to the Linux console (when in
9b20373a 324# text mode) for a blind person using a refreshable Braille display.
91162002 325#
326# Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
327#
328# BRLTTY comes with ABSOLUTELY NO WARRANTY.
329#
330# This is free software, placed under the terms of the
331# GNU General Public License, as published by the Free Software
332# Foundation. Please see the file COPYING for details.
333#
334# Web Page: http://mielke.cc/brltty/
335#
336# This software is maintained by Dave Mielke <dave@mielke.cc>.
337###############################################################################
338
339# Convert the boot parameter to configuration file directives.
340# If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
341# If /proc is not mounted then use the brltty environment variable.
342# Invoke with -h for usage information.
343
344programName="${0##*/}"
345programMessage()
346{
c247b245 347 echo 2>&1 "${programName}: ${1}"
91162002 348}
349syntaxError()
350{
c247b245 351 programMessage "${1}"
352 exit 2
91162002 353}
354internalError()
355{
c247b245 356 programMessage "${1}"
357 exit 3
91162002 358}
359
360configurationFile=""
361requestedAction=create
362deviceTranslation=none
363requestedParameter=""
364OPTIND=1
365while getopts ":f:cundop:h" option
366do
c247b245 367 case "${option}" in
368 f) configurationFile="${OPTARG}";;
369 c) requestedAction=create;;
370 u) requestedAction=update;;
371 n) deviceTranslation=none;;
372 d) deviceTranslation=devfs;;
373 o) deviceTranslation=old;;
374 p) requestedParameter="${OPTARG}";;
375 h)
376 cat <<EOF
91162002 377Usage: ${programName} [option ...]
378-f file The configuration file to create/update.
379-c Create the configuration file (write to stdout if no -f).
380-u Update the configuration file (copying from stdin to stdout if no -f).
381-n Do not translate device paths.
382-d Do old-style to devfs device path translation.
383-o Do devfs to old-style device path translation.
384-p [driver][,[device][,[table]]]
385 Explicitly specify the boot parameter.
386-h Display this usage summary.
387EOF
c247b245 388 exit 0
389 ;;
390 \?) syntaxError "unknown option: -${OPTARG}";;
391 :) syntaxError "missing value: -${OPTARG}";;
392 *) internalError "unimplemented option: -${option}";;
393 esac
91162002 394done
395shift "`expr $OPTIND - 1`"
396[ "${#}" -eq 0 ] || syntaxError "too many parameters."
397
c247b245 398case "${requestedAction}" in
399 create)
400 putConfigurationLine()
401 {
402 echo "${1}" || exit 4
403 }
404 startConfigurationFile()
405 {
406 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
407 putConfigurationLine "`makeHeaderLine Created`"
408 putConfigurationLine "`makeParameterLine`"
409 putConfigurationLine ""
410 }
411 putConfigurationDirective()
412 {
413 putConfigurationLine "${1} ${2}"
414 }
415 finalizeConfigurationFile()
416 {
417 :
418 }
419 ;;
420 update)
421 putSedCommand()
422 {
423 sedScript="${sedScript}
91162002 424${1}"
c247b245 425 }
426 startConfigurationFile()
427 {
106ddbb5 428 if [ -n "${configurationFile}" ]; then
c247b245 429 [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
430 [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
431 [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
432 [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
433 outputFile="${configurationFile}.new"
434 exec <"${configurationFile}" >"${outputFile}"
435 fi
436 sedScript=""
437 putSedCommand "1i\\
91162002 438`makeHeaderLine Updated`\\
439`makeParameterLine`\\
440"
c247b245 441 }
442 putConfigurationDirective()
443 {
444 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
445 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
446 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
447 }
448 finalizeConfigurationFile()
449 {
450 sed -e "${sedScript}"
451 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
452 }
453 ;;
454 *) internalError "unimplemented action: ${requestedAction}";;
91162002 455esac
456
457translateDevice_none()
458{
c247b245 459 :
91162002 460}
461translateDevice_devfs()
462{
c247b245 463 minor="${device#ttyS}"
106ddbb5 464 if [ "${minor}" != "${device}" ]; then
c247b245 465 device="tts/${minor}"
466 return 0
467 fi
468 minor="${device#lp}"
106ddbb5 469 if [ "${minor}" != "${device}" ]; then
c247b245 470 device="printers/${minor}"
471 return 0
472 fi
473 programMessage "unsupported old-style device: ${device}"
91162002 474}
475translateDevice_old()
476{
c247b245 477 major="${device%%/*}"
106ddbb5 478 if [ "${major}" != "${device}" ]; then
c247b245 479 minor="${device#*/}"
480 case "${major}" in
481 tts) devfs="ttyS${minor}";;
482 printers) devfs="lp${minor}";;
483 esac
484 fi
106ddbb5 485 if [ -n "${devfs}" ]; then
c247b245 486 device="${devfs}"
487 else
488 programMessage "unsupported devfs device: ${device}"
489 fi
91162002 490}
491
492makeHeaderLine()
493{
c247b245 494 echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
91162002 495}
496makeParameterLine()
497{
c247b245 498 echo "# Boot Parameter:${bootParameter}"
91162002 499}
500putConfigurationFile()
501{
c247b245 502 startConfigurationFile
503 [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
504 [ -n "${brailleDevice}" ] && {
505 device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
106ddbb5 506 if [ "${device#/}" = "${device}" ]; then
c247b245 507 translateDevice_${deviceTranslation}
508 fi
509 putConfigurationDirective "braille-device" "${device}"
510 }
511 [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
512 finalizeConfigurationFile
91162002 513}
514parseBootParameter()
515{
c247b245 516 bootParameter="${bootParameter} ${1}"
517 number=1
106ddbb5 518 while [ "${number}" -le 3 ]; do
c247b245 519 cut="cut -d, -f${number}"
520 [ "${number}" -gt 1 ] && cut="${cut} -s"
521 operand="`echo ${1} | ${cut}`"
106ddbb5 522 if [ -n "${operand}" ]; then
c247b245 523 case "${number}" in
524 1) brailleDriver="${operand}";;
525 2) brailleDevice="${operand}";;
526 3) textTable="${operand}";;
527 esac
528 fi
529 number="`expr ${number} + 1`"
530 done
91162002 531}
532putBootParameter()
533{
c247b245 534 parseBootParameter "${1}"
535 putConfigurationFile
91162002 536}
537parseBootCommand()
538{
c247b245 539 found=false
106ddbb5 540 while [ "${#}" -gt 0 ]; do
c247b245 541 case "${1}" in
542 "brltty="*)
543 found=true
544 parseBootParameter "${1#*=}"
545 ;;
546 esac
547 shift
548 done
549 "${found}" && putConfigurationFile
91162002 550}
551
552brailleDriver=""
553brailleDevice=""
554textTable=""
555bootCommandFile="/proc/cmdline"
106ddbb5 556if [ -n "${requestedParameter}" ]; then
c247b245 557 putBootParameter "${requestedParameter}"
106ddbb5 558elif [ -f "${bootCommandFile}" ]; then
c247b245 559 parseBootCommand `cat "${bootCommandFile}"`
106ddbb5 560elif [ -n "${brltty}" ]; then
c247b245 561 putBootParameter "${brltty}"
91162002 562fi
563exit 0
564)
565
9b20373a 566%post -n brlapi -p /sbin/ldconfig
567%postun -n brlapi -p /sbin/ldconfig
91162002 568
569%files
570%defattr(644,root,root,755)
c0ab824f 571%doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
b538cd8d 572%doc doc/{Bindings,Bootdisks,Drivers,Patches,Tables,README,nsistrings.txt}
91162002 573%attr(755,root,root) %{_bindir}/brltty
c0ab824f 574%attr(755,root,root) %{_bindir}/brltty-config
509de961
JB
575%attr(755,root,root) %{_bindir}/brltty-ctb
576%attr(755,root,root) %{_bindir}/brltty-install
577%attr(755,root,root) %{_bindir}/brltty-trtxt
578%attr(755,root,root) %{_bindir}/brltty-ttb
18f080b9 579%attr(755,root,root) %{_bindir}/vstp
eb77b64b 580%{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
91162002 581%dir %{_libdir}/brltty
82b1c71c 582# Braille drivers
c0ab824f
SS
583%attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
584%attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
585%attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
82b1c71c 586%attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
c0ab824f
SS
587%attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
588%attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
589%attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
590%attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
591%attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
0b1afa7b 592%attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
c0ab824f
SS
593%attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
594%attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
595%attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
82b1c71c 596%attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
c0ab824f 597%attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
509de961 598%attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
509de961
JB
599%attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
600%{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
c0ab824f
SS
601%attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
602%attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
603%attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
604%attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
82b1c71c 605%attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
509de961 606%attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
82b1c71c 607%attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
c0ab824f 608%attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
82b1c71c 609%attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
c0ab824f
SS
610%attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
611%attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
612%attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
613%attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
614%attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
615%attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
616%attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
eb77b64b 617%{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
82b1c71c 618# speech synthesizer drivers
c0ab824f
SS
619%attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
620%attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
621%attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
82b1c71c
JB
622%{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
623%{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
c0ab824f
SS
624%attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
625%attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
dfe38ff6 626%{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
82b1c71c 627%{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
dfe38ff6
JB
628%{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
629%{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
630%{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
b538cd8d 631%attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
82b1c71c 632# screen drivers
681d76a3 633%{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
82b1c71c
JB
634%{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
635%attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
636%attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
91162002 637%{_sysconfdir}/brltty
1c33f0ca 638%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
82b1c71c
JB
639/usr/lib/tmpfiles.d/brltty.conf
640%dir /var/lib/BrlAPI
641%dir /var/run/brltty
c0ab824f
SS
642%{_mandir}/man1/brltty.1*
643%{_mandir}/man1/vstp.1*
b538cd8d 644%{?with_x:%{_mandir}/man1/xbrlapi.1*}
91162002 645
646%files -n brlapi
647%defattr(644,root,root,755)
82b1c71c 648%attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
0b1afa7b 649%attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.6
91162002 650
651%files -n brlapi-devel
652%defattr(644,root,root,755)
608626ec 653%doc Documents/Manual-BrlAPI/English/BrlAPI*
1c33f0ca 654%attr(755,root,root) %{_libdir}/libbrlapi.so
91162002 655%{_includedir}/brltty
18f080b9 656%{_includedir}/brlapi*.h
82b1c71c 657%{_mandir}/man3/brlapi_*.3*
91162002 658
659%files -n brlapi-static
660%defattr(644,root,root,755)
661%{_libdir}/libbrlapi.a
608626ec 662
09255552 663%if %{with apidocs}
608626ec
SS
664%files -n brlapi-apidocs
665%defattr(644,root,root,755)
666%doc Documents/BrlAPIref/html/*
09255552
SS
667%endif
668
669%if %{with java}
332e4348 670%files -n java-brlapi
09255552 671%defattr(644,root,root,755)
3dcc4a01 672%attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
09255552
SS
673%{_javadir}/brlapi.jar
674%endif
0bb357f1 675
82b1c71c
JB
676%if %{with ocaml}
677%files -n ocaml-brlapi
678%defattr(644,root,root,755)
679%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
680%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
681
682%files -n ocaml-brlapi-devel
683%defattr(644,root,root,755)
684%dir %{_libdir}/ocaml/brlapi
685%{_libdir}/ocaml/brlapi/META
686%{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
687%{_libdir}/ocaml/brlapi/brlapi.mli
688%{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
689%endif
690
0bb357f1
SS
691%if %{with python}
692%files -n python-brlapi
693%defattr(644,root,root,755)
0bb357f1 694%attr(755,root,root) %{py_sitedir}/brlapi.so
509de961 695%{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
0bb357f1
SS
696%endif
697
698%if %{with tcl}
699%files -n brlapi-tcl
700%defattr(644,root,root,755)
509de961
JB
701%dir %{_libdir}/brlapi-%{brlapi_ver}
702%attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
703%{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
0bb357f1 704%endif
This page took 0.158981 seconds and 4 git commands to generate.