]> git.pld-linux.org Git - packages/brlcad.git/blob - brlcad.spec
8c0b759560d1ddca5223748af48125f1e245d899
[packages/brlcad.git] / brlcad.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  tests           # build without tests
5 #
6 Summary:        BRL CAD
7 Summary(pl):    BRL CAD
8 Name:           brlcad
9 Version:        7.8.0
10 Release:        0.1
11 License:        GPL
12 Group:          Applications/CAD
13 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  bb4c5fd83ae1dd1b5dd84384f7894fc8
15 #Source1:       -
16 # Source1-md5:  -
17 #Patch0:                %{name}-DESTDIR.patch
18 URL:            htp://brlcad.sourceforge.net/
19 #BuildRequires: -
20 #for TH
21 BuildRequires:  xorg-lib-libICE-devel
22 BuildRequires:  xorg-lib-libX11-devel
23 BuildRequires:  xorg-lib-libXext-devel
24 BuildRequires:  xorg-lib-libXi-devel
25 BuildRequires:  xorg-lib-libXmu-devel
26 BuildRequires:  xorg-lib-libXt-devel
27 BuildRequires:  xorg-lib-libSM-devel
28 # for AC
29 #BuildRequires: X11-devel
30 #
31 BuildRequires:  tcl-devel
32 BuildRequires:  tk-devel
33 #Buildrequires: itcl-devel
34 #BuildRequires: itk-devel
35 Buildrequires:  python
36 BuildRequires:  SDL-devel
37 #BuildRequires: tk-Img-devel
38
39 #Requires(postun):      -
40 #Requires(pre,post):    -
41 #Requires(preun):       -
42 #Requires:      -
43 #Provides:      -
44 #Provides:      group(foo)
45 #Provides:      user(foo)
46 #Obsoletes:     -
47 #Conflicts:     -
48 #BuildArch:     noarch
49 #ExclusiveArch: %{ix86}
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 The BRL-CAD package is a powerful Constructive Solid Geometry (CSG) solid modeling system with over 20 years development and production use by the U.S. military. BRL-CAD includes an interactive geometry editor, parallel ray-tracing support for rendering and geometric analysis, path-tracing for realistic image synthesis, network distributed framebuffer support, image-processing and signal-processing tools. The entire package is distributed in source code form.
54
55 %description -l pl
56
57 %package subpackage
58 Summary:        -
59 Summary(pl):    -
60 Group:          -
61
62 %description subpackage
63
64 %description subpackage -l pl
65
66 %package libs
67 Summary:        -
68 Summary(pl):    -
69 Group:          Libraries
70
71 %description libs
72
73 %description libs -l pl
74
75
76 %package devel
77 Summary:        Header files for ... library
78 Summary(pl):    Pliki nag³ówkowe biblioteki ...
79 Group:          Development/Libraries
80 #Requires:      %{name} = %{version}-%{release}
81
82 %description devel
83 This is the package containing the header files for ... library.
84
85 %description devel -l pl
86 Ten pakiet zawiera pliki nag³ówkowe biblioteki ....
87
88 %package static
89 Summary:        Static ... library
90 Summary(pl):    Statyczna biblioteka ...
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93
94 %description static
95 Static ... library.
96
97 %description static -l pl
98 Statyczna biblioteka ....
99
100 %prep
101 %setup -q
102 #%setup -q -c -T
103 #%setup -q -n %{name}
104 #%%setup -q -n %{name}-%{version}.orig -a 1
105 #%patch0 -p1
106
107 # undos the source
108 #find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 sed -i -e 's,\r$,,'
109
110 # remove CVS control files
111 #find -name CVS -print0 | xargs -0 rm -rf
112
113 %build
114 #/autogen.sh
115 %configure \
116         --disable-blt-build \
117         --disable-itcl-build \
118         --disable-itk-build \
119         --disable-png-build \
120         --disable-regex-build \
121         --disable-tcl-build \
122         --disable-tkimg-build \
123         --disable-zlib-build \
124         --disable-debug \
125         --disable-profiling \
126         --enable-optimized \
127         --with-gnu-ld \
128         --bindir=%{_bindir} \
129         --sbindir=%{_sbindir} \
130         --datadir=%{_datadir} \
131         --mandir=%{_mandir} \
132         --sysconfdir=%{_sysconfdir}
133 %{__make}
134
135 #%{__make} \
136 #       CFLAGS="%{rpmcflags}" \
137 #       LDFLAGS="%{rpmldflags}"
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 # create directories if necessary
142 #install -d $RPM_BUILD_ROOT
143 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %pre
152
153 %post
154
155 %preun
156
157 %postun
158
159 %if %{with ldconfig}
160 %post   -p /sbin/ldconfig
161 %postun -p /sbin/ldconfig
162 %endif
163
164 %if %{with initscript}
165 %post init
166 /sbin/chkconfig --add %{name}
167 %service %{name} restart
168
169 %preun init
170 if [ "$1" = "0" ]; then
171         %service -q %{name} stop
172         /sbin/chkconfig --del %{name}
173 fi
174 %endif
175
176 %files
177 %defattr(644,root,root,755)
178 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
179
180 %if 0
181 # if _sysconfdir != /etc:
182 #%%dir %{_sysconfdir}
183 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
184 %attr(755,root,root) %{_bindir}/*
185 %{_datadir}/%{name}
186 %endif
187
188 # initscript and its config
189 %if %{with initscript}
190 %attr(754,root,root) /etc/rc.d/init.d/%{name}
191 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
192 %endif
193
194 #%{_examplesdir}/%{name}-%{version}
195
196 %if %{with subpackage}
197 %files subpackage
198 %defattr(644,root,root,755)
199 #%doc extras/*.gz
200 #%{_datadir}/%{name}-ext
201 %endif
This page took 0.06102 seconds and 2 git commands to generate.