]> git.pld-linux.org Git - packages/brlcad.git/blob - brlcad.spec
- updated BR
[packages/brlcad.git] / brlcad.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  tests           # build without tests
5 #
6 Summary:        BRL CAD
7 Summary(pl):    BRL CAD
8 Name:           brlcad
9 Version:        7.8.0
10 Release:        0.1
11 License:        GPL
12 Group:          Applications/CAD
13 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  bb4c5fd83ae1dd1b5dd84384f7894fc8
15 #Source1:       -
16 # Source1-md5:  -
17 #Patch0:                %{name}-DESTDIR.patch
18 URL:            htp://brlcad.sourceforge.net/
19 #BuildRequires: -
20 #BuildRequires: autoconf
21 #BuildRequires: automake
22 #BuildRequires: intltool
23 #BuildRequires: libtool
24 BuildRequires:  tcl-devel
25 BuildRequires:  tk-devel
26 Buildrequires:  itcl-devel
27 BuildRequires:  itk-devel
28 Buildrequires:  python
29 BuildRequires:  SDL-devel
30 #Requires(postun):      -
31 #Requires(pre,post):    -
32 #Requires(preun):       -
33 #Requires:      -
34 #Provides:      -
35 #Provides:      group(foo)
36 #Provides:      user(foo)
37 #Obsoletes:     -
38 #Conflicts:     -
39 #BuildArch:     noarch
40 #ExclusiveArch: %{ix86}
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 The BRL-CAD package is a powerful Constructive Solid Geometry (CSG) solid modeling system with over 20 years development and production use by the U.S. military. BRL-CAD includes an interactive geometry editor, parallel ray-tracing support for rendering and geometric analysis, path-tracing for realistic image synthesis, network distributed framebuffer support, image-processing and signal-processing tools. The entire package is distributed in source code form.
45
46 %description -l pl
47
48 %package subpackage
49 Summary:        -
50 Summary(pl):    -
51 Group:          -
52
53 %description subpackage
54
55 %description subpackage -l pl
56
57 %package libs
58 Summary:        -
59 Summary(pl):    -
60 Group:          Libraries
61
62 %description libs
63
64 %description libs -l pl
65
66
67 %package devel
68 Summary:        Header files for ... library
69 Summary(pl):    Pliki nag³ówkowe biblioteki ...
70 Group:          Development/Libraries
71 #Requires:      %{name} = %{version}-%{release}
72
73 %description devel
74 This is the package containing the header files for ... library.
75
76 %description devel -l pl
77 Ten pakiet zawiera pliki nag³ówkowe biblioteki ....
78
79 %package static
80 Summary:        Static ... library
81 Summary(pl):    Statyczna biblioteka ...
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static ... library.
87
88 %description static -l pl
89 Statyczna biblioteka ....
90
91 %prep
92 %setup -q
93 #%setup -q -c -T
94 #%setup -q -n %{name}
95 #%%setup -q -n %{name}-%{version}.orig -a 1
96 #%patch0 -p1
97
98 # undos the source
99 #find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 sed -i -e 's,\r$,,'
100
101 # remove CVS control files
102 #find -name CVS -print0 | xargs -0 rm -rf
103
104 %build
105 # if ac/am/* rebuilding is necessary, do it in this order and add
106 # appropriate BuildRequires
107 #%%{__intltoolize}
108 #%%{__gettextize}
109 #%%{__libtoolize}
110 #%%{__aclocal}
111 #%%{__autoconf}
112 #%%{__autoheader}
113 #%%{__automake}
114 #cp -f /usr/share/automake/config.sub .
115 %configure
116 #{__make}
117
118 #%{__make} \
119 #       CFLAGS="%{rpmcflags}" \
120 #       LDFLAGS="%{rpmldflags}"
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 # create directories if necessary
125 #install -d $RPM_BUILD_ROOT
126 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %pre
135
136 %post
137
138 %preun
139
140 %postun
141
142 %if %{with ldconfig}
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145 %endif
146
147 %if %{with initscript}
148 %post init
149 /sbin/chkconfig --add %{name}
150 %service %{name} restart
151
152 %preun init
153 if [ "$1" = "0" ]; then
154         %service -q %{name} stop
155         /sbin/chkconfig --del %{name}
156 fi
157 %endif
158
159 %files
160 %defattr(644,root,root,755)
161 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
162
163 %if 0
164 # if _sysconfdir != /etc:
165 #%%dir %{_sysconfdir}
166 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
167 %attr(755,root,root) %{_bindir}/*
168 %{_datadir}/%{name}
169 %endif
170
171 # initscript and its config
172 %if %{with initscript}
173 %attr(754,root,root) /etc/rc.d/init.d/%{name}
174 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
175 %endif
176
177 #%{_examplesdir}/%{name}-%{version}
178
179 %if %{with subpackage}
180 %files subpackage
181 %defattr(644,root,root,755)
182 #%doc extras/*.gz
183 #%{_datadir}/%{name}-ext
184 %endif
This page took 0.151604 seconds and 3 git commands to generate.