]> git.pld-linux.org Git - packages/boson.git/blob - boson.spec
- raw version.
[packages/boson.git] / boson.spec
1 #
2 # Spec file for package Boson
3 #
4 # Please send bugfixes or comments to the packager
5 #
6
7
8 #
9 # Thomas : Every packager should change only those four lines
10 #
11
12 # THe number of your attempt to build the rpm
13 %define release          1
14 # The name of your distribution : ex "SuSe Linux 6.0 (i386)", or "RedHat 5.1 (alpha)"
15 %define distro           LinuxPPC R5/Q3
16 # THe place where kde is installed in your distro (probably /opt/kde/)
17 %define prefix           /usr
18 # Your name
19 %define packager         Thomas Capricelli <capricel@enst.fr>
20
21 #
22 # Thomas : shouldn't be altered after this line
23 #
24
25 %define version          0.2
26
27 # Directory-related Tags
28 %define builddir         $RPM_BUILD_DIR/boson-%{version}
29 BuildRoot:               /var/tmp/boson-%{version}-root
30 Prefix:                  %{prefix}
31
32 # Package Naming Tags
33 Name:                    boson 
34 Version:                 %{version}
35 Release:                 %{release}
36 Distribution:            %{distro}
37 Packager:                %{packager}
38 Group:                   X11/KDE/Games
39
40
41 Icon:                    boson.xpm
42 Source0:                 boson-%{version}.tgz
43 Source1:                 boson-pics-%{version}.tgz
44
45 # Dependancy Tags
46 Provides:                boson
47 Serial:                  %{release}
48 AutoReqProv:             Yes
49
50 # Descriptive Tags
51 Summary:                 Boson : a Real-Time Strategy Game (RTS) for the KDE project
52 Vendor:                  Thomas Capricelli <capricel@enst.fr>, Benjamin Adler <BenAdler@gmx.net>
53 Copyright:               GPL
54 URL:                     http://aquila.rezel.enst.fr/boson/
55
56 %description
57 Boson is a real-time strategy game, like Command&Conquer(tm) or StarCraft(tm).
58 It is designed to run on Unix (Linux) computers and uses the Qt
59 Toolkit and QwSpriteField. A minimum of two players is required, since there is
60 no artifical intelligence (yet?). Boson is still in very early development
61 and not playable yet. 
62
63 Boson's Code and Graphics are published under the GNU General Public License.
64
65 If you want to know more about Boson, have a look at the Web site.
66
67 %prep
68 %setup -n boson-%{version}
69 %build
70 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" ./configure \
71               --prefix=$KDEDIR \
72               --libdir=%{buildroot}/$KDEDIR/lib \
73  --with-install-root=%{buildroot}
74 make
75
76
77 %install
78 if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT ; fi
79 make prefix=$RPM_BUILD_ROOT%{prefix} install
80
81 ## install textures and resources files :
82 mkdir $RPM_BUILD_ROOT%{prefix}/share/apps/
83 cd $RPM_BUILD_ROOT%{prefix}/share/apps/
84 cp $RPM_SOURCE_DIR/boson-pics-%{version}.tgz . 
85 gunzip boson-pics-%{version}.tgz
86 tar xvf boson-pics-%{version}.tar
87 rm boson-pics-%{version}.tar
88
89 %clean
90 rm -rf %{builddir}
91 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
92 #rm -f $RPM_SOURCE_DIR/boson*
93
94 %files 
95 %{prefix}/bin/
96 %{prefix}/share/applnk/
97 %{prefix}/share/apps/
98 %{prefix}/share/icons/
99 %doc %{prefix}/share/doc/HTML/en/Boson/
100 %doc AUTHORS COPYING ChangeLog INSTALL README TODO
101
102 %changelog
103 * Tue Sep 21 1999 Thomas Capricelli <capricel@enst.fr>
104 -  making it the way I want it..
105 -  adapted to boson-0.2 (Games/Boson)
106 * Thu Sep 17 1999 Guillaume Assire <alphagolf@rocketmail.com>
107 -  Initial packaging version 0.1
This page took 0.077346 seconds and 3 git commands to generate.