]> git.pld-linux.org Git - packages/bopm.git/blob - bopm.spec
e36aee4f23467018b63d3615a5cbfa37510e6f61
[packages/bopm.git] / bopm.spec
1 Summary:        Open proxy monitor and blocker, designed for use with ircds
2 Summary(pl):    Monitorowanie i blokowanie otwartych proxy do u¿ywania z ircd
3 Name:           bopm
4 Version:        3.1.2
5 Release:        0.14
6 License:        GPL
7 Group:          Applications/Communications
8 Source0:        http://static.blitzed.org/www.blitzed.org/bopm/files/%{name}-%{version}.tar.gz
9 # Source0-md5:  ab1b7494c4242eef957b5fca61c92b18
10 Source1:        %{name}.init
11 Source2:        %{name}.conf
12 Patch0:         %{name}-DESTDIR.patch
13 Patch1:         %{name}-shared.patch
14 URL:            http://www.blitzed.org/bopm/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libtool
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires:       %{name} = %{version}-%{release}
20 Requires(post,preun):   /sbin/chkconfig
21 Requires(postun):       /usr/sbin/groupdel
22 Requires(postun):       /usr/sbin/userdel
23 Requires(pre):  /bin/id
24 Requires(pre):  /usr/bin/getgid
25 Requires(pre):  /usr/sbin/groupadd
26 Requires(pre):  /usr/sbin/useradd
27 Requires:       rc-scripts >= 0.4.0.17
28 Provides:       group(%{name})
29 Provides:       user(%{name})
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The Blitzed Open Proxy Monitor is designed to connect to an IRC server
34 and become an IRC operator. It then watches connect notices in order
35 to scan all connecting clients for open (insecure) proxies. Such
36 insecure proxies are commonly used for spamming, floods and other
37 abusive activities.
38
39 BOPM can detect WinGates, HTTP proxies, SOCKS 4/5 proxies and Cisco
40 routers with default passwords. BOPM also has support for checking
41 against a DNS-Based Blacklist (similar to MAPS RBL) and can be
42 configured to report new proxies back to the Blitzed Open Proxy
43 Monitoring project.
44
45 %description -l pl
46 Blitzed Open Proxy Monitor jest zaprojektowany tak, ¿e ³±czy siê z
47 serwerem IRC i staje operatorem. Nastêpnie ogl±da informacje o
48 po³±czeniach w celu skanowania wszystkich klientów pod k±tem otwartych
49 (niebezpiecznych) proxy. Takie niebezpieczne proxy zwykle s± u¿ywane
50 do spamowania, floodowania i innych nadu¿yæ.
51
52 BOPM jest w stanie wykryæ WinGates, proxy HTTP, proxy SOCKS 4/5 oraz
53 routery Cisco z domy¶lnymi has³ami. BOPM obs³uguje tak¿e sprawdzanie
54 czarnych list opartych na DNS (takich jak MAPS RBL) i mo¿e byæ
55 skonfigurowany do zg³aszania nowych proxy z powrotem do projektu
56 Blitzed Open Proxy Monitoring.
57
58 %package libs
59 Summary:        libopm open proxy scanning library
60 Group:          Libraries
61
62 %description libs
63 libopm open proxy scanning library.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68 %patch1 -p1
69
70 # we include contrib in %doc. cleanup it
71 find -name CVS | xargs -r rm -rf
72 rm -f contrib/bopm.spec
73
74 %build
75 %{__libtoolize}
76 %{__aclocal}
77 %{__autoconf}
78 %{__autoheader}
79 %{__automake}
80 %configure \
81         --localstatedir=/var/log/%{name} \
82         --bindir=%{_sbindir}
83
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/var/{run,log}/%{name}}
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
94 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
95 > $RPM_BUILD_ROOT/var/log/%{name}/bopm.log
96 > $RPM_BUILD_ROOT/var/log/%{name}/scan.log
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %pre
102 %groupadd -g 151 %{name}
103 %useradd -u 151 -c "BOPM Daemon" -g %{name} %{name}
104
105 %post
106 /sbin/chkconfig --add %{name}
107 %service %{name} restart "BOPM daemon"
108
109 %preun
110 if [ "$1" = "0" ]; then
111         %service %{name} stop
112         /sbin/chkconfig --del %{name}
113 fi
114
115 %postun
116 if [ "$1" = "0" ]; then
117         %userremove %{name}
118         %groupremove %{name}
119 fi
120
121 %post   libs -p /sbin/ldconfig
122 %postun libs -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc ChangeLog INSTALL README bopm.conf.sample
127 %doc contrib/ network-bopm/
128 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
129 %attr(754,root,root) /etc/rc.d/init.d/%{name}
130 %attr(755,root,root) %{_sbindir}/%{name}
131
132 %attr(770,root,bopm) %dir /var/run/%{name}
133 %attr(770,root,bopm) %dir /var/log/%{name}
134 %attr(640,bopm,bopm) %ghost /var/log/%{name}/bopm.log
135 %attr(640,bopm,bopm) %ghost /var/log/%{name}/scan.log
136
137 %files libs
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libopm.so.*.*.*
140
141 # oneday when -devel is created
142 %if 0
143 %files devel
144 %defattr(644,root,root,755)
145 %{_includedir}/opm.h
146 %{_includedir}/opm_common.h
147 %{_includedir}/opm_error.h
148 %{_includedir}/opm_types.h
149 %{_libdir}/libopm.la
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/libopm.a
154 %endif
This page took 0.053725 seconds and 2 git commands to generate.