]> git.pld-linux.org Git - packages/boost.git/commitdiff
- O: boost-compose-devel (use bind and/or lambda instead).
authorPaweł Sikora <pluto@pld-linux.org>
Sun, 24 Sep 2006 18:56:30 +0000 (18:56 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- excessive inlining disabled.

Changed files:
    boost.spec -> 1.69

boost.spec

index 4a3ac984d41e65df8af869e627a9942331b586ba..a6fbe73acded6ea5e739a883ed31a32b89708273 100644 (file)
@@ -57,6 +57,7 @@ Provides:     boost-preprocessor-devel = %{version}-%{release}
 Provides:      boost-static_assert-devel = %{version}-%{release}
 Provides:      boost-type_traits-devel = %{version}-%{release}
 Provides:      boost-utility-devel = %{version}-%{release}
+Obsoletes:     boost-compose-devel
 Obsoletes:     boost-concept_check-devel
 Obsoletes:     boost-conversion-devel
 Obsoletes:     boost-mpl-devel
@@ -217,6 +218,7 @@ Summary(pl):        Uog
 Group:         Development/Libraries
 Requires:      %{name}-ref-devel = %{version}-%{release}
 Provides:      boost-mem_fn-devel = %{version}-%{release}
+Obsoletes:     boost-compose-devel
 Obsoletes:     boost-mem_fn-devel
 
 %description bind-devel
@@ -652,7 +654,7 @@ Dokumentacja dla biblioteki Boost C++.
 
 # don't know how to pass it through (b)jam -s (no way?)
 # due to oversophisticated build flags system
-%{__perl} -pi -e 's/ -O3 / %{rpmcflags} /' tools/build/v1/gcc-tools.jam
+%{__perl} -pi -e 's/ -O3 / %{rpmcxxflags} /' tools/build/v1/gcc-tools.jam
 
 %ifarch alpha
 # -pthread gcc parameter doesn't add _REENTRANT to cpp macros on alpha (only)
@@ -671,7 +673,7 @@ PYTHON_VERSION=
 %endif
 bjam \
        -d2 \
-       -sBUILD="release <threading>multi <shared-linkable>true" \
+       -sBUILD="release <threading>multi <shared-linkable>true <inlining>on" \
        -sPYTHON_ROOT=$PYTHON_ROOT \
        -sPYTHON_VERSION=$PYTHON_VERSION
 
@@ -681,10 +683,10 @@ install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
 
 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
 
-install bin/boost/libs/*/build/*.a/*/release/shared-linkable-true/*/lib*.a $RPM_BUILD_ROOT%{_libdir}
-install bin/boost/libs/*/build/*.so/*/release/shared-linkable-true/*/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
+install bin/boost/libs/*/build/*.a/*/release/inlining-on/shared-linkable-true/*/lib*.a $RPM_BUILD_ROOT%{_libdir}
+install bin/boost/libs/*/build/*.so/*/release/inlining-on/shared-linkable-true/*/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
 # use cp -d, install follows symlinks instead of preserving them!
-cp -df bin/boost/libs/*/build/*.so/*/release/shared-linkable-true/*/lib*.so $RPM_BUILD_ROOT%{_libdir}
+cp -df bin/boost/libs/*/build/*.so/*/release/inlining-on/shared-linkable-true/*/lib*.so $RPM_BUILD_ROOT%{_libdir}
 
 # create symlinks without -gcc-mt-* things in names
 for f in $RPM_BUILD_ROOT%{_libdir}/*.so.*; do
@@ -991,12 +993,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_includedir}/boost/compatibility
 
-%if 0
-%files compose-devel
-%defattr(644,root,root,755)
-#%{_includedir}/boost/compose.hpp
-%endif
-
 %files compressed_pair-devel
 %defattr(644,root,root,755)
 %{_includedir}/boost/compressed_pair.hpp
This page took 0.100465 seconds and 4 git commands to generate.