]> git.pld-linux.org Git - packages/boost.git/commitdiff
- enable hashing for new c++11 char types auto/th/boost-1.63.0-4
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 26 Apr 2017 17:48:32 +0000 (19:48 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 26 Apr 2017 17:48:32 +0000 (19:48 +0200)
- rel 4

boost.spec
hash-new-char-types.patch [new file with mode: 0644]

index 71367ed75a44ca0a7c232eebd7c80c807ec5bd65..126a4a167e5b4d0cf3e2db339c12083398948a3c 100644 (file)
@@ -13,7 +13,7 @@ Summary:      The Boost C++ Libraries
 Summary(pl.UTF-8):     Biblioteki C++ "Boost"
 Name:          boost
 Version:       1.63.0
-Release:       3
+Release:       4
 License:       Boost Software License and others
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
@@ -22,6 +22,7 @@ Patch0:               %{name}-link.patch
 Patch1:                %{name}-x32-context.patch
 Patch2:                %{name}-clean-gcc-flags.patch
 Patch3:                %{name}-numpy3.patch
+Patch4:                hash-new-char-types.patch
 # FC Patches:
 Patch201:      %{name}-python-abi_letters.patch
 # https://github.com/boostorg/build/issues/163
@@ -486,6 +487,7 @@ Dokumentacja dla biblioteki Boost C++.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %patch201 -p1
 %patch202 -p1
diff --git a/hash-new-char-types.patch b/hash-new-char-types.patch
new file mode 100644 (file)
index 0000000..b767f52
--- /dev/null
@@ -0,0 +1,21 @@
+https://svn.boost.org/trac/boost/ticket/11145
+
+--- boost_1_63_0/boost/functional/hash/hash.hpp~       2016-12-22 13:33:15.000000000 +0100
++++ boost_1_63_0/boost/functional/hash/hash.hpp        2017-04-26 19:14:04.588719738 +0200
+@@ -117,6 +117,16 @@
+             boost::hash_detail::enable_hash_value {};
+ #endif
++#if !defined(BOOST_NO_CXX11_CHAR16_T)
++        template <> struct basic_numbers<char16_t> :
++            boost::hash_detail::enable_hash_value {};
++#endif
++
++#if !defined(BOOST_NO_CXX11_CHAR32_T)
++        template <> struct basic_numbers<char32_t> :
++            boost::hash_detail::enable_hash_value {};
++#endif
++
+         template <> struct float_numbers<float> :
+             boost::hash_detail::enable_hash_value {};
+         template <> struct float_numbers<double> :
This page took 0.038128 seconds and 4 git commands to generate.