]> git.pld-linux.org Git - packages/boost.git/blobdiff - boost.spec
up to 1.82.0
[packages/boost.git] / boost.spec
index 3313a56c4ce830a7e63f0e401f1c6bf14c670d44..b3f27b0a8a90b9bbc1e09c23caad8aab36d24589 100644 (file)
 Summary:       The Boost C++ Libraries
 Summary(pl.UTF-8):     Biblioteki C++ "Boost"
 Name:          boost
-Version:       1.78.0
-Release:       4
+Version:       1.82.0
+Release:       1
 License:       Boost Software License and others
 Group:         Libraries
 Source0:       https://boostorg.jfrog.io/artifactory/main/release/%{version}/source/%{name}_%{fver}.tar.bz2
-# Source0-md5: db0112a3a37a3742326471d20f1a186a
+# Source0-md5: b45dac8b54b58c087bfbed260dbfc03a
 Patch0:                %{name}-link.patch
 Patch1:                %{name}-clean-gcc-flags.patch
+Patch2:                %{name}-fallthrough.patch
+Patch3:                uarg-def.patch
 # FC Patches:
 Patch201:      %{name}-python-abi_letters.patch
 # https://svn.boost.org/trac/boost/ticket/5637
@@ -33,7 +35,7 @@ BuildRequires:        expat-devel
 BuildRequires: libicu-devel
 BuildRequires: libstdc++-devel >= 6:4.7
 BuildRequires: perl-base
-%if %{with python}
+%if %{with python2}
 BuildRequires: python-devel >= 2.2
 %{?with_numpy:BuildRequires:   python-numpy-devel}
 %endif
@@ -43,7 +45,7 @@ BuildRequires:        python3-devel
 %endif
 BuildRequires: rpm-build >= 4.6
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.734
+BuildRequires: rpmbuild(macros) >= 1.750
 BuildRequires: zlib-devel
 Obsoletes:     boost-signals < 1.69
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -53,11 +55,11 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                py2v %(echo %{py_ver} | tr -d .)
 %define                py3v %(echo %{py3_ver} | tr -d .)
 
-#if "%{py3_ver}" >= "3.8"
+%if %{_ver_ge "%{py3_ver}" "3.8"}
 %define                py3v_suffix ""
-#else
-#define                py3v_suffix "m"
-#endif
+%else
+%define                py3v_suffix "m"
+%endif
 
 %description
 The Boost web site provides free peer-reviewed portable C++ source
@@ -97,6 +99,7 @@ Requires:     %{name}-system = %{version}-%{release}
 Requires:      %{name}-test = %{version}-%{release}
 Requires:      %{name}-thread = %{version}-%{release}
 Requires:      %{name}-timer = %{version}-%{release}
+Requires:      %{name}-url = %{version}-%{release}
 Requires:      %{name}-wave = %{version}-%{release}
 Requires:      libstdc++-devel >= 6:4.7
 Obsoletes:     boost-any-devel < 1.35
@@ -470,6 +473,17 @@ Event timer, progress timer, and progress display classes.
 %description timer -l pl.UTF-8
 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
 
+%package url
+Summary:       Library for manipulating Uniform Resource Identifiers and Locators
+Summary(pl.UTF-8):     Biblioteka do manipulacji Unfiform Resource Identifier i Locator
+Group:         Libraries
+
+%description url
+Library for manipulating Uniform Resource Identifiers and Locators.
+
+%description url -l pl.UTF-8
+Biblioteka do manipulacji Unfiform Resource Identifier i Locator.
+
 %package wave
 Summary:       Boost.Wave - a standard compliant C++ preprocessor library
 Summary(pl.UTF-8):     Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
@@ -497,6 +511,8 @@ Dokumentacja dla biblioteki Boost C++.
 %setup -q -n %{name}_%{fver}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %patch201 -p1
 %patch203 -p0
@@ -522,12 +538,11 @@ ICU_PATH=%{_prefix} \
        --prefix=%{_prefix} \
        -without-libraries=python
 
-# x32 detection need help (it's autodetected as address-model=32 abi=sysv, while context build expects address-model=64 abi=x32)
 ./b2 \
+       %{?__jobs:-j %{__jobs}} \
        -d2 --toolset=gcc \
 %ifarch x32
        abi=x32 \
-       address-model=64 \
 %endif
        debug-symbols=on \
        inlining=on \
@@ -538,6 +553,7 @@ ICU_PATH=%{_prefix} \
 %if %{with python3}
 echo "using python : %{py3_ver} : %{py3_prefix} : %{py3_incdir} : : : : %{py3v_suffix} ;" >> project-config.jam
 ./b2 \
+       %{?__jobs:-j %{__jobs}} \
        --with-python python=%{py3_ver} \
        -a -d2 --toolset=gcc \
        debug-symbols=on \
@@ -551,6 +567,7 @@ echo "using python : %{py3_ver} : %{py3_prefix} : %{py3_incdir} : : : : %{py3v_s
 %{__sed} -i -e '/^using python : 3/d' project-config.jam
 echo "using python : %{py_ver} : %{py_prefix} : %{py_incdir} ;" >> project-config.jam
 ./b2 \
+       %{?__jobs:-j %{__jobs}} \
        --with-python python=%{py_ver} \
        -a -d2 --toolset=gcc \
        debug-symbols=on \
@@ -570,12 +587,6 @@ install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
 
-# workaround https://github.com/boostorg/boost/issues/594
-find bin.v2/libs '(' -name libboost_fiber.a -o -name 'libboost_stacktrace_*.a' -o -name 'libboost_fiber.so.*' -o -name 'libboost_stacktrace_*.so.*' ')' -exec cp -p {} $RPM_BUILD_ROOT%{_libdir} \;
-for lib in $RPM_BUILD_ROOT%{_libdir}/*{stacktrace,fiber}*.so.*; do
-       ln -sf $(basename $lib) $RPM_BUILD_ROOT%{_libdir}/$(basename $lib .%{version})
-done
-
 %if %{with doc}
 # documentation
 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
@@ -679,6 +690,9 @@ rm -rf $RPM_BUILD_ROOT
 %post  timer -p /sbin/ldconfig
 %postun        timer -p /sbin/ldconfig
 
+%post  url -p /sbin/ldconfig
+%postun        url -p /sbin/ldconfig
+
 %post  wave -p /sbin/ldconfig
 %postun        wave -p /sbin/ldconfig
 
@@ -727,6 +741,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libboost_timer.so
 %attr(755,root,root) %{_libdir}/libboost_type_erasure.so
 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
+%attr(755,root,root) %{_libdir}/libboost_url.so
 %attr(755,root,root) %{_libdir}/libboost_wave.so
 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
 %{_includedir}/boost
@@ -762,6 +777,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libboost_system.a
 %{_libdir}/libboost_test_exec_monitor.a
 %{_libdir}/libboost_timer.a
+%{_libdir}/libboost_url.a
 %{_libdir}/libboost_thread.a
 %{_libdir}/libboost_type_erasure.a
 %{_libdir}/libboost_unit_test_framework.a
@@ -883,6 +899,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
 
+%files url
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libboost_url.so.*.*.*
+
 %files wave
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
This page took 0.168826 seconds and 4 git commands to generate.