]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
126a4a167e5b4d0cf3e2db339c12083398948a3c
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #
6 # Conditional build:
7 %bcond_without  python2         # boost-python[2] support
8 %bcond_without  python3         # boost-python3 support
9 %bcond_without  numpy           # boost-numpy support
10
11 %define         fver    %(echo %{version} | tr . _)
12 Summary:        The Boost C++ Libraries
13 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
14 Name:           boost
15 Version:        1.63.0
16 Release:        4
17 License:        Boost Software License and others
18 Group:          Libraries
19 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
20 # Source0-md5:  1c837ecd990bb022d07e7aab32b09847
21 Patch0:         %{name}-link.patch
22 Patch1:         %{name}-x32-context.patch
23 Patch2:         %{name}-clean-gcc-flags.patch
24 Patch3:         %{name}-numpy3.patch
25 Patch4:         hash-new-char-types.patch
26 # FC Patches:
27 Patch201:       %{name}-python-abi_letters.patch
28 # https://github.com/boostorg/build/issues/163
29 Patch202:       %{name}-dual-python-build.patch
30 # https://svn.boost.org/trac/boost/ticket/5637
31 Patch203:       %{name}-1.54.0-mpl-print.patch
32 # https://svn.boost.org/trac/boost/ticket/8881
33 Patch221:       %{name}-1.54.0-mpi-unused_typedef.patch
34 URL:            http://www.boost.org/
35 BuildRequires:  bzip2-devel
36 BuildRequires:  expat-devel
37 BuildRequires:  libicu-devel
38 BuildRequires:  libstdc++-devel >= 6:4.7
39 BuildRequires:  perl-base
40 %if %{with python}
41 BuildRequires:  python-devel >= 2.2
42 %{?with_numpy:BuildRequires:    python-numpy-devel}
43 %endif
44 %if %{with python3}
45 BuildRequires:  python3-devel
46 %{?with_numpy:BuildRequires:    python3-numpy-devel}
47 %endif
48 BuildRequires:  rpm-pythonprov
49 BuildRequires:  zlib-devel
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
53
54 # __once_call, __once_callable non-function symbols from libstdc++
55 %define         skip_post_check_so      libboost_context.so.* libboost_fiber.so.*
56
57 %description
58 The Boost web site provides free peer-reviewed portable C++ source
59 libraries. The emphasis is on libraries which work well with the C++
60 Standard Library. One goal is to establish "existing practice" and
61 provide reference implementations so that the Boost libraries are
62 suitable for eventual standardization. Some of the libraries have
63 already been proposed for inclusion in the C++ Standards Committee's
64 upcoming C++ Standard Library Technical Report.
65
66 %description -l pl.UTF-8
67 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
68 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
69 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
70 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
71 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
72 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
73 Raporcie Technicznym Biblioteki Standardowej C++.
74
75 %package devel
76 Summary:        Boost C++ development headers
77 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       %{name}-chrono = %{version}-%{release}
81 Requires:       %{name}-context = %{version}-%{release}
82 Requires:       %{name}-date_time = %{version}-%{release}
83 Requires:       %{name}-fiber = %{version}-%{release}
84 Requires:       %{name}-filesystem = %{version}-%{release}
85 Requires:       %{name}-graph = %{version}-%{release}
86 Requires:       %{name}-locale = %{version}-%{release}
87 Requires:       %{name}-log = %{version}-%{release}
88 Requires:       %{name}-program_options = %{version}-%{release}
89 Requires:       %{name}-regex = %{version}-%{release}
90 Requires:       %{name}-signals = %{version}-%{release}
91 Requires:       %{name}-system = %{version}-%{release}
92 Requires:       %{name}-test = %{version}-%{release}
93 Requires:       %{name}-thread = %{version}-%{release}
94 Requires:       %{name}-timer = %{version}-%{release}
95 Requires:       %{name}-wave = %{version}-%{release}
96 Requires:       libstdc++-devel >= 6:4.7
97 Obsoletes:      boost-any-devel
98 Obsoletes:      boost-array-devel
99 Obsoletes:      boost-asio
100 Obsoletes:      boost-bind-devel
101 Obsoletes:      boost-call_traits-devel
102 Obsoletes:      boost-compatibility-devel
103 Obsoletes:      boost-compose-devel
104 Obsoletes:      boost-compressed_pair-devel
105 Obsoletes:      boost-concept_check-devel
106 Obsoletes:      boost-conversion-devel
107 Obsoletes:      boost-crc-devel
108 Obsoletes:      boost-date_time-devel
109 Obsoletes:      boost-filesystem-devel
110 Obsoletes:      boost-graph-devel
111 Obsoletes:      boost-mem_fn-devel
112 Obsoletes:      boost-mpl-devel
113 Obsoletes:      boost-preprocessor-devel
114 Obsoletes:      boost-program_options-devel
115 Obsoletes:      boost-ref-devel
116 Obsoletes:      boost-regex-devel
117 Obsoletes:      boost-signals-devel
118 Obsoletes:      boost-spirit-devel
119 Obsoletes:      boost-statechart-devel
120 Obsoletes:      boost-static_assert-devel
121 Obsoletes:      boost-test-devel
122 Obsoletes:      boost-thread-devel
123 Obsoletes:      boost-tr1-devel
124 Obsoletes:      boost-type_traits-devel
125 Obsoletes:      boost-typeof-devel
126 Obsoletes:      boost-uBLAS-devel
127 Obsoletes:      boost-utility-devel
128 Obsoletes:      boost-wave-devel
129 Obsoletes:      boost-xpressive-devel
130
131 %description devel
132 Header files for the Boost C++ libraries.
133
134 %description devel -l pl.UTF-8
135 Pliki nagłówkowe bibliotek C++ Boost.
136
137 %package static
138 Summary:        Static version of base Boost C++ libraries
139 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
140 Group:          Development/Libraries
141 Requires:       %{name}-devel = %{version}-%{release}
142 Obsoletes:      boost-static < 1.33
143
144 %description static
145 Static version of base Boost C++ libraries.
146
147 %description static -l pl.UTF-8
148 Statyczne wersje podstawowych bibliotek C++ Boost.
149
150 %package python-devel-common
151 Summary:        Boost.Python development headers
152 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Boost.Python
153 Group:          Development/Libraries
154 Requires:       %{name}-devel = %{version}-%{release}
155
156 %description python-devel-common
157 Headers for the Boost.Python library.
158
159 %description python-devel-common -l pl.UTF-8
160 Pliki nagłówkowe biblioteki Boost.Python.
161
162 %package python
163 Summary:        Boost.Python library for Python 2
164 Summary(pl.UTF-8):      Biblioteka Boost.Python dla Pythona 2
165 Group:          Libraries
166 Requires:       python-libs
167
168 %description python
169 Use the Boost Python Library to quickly and easily export a C++
170 library to Python 2 such that the Python 2 interface is very similar
171 to the C++ interface. It is designed to be minimally intrusive on your
172 C++ design. In most cases, you should not have to alter your C++
173 classes in any way in order to use them with Boost.Python. The system
174 should simply ``reflect'' your C++ classes and functions into Python
175 3.
176
177 %description python -l pl.UTF-8
178 Biblioteka Boost Python służy do szybkiego i prostego eksportu
179 biblioteki C++ do Pythona 2, tak że interfejs Pythona 2 jest bardzo
180 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
181 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
182 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
183 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
184 klasy C++ i funkcje do Pythona 3.
185
186 %package python-devel
187 Summary:        Boost.Python development files for Python 2
188 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 2
189 Group:          Development/Libraries
190 Requires:       %{name}-devel = %{version}-%{release}
191 Requires:       %{name}-python = %{version}-%{release}
192 Requires:       %{name}-python-devel-common = %{version}-%{release}
193
194 %description python-devel
195 Boost.Python development files for Python 2.
196
197 %description python-devel -l pl.UTF-8
198 Pliki programistyczne biblioteki Boost.Python dla Pythona 2.
199
200 %package python-static
201 Summary:        Static version of Boost.Python library for Python 2
202 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 2
203 Group:          Development/Libraries
204 Requires:       %{name}-python-devel = %{version}-%{release}
205
206 %description python-static
207 Static version of Boost.Python library for Python 2.
208
209 %description python-static -l pl.UTF-8
210 Statyczna wersja biblioteki Boost.Python dla Pythona 2.
211
212 %package python3
213 Summary:        Boost.Python library for Python 3
214 Summary(pl.UTF-8):      biblioteka Boost.Python dla Pythona 3
215 Group:          Libraries
216 Requires:       python3-libs
217
218 %description python3
219 Use the Boost Python Library to quickly and easily export a C++
220 library to Python 3 such that the Python 3 interface is very similar
221 to the C++ interface. It is designed to be minimally intrusive on your
222 C++ design. In most cases, you should not have to alter your C++
223 classes in any way in order to use them with Boost.Python. The system
224 should simply ``reflect'' your C++ classes and functions into Python
225 3.
226
227 %description python3 -l pl.UTF-8
228 Biblioteka Boost Python służy do szybkiego i prostego eksportu
229 biblioteki C++ do Pythona 3, tak że interfejs Pythona 3 jest bardzo
230 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
231 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
232 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
233 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
234 klasy C++ i funkcje do Pythona 3.
235
236 %package python3-devel
237 Summary:        Boost.Python development files for Python 3
238 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 3
239 Group:          Development/Libraries
240 Requires:       %{name}-devel = %{version}-%{release}
241 Requires:       %{name}-python-devel-common = %{version}-%{release}
242 Requires:       %{name}-python3 = %{version}-%{release}
243
244 %description python3-devel
245 Boost.Python development files for Python 3.
246
247 %description python3-devel -l pl.UTF-8
248 Pliki programistyczne biblioteki Boost.Python dla Pythona 3.
249
250 %package python3-static
251 Summary:        Static version of Boost.Python library for Python 3
252 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 3
253 Group:          Development/Libraries
254 Requires:       %{name}-python3-devel = %{version}-%{release}
255
256 %description python3-static
257 Static version of Boost.Python library for Python 3.
258
259 %description python3-static -l pl.UTF-8
260 Statyczna wersja biblioteki Boost.Python dla Pythona 3.
261
262 %package chrono
263 Summary:        Useful time utilities
264 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
265 Group:          Libraries
266 Obsoletes:      boost < 1.33
267
268 %description chrono
269 Useful time utilities.
270
271 %description chrono -l pl.UTF-8
272 Przydatne funkcje związane z czasem.
273
274 %package context
275 Summary:        Boost.Context - context switching library
276 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
277 Group:          Libraries
278
279 %description context
280 Boost.Context - context switching library, providing a sort of
281 cooperative multitasking on a single thread.
282
283 %description context -l pl.UTF-8
284 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
285 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
286
287 %package date_time
288 Summary:        Date-Time library
289 Summary(pl.UTF-8):      Biblioteka daty-czasu
290 Group:          Libraries
291 Obsoletes:      boost < 1.33
292
293 %description date_time
294 A set of date-time libraries.
295
296 %description date_time -l pl.UTF-8
297 Zbiór bibliotek daty-czasu.
298
299 %package fiber
300 Summary:        A framework for micro-/userland-threads (fibers) scheduled cooperatively
301 Summary(pl.UTF-8):      Szkielet mikrowątków przestrzeni użytkownika (fibers), szeregowanych kooperacyjnie
302 Group:          Libraries
303
304 %description fiber
305 boost::fiber provides a framework for micro-/userland-threads (fibers)
306 scheduled cooperatively. The API contains classes and functions
307 to manage and synchronize fibers similiar to boost.thread.
308
309 %description fiber -l pl.UTF-8
310 boost::fiber to szkielt mikrowątków przestrzeni użytkownika (fibers)
311 szeregowanych kooperacyjnie. API zawiera klasy i funkcje służące do
312 zarządzania i synchronizacji wątków podobne do boost.thread.
313
314 %package filesystem
315 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
316 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
317 Group:          Libraries
318 Requires:       %{name}-system = %{version}-%{release}
319 Obsoletes:      boost < 1.33
320
321 %description filesystem
322 The boost::filesystem library provides portable facilities to query
323 and manipulate paths, files, and directories.
324
325 %description filesystem -l pl.UTF-8
326 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
327 operacjach na ścieżkach, plikach i katalogach.
328
329 %package graph
330 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
331 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
332 Group:          Libraries
333
334 %description graph
335 The boost::graph library provides portable facilities to operate on
336 graph data structures using graph algorithms.
337
338 %description graph -l pl.UTF-8
339 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
340 strukturach danych typu graf za pomocą algorytmów związanych z
341 grafami.
342
343 %package locale
344 Summary:        Provide localization and Unicode handling tools for C++
345 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
346 Group:          Libraries
347
348 %description locale
349 Provide localization and Unicode handling tools for C++.
350
351 %description locale -l pl.UTF-8
352 Narzędzia do obsługi lokalizacji i Unikodu w C++.
353
354 %package log
355 Summary:        Provide logging tools for C++
356 Summary(pl.UTF-8):      Narzędzia do logowania w C++
357 Group:          Libraries
358
359 %description log
360 Provide logging tools for C++.
361
362 %description log -l pl.UTF-8
363 Narzędzia do logowania w C++.
364
365 %package program_options
366 Summary:        Access to program options, via conventional methods such as command line and config file
367 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
368 Group:          Libraries
369
370 %description program_options
371 The program_options library allows program developers to obtain
372 program options, that is (name, value) pairs from the user, via
373 conventional methods such as command line and config file.
374
375 %description program_options -l pl.UTF-8
376 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
377 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
378 jak linia poleceń, czy plik konfiguracyjny.
379
380 %package regex
381 Summary:        Boost C++ regular expressions library
382 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
383 Group:          Libraries
384
385 %description regex
386 Shared library for Boost C++ regular expressions.
387
388 %description regex -l pl.UTF-8
389 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
390
391 %package signals
392 Summary:        Signals & slots callback implementation
393 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
394 Group:          Libraries
395 Obsoletes:      boost < 1.33
396
397 %description signals
398 The boost::signals library is an implementation of a signals and slots
399 system.
400
401 %description signals -l pl.UTF-8
402 Biblioteka boost::signals jest implementacją systemu sygnałów i
403 slotów.
404
405 %package system
406 Summary:        Support for getting system specific error codes
407 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
408 Group:          Libraries
409
410 %description system
411 The Boost System library provides simple, light-weight error_code
412 objects that encapsulate system-specific error code values, yet also
413 provide access to more abstract and portable error conditions objects.
414
415 %description system -l pl.UTF-8
416 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
417 obudowujące wartości kodów błędów specyficznych dla systemu, dając
418 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
419 błędów.
420
421 %package test
422 Summary:        Support for program testing and execution monitoring
423 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
424 Group:          Libraries
425 Obsoletes:      boost < 1.33
426
427 %description test
428 Support for simple program testing, full unit testing, and for program
429 execution monitoring.
430
431 %description test -l pl.UTF-8
432 Wsparcie dla prostego testowania programu, pełnego testowania i
433 monitorowania wykonania programu.
434
435 %package thread
436 Summary:        Portable C++ threads library
437 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
438 Group:          Libraries
439 Obsoletes:      boost < 1.33
440
441 %description thread
442 Portable C++ threads library - shared library.
443
444 %description thread -l pl.UTF-8
445 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
446
447 %package timer
448 Summary:        Event timer, progress timer, and progress display classes
449 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
450 Group:          Libraries
451 Obsoletes:      boost < 1.33
452
453 %description timer
454 Event timer, progress timer, and progress display classes.
455
456 %description timer -l pl.UTF-8
457 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
458
459 %package wave
460 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
461 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
462 Group:          Development/Libraries
463
464 %description wave
465 Boost.Wave - a standard compliant C++ preprocessor library.
466
467 %description wave -l pl.UTF-8
468 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
469
470 %package doc
471 Summary:        Boost C++ Library documentation
472 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
473 Group:          Documentation
474 %if "%{_rpmversion}" >= "5"
475 BuildArch:      noarch
476 %endif
477
478 %description doc
479 Documentation for the Boost C++ Library.
480
481 %description doc -l pl.UTF-8
482 Dokumentacja dla biblioteki Boost C++.
483
484 %prep
485 %setup -q -n %{name}_%{fver}
486 %patch0 -p1
487 %patch1 -p1
488 %patch2 -p1
489 %patch3 -p1
490 %patch4 -p1
491
492 %patch201 -p1
493 %patch202 -p1
494 %patch203 -p0
495 %patch221 -p1
496
497 cat << EOF > tools/build/src/user-config.jam
498 using gcc : %{cxx_version} : %{__cxx} : <cflags>"%{rpmcflags} -fPIC" <cxxflags>"%{rpmcxxflags} -std=c++11 -fPIC" <linkflags>"%{rpmldflags}" ;
499 EOF
500
501 # cleanup backups after patching
502 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
503
504 %build
505 EXPAT_INCLUDE=%{_includedir} \
506 EXPAT_LIBPATH=%{_libdir} \
507 ICU_PATH=%{_prefix} \
508 ./bootstrap.sh \
509         --prefix=%{_prefix} \
510         -without-libraries=python
511
512 ./b2 \
513         -d2 --toolset=gcc \
514         variant=release \
515         debug-symbols=on \
516         inlining=on \
517         link=static,shared \
518         threading=multi
519
520 %if %{with python3}
521 echo "using python : %{py3_ver} : %{py3_prefix} : %{py3_incdir} : : : : m ;" >> project-config.jam
522 ./b2 \
523         --with-python python=%{py3_ver} \
524         -a -d2 --toolset=gcc \
525         variant=release \
526         debug-symbols=on \
527         inlining=on \
528         link=static,shared \
529         threading=multi
530 %endif
531
532 %if %{with python2}
533 %{__sed} -i -e '/^using python : 3/d' project-config.jam
534 echo "using python : %{py_ver} : %{py_prefix} : %{py_incdir} ;" >> project-config.jam
535 ./b2 \
536         --with-python python=%{py_ver} \
537         -a -d2 --toolset=gcc \
538         variant=release \
539         debug-symbols=on \
540         inlining=on \
541         link=static,shared \
542         threading=multi
543 %endif
544
545 %install
546 rm -rf $RPM_BUILD_ROOT
547 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
548
549 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
550
551 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
552 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
553 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
554
555 # documentation
556 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
557
558 # as the documentation doesn't completely reside in a directory of its
559 # own, we need to find out ourselves... this looks for HTML files and
560 # then collects everything linked from those.  this is certainly quite
561 # unoptimized wrt mkdir calls, but does it really matter?
562 installdocs() {
563 for i in $(find -type f -name '*.htm*'); do
564         # bjam docu is included in the boost-jam RPM
565         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
566                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
567                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
568                         sub rewrite_link
569                         {
570                                 my $link = shift;
571                                 # rewrite links from boost/* to %{_includedir}/boost/* and
572                                 # ignore external links as well as document-internal ones.
573                                 # HTML files are also ignored as they get installed anyway.
574                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
575                                 {
576                                         (my $file = $link) =~ s/\#.*//;
577                                         print "$file\n";
578                                 }
579                                 $link;
580                         }
581                         open IN, @ARGV[0];
582                         open OUT, ">@ARGV[1]";
583                         my $in_link;
584                         while (<IN>)
585                         {
586                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
587                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
588                                 print OUT;
589                                 $in_link = /href|src=\s*$/;
590                         }
591 EOT`; do
592                         TARGET=${i%/*}/$LINKED
593                         # ignore non-existant linked files
594                         if test -f $TARGET; then
595                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
596                         fi
597                 done
598         fi
599 done
600 }; installdocs
601
602 %clean
603 rm -rf $RPM_BUILD_ROOT
604
605 %post   -p /sbin/ldconfig
606 %postun -p /sbin/ldconfig
607
608 %post   chrono -p /sbin/ldconfig
609 %postun chrono -p /sbin/ldconfig
610
611 %post   context -p /sbin/ldconfig
612 %postun context -p /sbin/ldconfig
613
614 %post   date_time -p /sbin/ldconfig
615 %postun date_time -p /sbin/ldconfig
616
617 %post   fiber -p /sbin/ldconfig
618 %postun fiber -p /sbin/ldconfig
619
620 %post   filesystem -p /sbin/ldconfig
621 %postun filesystem -p /sbin/ldconfig
622
623 %post   graph -p /sbin/ldconfig
624 %postun graph -p /sbin/ldconfig
625
626 %post   locale -p /sbin/ldconfig
627 %postun locale -p /sbin/ldconfig
628
629 %post   python -p /sbin/ldconfig
630 %postun python -p /sbin/ldconfig
631
632 %post   python3 -p /sbin/ldconfig
633 %postun python3 -p /sbin/ldconfig
634
635 %post   program_options -p /sbin/ldconfig
636 %postun program_options -p /sbin/ldconfig
637
638 %post   regex -p /sbin/ldconfig
639 %postun regex -p /sbin/ldconfig
640
641 %post   signals -p /sbin/ldconfig
642 %postun signals -p /sbin/ldconfig
643
644 %post   system -p /sbin/ldconfig
645 %postun system -p /sbin/ldconfig
646
647 %post   test -p /sbin/ldconfig
648 %postun test -p /sbin/ldconfig
649
650 %post   thread -p /sbin/ldconfig
651 %postun thread -p /sbin/ldconfig
652
653 %post   timer -p /sbin/ldconfig
654 %postun timer -p /sbin/ldconfig
655
656 %post   wave -p /sbin/ldconfig
657 %postun wave -p /sbin/ldconfig
658
659 %files
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
662 %attr(755,root,root) %{_libdir}/libboost_container.so.*.*.*
663 %attr(755,root,root) %{_libdir}/libboost_coroutine.so.*.*.*
664 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
665 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
666 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
667 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
668 %attr(755,root,root) %{_libdir}/libboost_type_erasure.so.*.*.*
669 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
670
671 %files devel
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/libboost_atomic.so
674 %attr(755,root,root) %{_libdir}/libboost_chrono.so
675 %attr(755,root,root) %{_libdir}/libboost_container.so
676 %attr(755,root,root) %{_libdir}/libboost_context.so
677 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
678 %attr(755,root,root) %{_libdir}/libboost_date_time.so
679 %attr(755,root,root) %{_libdir}/libboost_fiber.so
680 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
681 %attr(755,root,root) %{_libdir}/libboost_graph.so
682 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
683 %attr(755,root,root) %{_libdir}/libboost_locale.so
684 %attr(755,root,root) %{_libdir}/libboost_log.so
685 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
686 %attr(755,root,root) %{_libdir}/libboost_math_*.so
687 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
688 %attr(755,root,root) %{_libdir}/libboost_program_options.so
689 %attr(755,root,root) %{_libdir}/libboost_regex.so
690 %attr(755,root,root) %{_libdir}/libboost_random.so
691 %attr(755,root,root) %{_libdir}/libboost_serialization.so
692 %attr(755,root,root) %{_libdir}/libboost_signals.so
693 %attr(755,root,root) %{_libdir}/libboost_system.so
694 %attr(755,root,root) %{_libdir}/libboost_thread.so
695 %attr(755,root,root) %{_libdir}/libboost_timer.so
696 %attr(755,root,root) %{_libdir}/libboost_type_erasure.so
697 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
698 %attr(755,root,root) %{_libdir}/libboost_wave.so
699 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
700 %{_includedir}/boost
701 %exclude %{_includedir}/boost/python
702 %exclude %{_includedir}/boost/python.hpp
703
704 %files static
705 %defattr(644,root,root,755)
706 %{_libdir}/libboost_atomic.a
707 %{_libdir}/libboost_chrono.a
708 %{_libdir}/libboost_container.a
709 %{_libdir}/libboost_context.a
710 %{_libdir}/libboost_coroutine.a
711 %{_libdir}/libboost_date_time.a
712 %{_libdir}/libboost_exception.a
713 %{_libdir}/libboost_fiber.a
714 %{_libdir}/libboost_filesystem.a
715 %{_libdir}/libboost_graph.a
716 %{_libdir}/libboost_iostreams.a
717 %{_libdir}/libboost_locale.a
718 %{_libdir}/libboost_log.a
719 %{_libdir}/libboost_log_setup.a
720 %{_libdir}/libboost_math_*.a
721 %{_libdir}/libboost_prg_exec_monitor.a
722 %{_libdir}/libboost_program_options.a
723 %{_libdir}/libboost_random.a
724 %{_libdir}/libboost_regex.a
725 %{_libdir}/libboost_serialization.a
726 %{_libdir}/libboost_signals.a
727 %{_libdir}/libboost_system.a
728 %{_libdir}/libboost_test_exec_monitor.a
729 %{_libdir}/libboost_timer.a
730 %{_libdir}/libboost_thread.a
731 %{_libdir}/libboost_type_erasure.a
732 %{_libdir}/libboost_unit_test_framework.a
733 %{_libdir}/libboost_wave.a
734 %{_libdir}/libboost_wserialization.a
735
736 %if %{with python2} || %{with python3}
737 %files python-devel-common
738 %defattr(644,root,root,755)
739 %{_includedir}/boost/python
740 %{_includedir}/boost/python.hpp
741 %endif
742
743 %if %{with python2}
744 %files python
745 %defattr(644,root,root,755)
746 %if %{with numpy}
747 %attr(755,root,root) %{_libdir}/libboost_numpy.so.*.*.*
748 %endif
749 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
750
751 %files python-devel
752 %defattr(644,root,root,755)
753 %if %{with numpy}
754 %attr(755,root,root) %{_libdir}/libboost_numpy.so
755 %endif
756 %attr(755,root,root) %{_libdir}/libboost_python.so
757
758 %files python-static
759 %defattr(644,root,root,755)
760 %if %{with numpy}
761 %{_libdir}/libboost_numpy.a
762 %endif
763 %{_libdir}/libboost_python.a
764 %endif
765
766 %if %{with python3}
767 %files python3
768 %defattr(644,root,root,755)
769 %if %{with numpy}
770 %attr(755,root,root) %{_libdir}/libboost_numpy3.so.*.*.*
771 %endif
772 %attr(755,root,root) %{_libdir}/libboost_python3.so.*.*.*
773
774 %files python3-devel
775 %defattr(644,root,root,755)
776 %if %{with numpy}
777 %attr(755,root,root) %{_libdir}/libboost_numpy3.so
778 %endif
779 %attr(755,root,root) %{_libdir}/libboost_python3.so
780
781 %files python3-static
782 %defattr(644,root,root,755)
783 %if %{with numpy}
784 %{_libdir}/libboost_numpy3.a
785 %endif
786 %{_libdir}/libboost_python3.a
787 %endif
788
789 %files chrono
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
792
793 %files context
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
796
797 %files date_time
798 %defattr(644,root,root,755)
799 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
800
801 %files fiber
802 %defattr(644,root,root,755)
803 %attr(755,root,root) %{_libdir}/libboost_fiber.so.*.*.*
804
805 %files filesystem
806 %defattr(644,root,root,755)
807 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
808
809 %files graph
810 %defattr(644,root,root,755)
811 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
812
813 %files locale
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
816
817 %files log
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
820 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
821
822 %files program_options
823 %defattr(644,root,root,755)
824 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
825
826 %files regex
827 %defattr(644,root,root,755)
828 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
829
830 %files signals
831 %defattr(644,root,root,755)
832 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
833
834 %files system
835 %defattr(644,root,root,755)
836 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
837
838 %files test
839 %defattr(644,root,root,755)
840 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
841 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
842
843 %files thread
844 %defattr(644,root,root,755)
845 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
846
847 %files timer
848 %defattr(644,root,root,755)
849 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
850
851 %files wave
852 %defattr(644,root,root,755)
853 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
854
855 %files doc
856 %defattr(644,root,root,755)
857 %{_docdir}/%{name}-%{version}
This page took 0.157321 seconds and 3 git commands to generate.