]> git.pld-linux.org Git - packages/boomerang.git/blob - boomerang.spec
- new
[packages/boomerang.git] / boomerang.spec
1 %bcond_with     flex_bison_c++
2 Summary:        A general, open source, retargetable decompiler of native executable files
3 Summary(pl):    Ogólny, otwarty dekompilator natywnych plików wykonywalnych
4 Name:           boomerang
5 Version:        0.0.0.20040707
6 Release:        0.1
7 License:        GPL
8 Group:          Development/Languages
9 Source0:        %{name}.tar.gz
10 # Source0-md5:  97d2b1825b3e2d5bcd85df48eb15a45e
11 URL:            http://boomerang.sourceforge.net/
12 %if %{with flex_bison_c++}
13 BuildRequires:  bison++
14 BuildRequires:  flex
15 %endif
16 BuildRequires:  cppunit-devel
17 BuildRequires:  expat-devel
18 BuildRequires:  gc-devel
19 BuildRequires:  libstdc++-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 An attempt to develop a real decompiler through the open source
24 community. A decompiler takes as input an executable file, and
25 attempts to create a high level, compilable, even maintainable source
26 file that does the same thing. It is therefore the opposite of a
27 compiler, which of course takes a source file and makes an executable.
28 It won't of course recreate the original source file; probably nothing
29 like it. It does not matter if the executable file has symbols or not,
30 or was compiled from any particular language. (However, languages like
31 ML that are usually interpreted are not considered.)
32
33 The intent is to create a retargetable decompiler (i.e. one that can
34 work with different types of input executable files with modest
35 effort, e.g. X86-windows, sparc-solaris, etc). It will be highly
36 modular, so that different parts of the decompiler can be replaced
37 with experimental modules. It is intended to eventually become
38 interactive, a la IDA Pro, because some things (not just variable
39 names and comments, though these are obviously very important) require
40 expert intervention.
41
42 %description -l pl
43 Próba stworzenia prawdziwego dekompilatora przez spo³eczno¶æ otwartego
44 oprogramowania. Dekompilator przyjmuje na wej¶ciu plik wykonywalny i
45 próbuje stworzyæ kompilowalny, a nawet zarz±dzalny, plik ¼ród³owy w
46 jêzyku wy¿szego poziomu wykonuj±cy to samo zadanie. Jest to wiêc
47 przeciwieñstwo kompilatora, który oczywi¶cie przyjmuje plik ¼ród³owy i
48 tworzy wykonywalny. Oczywi¶cie dekompilator nie odtworzy oryginalnego
49 pliku ¼ród³owego; raczej nic z tych rzeczy. Nie ma znaczenia, czy plik
50 wykonywalny ma symbole czy nie, ani czy zosta³ skompilowany z jakiego¶
51 konkretnego jêzyka (jednak jêzyki w rodzaju ML, które s± zwykle
52 interpretowane, nie s± brane pod uwagê).
53
54 Intencj± jest stworzenie dekompilatora dla wielu architektur (czyli
55 takiego, który mo¿e dzia³aæ z ró¿nymi rodzajami wej¶ciowych plików
56 wykonywalnych z przyzwoitym efektem, np. x86-windows, sparc-solaris
57 itp.). Bêdzie bardzo modularny, wiêc wiele czê¶ci dekompilatora mo¿e
58 zostaæ zast±piona eksperymentalnymi modu³ami. Byæ mo¿e stanie siê
59 interaktywny, jak IDA Pro, poniewa¿ niektóre rzeczy (nie tylko nazwy
60 zmiennych i komentarze, chocia¿ te s± oczywi¶cie bardzo wa¿ne)
61 wymagaj± interwencji eksperta.
62
63 %prep
64 %setup -q -n %{name}
65
66 %build
67 rm -rf */CVS
68
69 ln -s %{_includedir}/cppunit include/cppunit
70 %configure
71
72 %if ! %{with flex_bison_c++}
73 %{__make} remote
74 %endif
75
76 %{__make} \
77         C="%{__cc} %{rpmcflags} -I%{_includedir}/gc" \
78         CC="%{__cxx} %{rpmcflags} -I%{_includedir}/gc"
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT{%{_libdir},%{_datadir}/%{name},%{_bindir}}
83
84 install %{name} $RPM_BUILD_ROOT%{_bindir}
85 cp -a signatures transformations $RPM_BUILD_ROOT%{_datadir}/%{name}
86 cp -a lib $RPM_BUILD_ROOT%{_libdir}/%{name}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %attr(755,root,root) %{_bindir}/*
94 %{_datadir}/%{name}
95 %dir %{_libdir}/%{name}
96 %attr(755,root,root) %{_libdir}/%{name}/*.so
This page took 0.037896 seconds and 3 git commands to generate.