]> git.pld-linux.org Git - packages/boomerang.git/blob - boomerang.spec
- initial pld release (still raw and nfy)
[packages/boomerang.git] / boomerang.spec
1 Summary:        An attempt at a general, open source, retargetable decompiler of native executable files
2 Name:           boomerang
3 Version:        0.0.0.20040707
4 Release:        0.1
5 License:        GPL
6 Group:          Development/Languages
7 Source0:        %{name}.tar.gz
8 # Source0-md5:  97d2b1825b3e2d5bcd85df48eb15a45e
9 URL:            http://boomerang.sourceforge.net/
10 BuildRequires:  bison++
11 BuildRequires:  flexx++
12 BuildRequires:  cppunit
13 BuildRequires:  expat-devel
14 BuildRequires:  libstdc++-devel
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 An attempt to develop a real decompiler through the open source
19 community. A decompiler takes as input an executable file, and
20 attempts to create a high level, compilable, even maintainable source
21 file that does the same thing. It is therefore the opposite of a
22 compiler, which of course takes a source file and makes an executable.
23 It won't of course recreate the original source file; probably nothing
24 like it. It does not matter if the executable file has symbols or not,
25 or was compiled from any particular language. (However, languages like
26 ML that are usually interpreted are not considered.)
27
28 The intent is to create a retargetable decompiler (i.e. one that can
29 work with different types of input executable files with modest
30 effort, e.g. X86-windows, sparc-solaris, etc). It will be highly
31 modular, so that different parts of the decompiler can be replaced
32 with experimental modules. It is intended to eventually become
33 interactive, a la IDA Pro, because some things (not just variable
34 names and comments, though these are obviously very important) require
35 expert intervention.
36
37 %prep
38 %setup -q -n %{name}
39
40 %build
41 %configure
42
43 %{__make} \
44         C="%{__cc}" \
45         CC="%{__cxx}"
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT%{_libdir}/emacs/site-lisp
50
51 %{__make} install \
52         DESTDIR="$RPM_BUILD_ROOT"
53
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
This page took 0.113798 seconds and 3 git commands to generate.