]> git.pld-linux.org Git - packages/bond.git/blob - bond.spec
- OBN :=> One Big NYF
[packages/bond.git] / bond.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  tests           # build without tests
5 #
6 Summary:        -
7 Summary(pl):    -
8 Name:           bond
9 Version:        2.0.9
10 Release:        0.1
11 License:        GPL v2
12 #Vendor:                -
13 Group:          -
14 #Icon:          -
15 Source0:        http://bond.treshna.com/%{name}-%{version}.tar.gz
16 # Source0-md5:  08b033a93d8b1a123a1be5fe112ac521
17 #Source1:       -
18 #Source1-md5:   -
19 #Patch0:                %{name}-what.patch
20 URL:            http://bond.treshna.com/
21 BuildRequires:  libxml2-devel >= 2.6.0
22 BuildRequires:  postgresql-devel 
23 #PreReq:                -
24 #Requires(pre,post):    -
25 #Requires(preun):       -
26 #Requires(postun):      -
27 Requires:       libxml2 >= 2.6.0
28 #Provides:      -
29 #Obsoletes:     -
30 #Conflicts:     -
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Bond is a rapid application development (RAD) tool for linux that allows you to create network database programs quickly and easily. With this new version comes major updates in Bond XML format, and a move away from the use of C code completely! This means you can create powerful database programs quickly, only requiring knowledge of XML and SQL.
35
36 %description -l pl
37
38 #%package subpackage
39 #Summary:       -
40 #Summary(pl):   -
41 #Group:         -
42
43 #%description subpackage
44
45 #%description subpackage -l pl
46
47 %prep
48 %setup -q -n %{name}
49 #%patch0 -p1
50
51 %build
52 # if ac/am/* rebuilding is necessary, do it in this order and add
53 # appropriate BuildRequires
54
55 for pack in bonddb bond; do
56
57 cd $pack
58 #%{__gettextize}
59 #%{__libtoolize}
60 #%{__aclocal}
61 #%{__autoconf}
62 #%{__autoheader}
63 #%{__automake}
64 %configure
65 %{__make}
66
67 cd ..
68 done
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 # create directories if necessary
73 #install -d $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %pre
82
83 %post
84
85 %preun
86
87 %postun
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
92
93 # if _sysconfdir != /etc:
94 #%%dir %{_sysconfdir}
95 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
96
97 %attr(755,root,root) %{_bindir}/*
98
99 %{_datadir}/%{name}
100
101 # initscript and its config
102 %attr(754,root,root) /etc/rc.d/init.d/%{name}
103 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
104
105 #%files subpackage
106 #%defattr(644,root,root,755)
107 #%doc extras/*.gz
108 #%{_datadir}/%{name}-ext
This page took 0.205481 seconds and 3 git commands to generate.