]> git.pld-linux.org Git - packages/boinc.git/blob - boinc.spec
- started packaging real boinc applications
[packages/boinc.git] / boinc.spec
1 # TODO:
2 #       - check for BR-s
3 #       - check configure options
4 #       - create devel and static subpackages
5 #       - package boinc script into separate package
6 #       - build files section
7 #       - maybe BOINC.spec
8 #       - find out license
9
10 Summary:        BOINC - Berkeley Open Infrastructure for Network Computing
11 Name:           boinc
12 Version:        5.3.19
13 Release:        0.1
14 License:        GPL
15 Group:          Applications
16 Source0:        %{name}-%{version}.tar.gz
17 # Source0-md5:  96281927b4f4288db389d58fc548c83b
18 Source1:        http://phileimer.9online.fr/%{name}-1.10.tar.bz2
19 # Source1-md5:  85907bd0b9b3527ee90ee73ad2d4ea8d
20 Patch0:         %{name}-include.patch
21 Patch1:         %{name}-path.patch
22 URL:            http://phileimer.9online.fr/
23 BuildRequires:  glut-devel
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  curl-devel
26 BuildRequires:  wxWidgets-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 BOINC is a software platform for distributed computing using volunteered
31 computer resources.
32
33
34 %package script
35 Summary:        boinc - a bash script used to manage boinc client
36 Summary(pl):    boinc - napisany w bashu skrypt do zarz±dzania klientem boinc
37 Group:          Applications
38 URL:            http://phileimer.9online.fr/
39
40 %description script
41 boinc is a bash script for unix like systems used to manage client of
42 the BOINC project (Berkeley Open Infrastructure for Network
43 Computing).
44
45 %description script -l pl
46 boinc to napisany w bashu skrypt dla systemów uniksowych s³u¿±cy do
47 zarz±dzania klientem projektu BOINC (Berkeley Open Infrastructure for
48 Network Computing).
49
50 %prep
51 %setup -q
52 %patch0 -p1
53 mv clientgui/BOINCDial{u,U}pManager.h
54
55 %build
56 #%%{__gettextize}
57 %{__libtoolize}
58 %{__aclocal} -I m4
59 %{__autoconf}
60 %{__autoheader}
61 %{__automake}
62 cp -f /usr/share/automake/config.sub .
63 %configure \
64         --enable-static \
65         --enable-shared \
66         --with-x \
67         --with-ssl \
68         --with-wx-config=/usr/bin/wx-gtk2-ansi-config
69         
70 %{__make}
71
72 #%{__make} \
73 #       CFLAGS="%{rpmcflags}" \
74 #       LDFLAGS="%{rpmldflags}"
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 # create directories if necessary
79 #install -d $RPM_BUILD_ROOT
80 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 #%%install
86 #rm -rf $RPM_BUILD_ROOT
87 #install -d $RPM_BUILD_ROOT%{_bindir}
88
89 #install boinc $RPM_BUILD_ROOT%{_bindir}
90
91 %clean
92 #rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %doc CHANGES README
97 %attr(755,root,root) %{_bindir}/*
This page took 0.048189 seconds and 3 git commands to generate.