]> git.pld-linux.org Git - packages/bogl.git/blob - bogl.spec
9946f0c2a5d6bb15ece125d477596683cde831af
[packages/bogl.git] / bogl.spec
1 # TODO
2 # - optflags
3 Summary:        A terminal program for displaying Unicode on the console
4 Summary(pl.UTF-8):   Program terminalowy do wyświetlania Unikodu na konsoli
5 Name:           bogl
6 Version:        0.1.18
7 Release:        1
8 Epoch:          0
9 License:        GPL
10 Group:          Libraries
11 Source0:        %{name}_%{version}-1.tar.gz
12 # Source0-md5:  9658700ed196eb1789c12aca0a095cb5
13 Source1:        wlite-0.8.1.tar.gz
14 # Source1-md5:  03a2faa33978e88ea2b9ff4679b8f2df
15 Source2:        http://www.cl.cam.ac.uk/~mgk25/download/ucs-fonts.tar.gz
16 # Source2-md5:  cca6a3cb6cfbde5f3ebb24278a9022a4
17 Source3:        http://www.cl.cam.ac.uk/~mgk25/download/ucs-fonts-asian.tar.gz
18 # Source3-md5:  d3184f182c6eebfcf156d08a65696496
19 Source4:        14x14cjk.bdf.gz
20 # Source4-md5:  c08ab351a43a91632127f509aadc6797
21 Patch0:         %{name}-0.1.18-rh.patch
22 Patch1:         %{name}-0.1.9-fpic.patch
23 Patch3:         %{name}-0.1.9-2.6fbdev.patch
24 Patch4:         %{name}-0.1.18-gcc.patch
25 Patch5:         %{name}-0.1.18-noexecstack.patch
26 URL:            http://www.stanford.edu/~blp/projects.html
27 BuildRequires:  gd-devel
28 BuildRequires:  libpng-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 BOGL stands for Ben's Own Graphics Library. It is a small graphics
33 library for Linux kernel framebuffers. It supports only very simple
34 graphics.
35
36 %description -l pl.UTF-8
37 BOGL oznacza Ben's Own Graphics Library (bibliotekę graficzną Bena).
38 Jest to mała biblioteka dla framebufferów jądra Linuksa. Obsługuje
39 tylko bardzo prostą grafikę.
40
41 %package devel
42 Summary:        Development files required to build BOGL applications
43 Summary(pl.UTF-8):   Pliki programistyczne potrzebne do budowania aplikacji BOGL
44 Group:          Development/Libraries
45 Requires:       %{name} = %{epoch}:%{version}-%{release}
46
47 %description devel
48 The bogl-devel package contains the header files for writing BOGL
49 applications.
50
51 %description devel -l pl.UTF-8
52 Ten pakiet zawiera pliki nagłówkowe do pisania aplikacji BOGL.
53
54 %package static
55 Summary:        Static BOGL libraries
56 Summary(pl.UTF-8):   Statyczne biblioteki BOGL
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
59
60 %description static
61 Static BOGL libraries.
62
63 %description static -l pl.UTF-8
64 Statyczne biblioteki BOGL.
65
66 %package bterm
67 Summary:        A Unicode capable terminal program for the Linux framebuffer
68 Summary(pl.UTF-8):   Obsługujący Unikod program terminalowy dla linuksowego framebuffera
69 Group:          Applications/System
70 Requires:       %{name} = %{epoch}:%{version}-%{release}
71
72 %description bterm
73 The bterm application is a terminal emulator that displays to a Linux
74 framebuffer. It is able to display Unicode text on the console.
75
76 %description bterm -l pl.UTF-8
77 Aplikacja bterm to emulator terminala wyświetlający obraz na
78 linuksowym framebufferze. Potrafi wyświetlać tekst unikodowy na
79 konsoli.
80
81 %prep
82 %setup -q -n %{name} -a 1
83 %patch0 -p1
84 %patch1 -p1
85 %patch3 -p1
86 %patch4 -p1
87 %patch5 -p1
88
89 mkdir -p fonts
90 cd fonts
91 tar zxf %{SOURCE2}
92 tar zxf %{SOURCE3}
93
94 %build
95 %{__make} \
96         CFLAGS="%{rpmcflags}"
97 #./mergebdf fonts/9x18.bdf fonts/18x18ja.bdf > font.bdf
98 gunzip -c %{SOURCE4} > font.bdf
99 ./bdftobogl -b font.bdf > font.bgf
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT \
106         libdir=%{_libdir}
107
108 %{__make} -C wlite install \
109         prefix=$RPM_BUILD_ROOT%{_prefix} \
110         libdir=$RPM_BUILD_ROOT%{_libdir}
111
112 if [ -f wlite/libwlitediet.a ]; then
113         install -m 644 wlite/libwlitediet.a $RPM_BUILD_ROOT%{_libdir}
114 fi
115 install -d $RPM_BUILD_ROOT%{_libdir}/bogl
116 install font.bgf $RPM_BUILD_ROOT%{_libdir}/bogl
117 install font.bdf $RPM_BUILD_ROOT%{_libdir}/bogl
118 gzip -9n $RPM_BUILD_ROOT%{_libdir}/bogl/font.bdf
119 gzip -9n $RPM_BUILD_ROOT%{_libdir}/bogl/font.bgf
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc README
130 %attr(755,root,root) %{_libdir}/libbogl.so.*.*
131
132 %files devel
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_bindir}/bdftobogl
135 %attr(755,root,root) %{_bindir}/mergebdf
136 %attr(755,root,root) %{_bindir}/pngtobogl
137 %attr(755,root,root) %{_bindir}/reduce-font
138 %attr(755,root,root) %{_libdir}/libbogl.so
139 %{_libdir}/libbterm.a
140 %{_libdir}/libwlite.a
141 %{_includedir}/bogl
142 %{_includedir}/wlite*.h
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libbogl.a
147
148 %files bterm
149 %defattr(644,root,root,755)
150 %doc README.BOGL-bterm
151 %attr(755,root,root) %{_bindir}/bterm
152 # XXX: dir duplicated with terminfo package
153 %dir %{_datadir}/terminfo/b
154 %{_datadir}/terminfo/b/bterm
155 %{_libdir}/bogl
This page took 0.057334 seconds and 2 git commands to generate.