]> git.pld-linux.org Git - packages/bochs.git/commitdiff
- added fonts
authorundefine <undefine@pld-linux.org>
Wed, 13 Jun 2001 08:32:24 +0000 (08:32 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- STB?

Changed files:
    bochs.spec -> 1.4

bochs.spec

index a8f75aad2e0ce3b9b4f4b1a23580c41847ef27fb..601a56214b449d249e3319796a428d7a816392f8 100644 (file)
@@ -5,6 +5,7 @@ Version:        1.1.2
 Release:       1
 License:       GPL
 Group:         Applications/Emulators
+Group(de):     Applikationen/Emulators
 Group(pl):     Aplikacje/Emulatory
 Source0:       ftp://bochs.com/pub/%{name}-%{version}.tar.gz
 URL:           http://www.bochs.com/
@@ -33,21 +34,39 @@ twoim komputerze.
        --enable-cdrom \
        --with-x11
 %{__make}
+cd font
+for i in vga.bdf hercules.bdf; 
+do
+       bdftopcf $i -o `basename $i .bdf`.pcf
+done;
+cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT/{%{_bindir},%{_datadir}/bochs/bios}
+install -d $RPM_BUILD_ROOT/{%{_bindir},%{_datadir}/bochs/bios,%{_datadir}/fonts/misc}
 install bochs $RPM_BUILD_ROOT/%{_bindir}
 install bios/BIOS-bochs-990925a bios/VGABIOS-elpin-2.40 $RPM_BUILD_ROOT%{_datadir}/bochs/bios
 mv -f .bochsrc .brc
 echo "Example .bochrc file - put it into selected directory and modify" \
      "path to images" >.bochsrc
 sed -e 's#bios#%{_datadir}/bochs/bios#g' <.brc >>.bochsrc
-gzip -9nf docs-html/* bios/VGABIOS-elpin-LICENSE .bochsrc
+gzip -9nf docs-html/* bios/VGABIOS-elpin-LICENSE .bochsrc font/*.pcf
+install font/*.pcf* $RPM_BUILD_ROOT%{_datadir}/fonts/misc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
+%post
+if [ -x /usr/X11R6/bin/mkfontdir ]; then
+        (cd /usr/share/fonts/misc; /usr/X11R6/bin/mkfontdir)
+fi
+killall -USR1 xfs > /dev/null 2>&1 ||:
+
+%postun
+if [ -x /usr/X11R6/bin/mkfontdir ]; then
+        (cd /usr/share/fonts/misc; /usr/X11R6/bin/mkfontdir)
+fi
+killall -USR1 xfs > /dev/null 2>&1 ||:
 
 %files
 %defattr(644,root,root,755)
@@ -55,3 +74,4 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/bochs
 %dir %{_datadir}/bochs
 %{_datadir}/bochs/*
+%{_datadir}/fonts/misc/*.pcf*
This page took 0.092619 seconds and 4 git commands to generate.