]> git.pld-linux.org Git - packages/bochs.git/blob - bochs.spec
- update to 2.1.pre3
[packages/bochs.git] / bochs.spec
1 # TODO:
2 #       - more subpackages (plugins)
3
4 %define pre     pre3
5 Summary:        Portable x86 PC Emulator
6 Summary(pl):    Przeno¶ny emulator x86 PC
7 Name:           bochs
8 Version:        2.1
9 Release:        0.%{pre}.1
10 License:        GPL
11 Group:          Applications/Emulators
12 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.%{pre}.tar.gz
13 # Source0-md5:  d9cf6b0373c40e636368f73859544269
14 Patch0:         %{name}-ncurses.patch
15 Patch1:         %{name}-wxGTK.patch
16 URL:            http://bochs.sourceforge.net/
17 BuildRequires:  SDL-devel
18 BuildRequires:  XFree86-devel
19 BuildRequires:  autoconf
20 BuildRequires:  docbook-dtd41-sgml
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  ncurses-devel
23 BuildRequires:  svgalib-devel
24 BuildRequires:  wxGTK-devel
25 BuildRequires:  zlib-devel
26 Requires:       XFree86-fonts
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Bochs is a portable x86 PC emulation software package that emulates
31 enough of the x86 CPU, related AT hardware, and BIOS to run DOS,
32 Windows '95, Minix 2.0, and other OS's, all on your workstation.
33
34 %description -l pl
35 Bochs jest przeno¶nym emulatorem x86 PC emuluj±cym wystarczaj±co du¿o
36 architektury procesora x86 oraz hardware'u AT i BIOS-u ¿eby uruchomiæ
37 DOS-a, Windows 95, Minix 2.0 i inne systemu operacyjne, wszystkie na
38 Twoim komputerze.
39
40 %prep
41 %setup -q -n %{name}-%{version}.%{pre}
42 %patch0 -p1
43 %patch1 -p1
44
45 %build
46 %{__autoconf}
47 # --enable-x86-64 (not supported together with --enable-sep)
48 # --enable-debugger --enable-iodebug --enable-x86-debugger (slowdowns emulation)
49 # --enable-apic (no need to specify, configure will choose best depending on nr cpus)
50 %configure \
51         --enable-config-interface \
52         --enable-new-pit \
53         --enable-plugins \
54         --enable-cpu-level=6 \
55         --enable-compressed-hd \
56         --enable-ne2000 \
57         --enable-pci \
58         --enable-usb \
59         --enable-4meg-pages \
60         --enable-pae \
61         --enable-guest2host-tlb \
62         --enable-repeat-speedups \
63         --enable-icache \
64 %ifarch %{ix86}
65         --enable-fast-function-calls \
66 %endif
67         --enable-global-pages \
68         --enable-host-specific-asms \
69         --enable-ignore-bad-msr \
70         --enable-disasm \
71         --enable-all-optimizations \
72         --enable-readline \
73         --enable-instrumentation \
74         --enable-vbe \
75         --enable-fpu \
76         --enable-mmx \
77         --enable-3dnow \
78         --enable-sse=2 \
79         --enable-sep \
80         --enable-cdrom \
81         --enable-sb16=linux \
82         --enable-gameport \
83         --with-x \
84         --with-wx \
85         --with-rfb \
86         --with-sdl \
87         --with-svga \
88         --with-x11 \
89         --with-term \
90         --with-rfb
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT \
99         docdir=%{_docdir}/%{name}-%{version}
100
101 mv -f $RPM_BUILD_ROOT%{_datadir}/bochs/VGABIOS*{LICENSE,README,latest} \
102     $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
103
104 cp -f TESTFORM.txt $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
105
106 rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*fonts
107 rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*pcf
108
109 find $RPM_BUILD_ROOT -type d -name CVS | xargs rm -rf
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_bindir}/*
117 %dir %{_libdir}/%{name}
118 %dir %{_libdir}/%{name}/plugins
119 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so.*
120 %{_libdir}/%{name}/plugins/*.la
121 %dir %{_datadir}/%{name}
122 %dir %{_datadir}/%{name}/keymaps
123 %attr(755,root,root) %{_datadir}/%{name}/keymaps/convertmap.pl
124 %{_datadir}/%{name}/keymaps/*.map
125 %{_datadir}/%{name}/*BIOS*
126 %{_mandir}/man[15]/*
127 %{_docdir}/%{name}-%{version}
This page took 0.077888 seconds and 4 git commands to generate.