]> git.pld-linux.org Git - packages/bochs.git/blob - bochs.spec
- conditional svgalib build
[packages/bochs.git] / bochs.spec
1 # TODO:
2 #       - more subpackages (plugins)
3
4 # Conditional build:
5 %bcond_without  svga    # without svgalib support
6 #
7 %ifnarch %{ix86} alpha
8 %undefine with_svga
9 %endif
10 Summary:        Portable x86 PC Emulator
11 Summary(pl):    Przeno¶ny emulator x86 PC
12 Name:           bochs
13 Version:        2.1.1
14 Release:        1
15 License:        GPL
16 Group:          Applications/Emulators
17 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
18 # Source0-md5:  7b21efbe2b56cc15d110993234259b33
19 Patch0:         %{name}-ncurses.patch
20 URL:            http://bochs.sourceforge.net/
21 BuildRequires:  SDL-devel
22 BuildRequires:  XFree86-devel
23 BuildRequires:  autoconf
24 BuildRequires:  docbook-dtd41-sgml
25 BuildRequires:  gtk+-devel
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  ncurses-devel
28 %{?with_svga:BuildRequires:     svgalib-devel}
29 BuildRequires:  wxGTK2-devel
30 BuildRequires:  zlib-devel
31 Requires:       XFree86-fonts
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Bochs is a portable x86 PC emulation software package that emulates
36 enough of the x86 CPU, related AT hardware, and BIOS to run DOS,
37 Windows '95, Minix 2.0, and other OS's, all on your workstation.
38
39 %description -l pl
40 Bochs jest przeno¶nym emulatorem x86 PC emuluj±cym wystarczaj±co du¿o
41 architektury procesora x86 oraz hardware'u AT i BIOS-u ¿eby uruchomiæ
42 DOS-a, Windows 95, Minix 2.0 i inne systemu operacyjne, wszystkie na
43 Twoim komputerze.
44
45 %prep
46 %setup -q
47 %patch0 -p1
48
49 %build
50 %{__autoconf}
51 # --enable-x86-64 (not supported together with --enable-sep)
52 # --enable-debugger --enable-iodebug --enable-x86-debugger (slowdowns emulation)
53 # --enable-apic (no need to specify, configure will choose best depending on nr cpus)
54 %configure \
55         WX_CONFIG=wxgtk2-2.4-config \
56         --enable-config-interface \
57         --enable-new-pit \
58         --enable-plugins \
59         --enable-cpu-level=6 \
60         --enable-compressed-hd \
61         --enable-ne2000 \
62         --enable-pci \
63         --enable-usb \
64         --enable-4meg-pages \
65         --enable-pae \
66         --enable-guest2host-tlb \
67         --enable-repeat-speedups \
68         --enable-icache \
69 %ifarch %{ix86}
70         --enable-fast-function-calls \
71 %endif
72         --enable-global-pages \
73         --enable-host-specific-asms \
74         --enable-ignore-bad-msr \
75         --enable-disasm \
76         --enable-all-optimizations \
77         --enable-readline \
78         --enable-instrumentation \
79         --enable-vbe \
80         --enable-fpu \
81         --enable-mmx \
82         --enable-3dnow \
83         --enable-sse=2 \
84         --enable-sep \
85         --enable-cdrom \
86         --enable-sb16=linux \
87         --enable-gameport \
88         --with-x \
89         --with-wx \
90         --with-rfb \
91         --with-sdl \
92         %{?with_svga:-with-svga} \
93         --with-x11 \
94         --with-term \
95         --with-rfb
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT \
104         docdir=%{_docdir}/%{name}-%{version}
105
106 mv -f $RPM_BUILD_ROOT%{_datadir}/bochs/VGABIOS*{LICENSE,README,latest} \
107     $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
108
109 cp -f TESTFORM.txt $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
110
111 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*fonts
112 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*pcf
113
114 #find $RPM_BUILD_ROOT -type d -name CVS | xargs rm -rf
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_bindir}/*
122 %dir %{_libdir}/%{name}
123 %dir %{_libdir}/%{name}/plugins
124 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so.*
125 %{_libdir}/%{name}/plugins/*.la
126 %dir %{_datadir}/%{name}
127 %dir %{_datadir}/%{name}/keymaps
128 %attr(755,root,root) %{_datadir}/%{name}/keymaps/convertmap.pl
129 %{_datadir}/%{name}/keymaps/*.map
130 %{_datadir}/%{name}/*BIOS*
131 %{_mandir}/man[15]/*
132 %{_docdir}/%{name}-%{version}
This page took 0.058613 seconds and 3 git commands to generate.