]> git.pld-linux.org Git - packages/bochs.git/blob - bochs.spec
- removed unneeded wxGTK patch, switched to wxGTK2
[packages/bochs.git] / bochs.spec
1 # TODO:
2 #       - more subpackages (plugins)
3
4 %define pre     pre3
5 Summary:        Portable x86 PC Emulator
6 Summary(pl):    Przeno¶ny emulator x86 PC
7 Name:           bochs
8 Version:        2.1
9 Release:        0.%{pre}.1
10 License:        GPL
11 Group:          Applications/Emulators
12 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.%{pre}.tar.gz
13 # Source0-md5:  d9cf6b0373c40e636368f73859544269
14 Patch0:         %{name}-ncurses.patch
15 URL:            http://bochs.sourceforge.net/
16 BuildRequires:  SDL-devel
17 BuildRequires:  XFree86-devel
18 BuildRequires:  autoconf
19 BuildRequires:  docbook-dtd41-sgml
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  ncurses-devel
22 BuildRequires:  svgalib-devel
23 BuildRequires:  wxGTK2-devel
24 BuildRequires:  zlib-devel
25 Requires:       XFree86-fonts
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Bochs is a portable x86 PC emulation software package that emulates
30 enough of the x86 CPU, related AT hardware, and BIOS to run DOS,
31 Windows '95, Minix 2.0, and other OS's, all on your workstation.
32
33 %description -l pl
34 Bochs jest przeno¶nym emulatorem x86 PC emuluj±cym wystarczaj±co du¿o
35 architektury procesora x86 oraz hardware'u AT i BIOS-u ¿eby uruchomiæ
36 DOS-a, Windows 95, Minix 2.0 i inne systemu operacyjne, wszystkie na
37 Twoim komputerze.
38
39 %prep
40 %setup -q -n %{name}-%{version}.%{pre}
41 %patch0 -p1
42
43 %build
44 %{__autoconf}
45 # --enable-x86-64 (not supported together with --enable-sep)
46 # --enable-debugger --enable-iodebug --enable-x86-debugger (slowdowns emulation)
47 # --enable-apic (no need to specify, configure will choose best depending on nr cpus)
48 %configure \
49         WX_CONFIG=wxgtk2-2.4-config \
50         --enable-config-interface \
51         --enable-new-pit \
52         --enable-plugins \
53         --enable-cpu-level=6 \
54         --enable-compressed-hd \
55         --enable-ne2000 \
56         --enable-pci \
57         --enable-usb \
58         --enable-4meg-pages \
59         --enable-pae \
60         --enable-guest2host-tlb \
61         --enable-repeat-speedups \
62         --enable-icache \
63 %ifarch %{ix86}
64         --enable-fast-function-calls \
65 %endif
66         --enable-global-pages \
67         --enable-host-specific-asms \
68         --enable-ignore-bad-msr \
69         --enable-disasm \
70         --enable-all-optimizations \
71         --enable-readline \
72         --enable-instrumentation \
73         --enable-vbe \
74         --enable-fpu \
75         --enable-mmx \
76         --enable-3dnow \
77         --enable-sse=2 \
78         --enable-sep \
79         --enable-cdrom \
80         --enable-sb16=linux \
81         --enable-gameport \
82         --with-x \
83         --with-wx \
84         --with-rfb \
85         --with-sdl \
86         --with-svga \
87         --with-x11 \
88         --with-term \
89         --with-rfb
90
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT \
98         docdir=%{_docdir}/%{name}-%{version}
99
100 mv -f $RPM_BUILD_ROOT%{_datadir}/bochs/VGABIOS*{LICENSE,README,latest} \
101     $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
102
103 cp -f TESTFORM.txt $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
104
105 rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*fonts
106 rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*pcf
107
108 find $RPM_BUILD_ROOT -type d -name CVS | xargs rm -rf
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_bindir}/*
116 %dir %{_libdir}/%{name}
117 %dir %{_libdir}/%{name}/plugins
118 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so.*
119 %{_libdir}/%{name}/plugins/*.la
120 %dir %{_datadir}/%{name}
121 %dir %{_datadir}/%{name}/keymaps
122 %attr(755,root,root) %{_datadir}/%{name}/keymaps/convertmap.pl
123 %{_datadir}/%{name}/keymaps/*.map
124 %{_datadir}/%{name}/*BIOS*
125 %{_mandir}/man[15]/*
126 %{_docdir}/%{name}-%{version}
This page took 0.0988 seconds and 3 git commands to generate.