]> git.pld-linux.org Git - packages/boa.git/commitdiff
ipv6 things fixed
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 14 Aug 1999 15:18:22 +0000 (15:18 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    boa-PLD.patch -> 1.5

boa-PLD.patch

index 12aa2909f445cb6b63d018b48ee94d64a41f936b..34f27a598c2a1cd08a9e57a5cea2a12bf7923be3 100644 (file)
@@ -1,6 +1,6 @@
-diff -ur boa-0.93.16.1/examples/boa.conf boa-0.93.16.1.new/examples/boa.conf
---- boa-0.93.16.1/examples/boa.conf    Sun Mar 28 15:09:59 1999
-+++ boa-0.93.16.1.new/examples/boa.conf        Fri Jul 16 17:18:24 1999
+diff -urN boa-0.93.16.1.orig/examples/boa.conf boa-0.93.16.1/examples/boa.conf
+--- boa-0.93.16.1.orig/examples/boa.conf       Sat Aug 14 17:10:00 1999
++++ boa-0.93.16.1/examples/boa.conf    Sat Aug 14 17:10:04 1999
 @@ -24,8 +24,8 @@
  #  User: The name or UID the server should run as.
  # Group: The group name or GID the server should run as.
@@ -78,9 +78,31 @@ diff -ur boa-0.93.16.1/examples/boa.conf boa-0.93.16.1.new/examples/boa.conf
  
  # VirtualHost: Maps a virtual host to a directory.
  # Example: VirtualHost cz.boa.org /html/htdocs/boa/
-diff -ur boa-0.93.16.1/src/defines.h boa-0.93.16.1.new/src/defines.h
---- boa-0.93.16.1/src/defines.h        Tue Jan  5 23:19:54 1999
-+++ boa-0.93.16.1.new/src/defines.h    Fri Jul 16 17:07:27 1999
+diff -urN boa-0.93.16.1.orig/src/Makefile.in boa-0.93.16.1/src/Makefile.in
+--- boa-0.93.16.1.orig/src/Makefile.in Sat Aug 14 17:10:00 1999
++++ boa-0.93.16.1/src/Makefile.in      Sat Aug 14 17:11:25 1999
+@@ -9,16 +9,13 @@
+ # Add -DNO_DAEMON if you do not want the server to fork upon launch
+ LDFLAGS = @LIBS@
+-CFLAGS = -O
++CFLAGS = $(RPM_OPT_FLAGS)
+ MANDIR = /usr/local/man
+ BINDIR = /usr/local/sbin
+ # FreeBSD's make doesn't like `ifdef`, but likes `.ifdef`
+-ifdef INET6
+-LDFLAGS += -L/usr/inet6/lib -linet6
+-CFLAGS += -DINET6 -I/usr/inet6/include
+-endif
++CFLAGS += -DINET6
+ # Change these if necessary
+diff -urN boa-0.93.16.1.orig/src/defines.h boa-0.93.16.1/src/defines.h
+--- boa-0.93.16.1.orig/src/defines.h   Sat Aug 14 17:10:00 1999
++++ boa-0.93.16.1/src/defines.h        Sat Aug 14 17:10:04 1999
 @@ -26,7 +26,7 @@
  /***** Change this, or use -c on the command line to specify it *****/
  
@@ -99,25 +121,41 @@ diff -ur boa-0.93.16.1/src/defines.h boa-0.93.16.1.new/src/defines.h
  
  /****** Authorization ******************************************************/
  
-diff -ur boa-0.93.16.1/util/resolver.pl boa-0.93.16.1.new/util/resolver.pl
---- boa-0.93.16.1/util/resolver.pl     Sun Dec 20 00:46:33 1998
-+++ boa-0.93.16.1.new/util/resolver.pl Fri Jul 16 17:08:09 1999
-@@ -1,10 +1,10 @@
--#!/usr/local/bin/perl
-+#!/usr/bin/perl
- # IP address resolver for Boa
- # If you want an "in place" change to the log file,
- # change the first line to
--#!/usr/local/bin/perl -i.bak
-+#!/usr/bin/perl -i.bak
- # Otherwise, send the output of this program wherever you want:
- #  resolver.pl access_log >access_log_resolved
-diff -ur boa-0.93.16.1/util/Makefile boa-0.93.16.1.new/util/Makefile
---- boa-0.93.16.1/util/Makefile        Sun Nov  7 23:18:21 1999
-+++ boa-0.93.16.1.new/util/Makefile    Fri Jul 16 17:29:45 1999
+diff -urN boa-0.93.16.1.orig/src/request.c boa-0.93.16.1/src/request.c
+--- boa-0.93.16.1.orig/src/request.c   Sat Aug 14 17:10:00 1999
++++ boa-0.93.16.1/src/request.c        Sat Aug 14 17:14:43 1999
+@@ -27,10 +27,6 @@
+ #include <netinet/tcp.h>
+ #include <netdb.h>
+-#ifdef INET6
+-#include <support.h>
+-#endif
+-
+ int sockbufsize = SOCKETBUF_SIZE;
+ extern int server_s;                  /* boa socket */
+@@ -154,7 +150,7 @@
+       /* for log file and possible use by CGI programs */
+ #ifdef INET6
+       if (getnameinfo((struct sockaddr *)&remote_addr, 
+-                                                                      NRL_SA_LEN((struct sockaddr *)&remote_addr), 
++                                                                      SA_LEN((struct sockaddr *)&remote_addr), 
+                                                                       conn->remote_ip_addr, 20,
+                                                                       NULL, 0, NI_NUMERICHOST)) {
+                       fprintf(stderr, "[IPv6] getnameinfo failed\n");
+@@ -181,7 +177,7 @@
+     if (getsockname(conn->fd, (struct sockaddr *) &salocal, &dummy) == -1)
+                                                                             die(SERVER_ERROR);
+               if (getnameinfo((struct sockaddr *)&salocal,
+-                  NRL_SA_LEN((struct sockaddr *)&salocal),
++                  SA_LEN((struct sockaddr *)&salocal),
+                   host, 20,
+                   NULL, 0, NI_NUMERICHOST)) {
+       fprintf(stderr, "[IPv6] getnameinfo failed\n");
+diff -urN boa-0.93.16.1.orig/util/Makefile boa-0.93.16.1/util/Makefile
+--- boa-0.93.16.1.orig/util/Makefile   Sat Aug 14 17:10:00 1999
++++ boa-0.93.16.1/util/Makefile        Sat Aug 14 17:10:04 1999
 @@ -4,10 +4,10 @@
        rm cpsel cp-test 
  
@@ -132,3 +170,19 @@ diff -ur boa-0.93.16.1/util/Makefile boa-0.93.16.1.new/util/Makefile
  boa_indexer: index_dir.c
 -      gcc -o boa_indexer index_dir.c
 +      gcc $(RPM_OPT_FLAGS) -o boa_indexer index_dir.c
+diff -urN boa-0.93.16.1.orig/util/resolver.pl boa-0.93.16.1/util/resolver.pl
+--- boa-0.93.16.1.orig/util/resolver.pl        Sat Aug 14 17:10:00 1999
++++ boa-0.93.16.1/util/resolver.pl     Sat Aug 14 17:10:04 1999
+@@ -1,10 +1,10 @@
+-#!/usr/local/bin/perl
++#!/usr/bin/perl
+ # IP address resolver for Boa
+ # If you want an "in place" change to the log file,
+ # change the first line to
+-#!/usr/local/bin/perl -i.bak
++#!/usr/bin/perl -i.bak
+ # Otherwise, send the output of this program wherever you want:
+ #  resolver.pl access_log >access_log_resolved
This page took 0.05422 seconds and 4 git commands to generate.