]> git.pld-linux.org Git - packages/boa.git/blob - boa.spec
- Release 2.
[packages/boa.git] / boa.spec
1 Summary:        Boa high speed HTTP server
2 Summary(pl):    Boa - szybki serwer HTTP
3 Name:           boa
4 Version:        0.94.8.2
5 Release:        2
6 License:        GPL
7 Group:          Networking/Daemons
8 Group(pl):      Sieciowe/Serwery
9 Group(de):      Netzwerkwesen/Server
10 Source0:        http://www.boa.org/%{name}-%{version}.tar.gz
11 Source1:        %{name}.init
12 Patch0:         %{name}-PLD.patch
13 Provides:       httpd                                                           
14 Provides:       webserver                                                       
15 Prereq:         sh-utils
16 Prereq:         %{_sbindir}/groupadd
17 Prereq:         %{_sbindir}/groupdel
18 Prereq:         %{_sbindir}/useradd
19 Prereq:         %{_sbindir}/userdel
20 BuildRequires:  flex
21 Requires:       rc-scripts
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23 %define         _sysconfdir     /etc/httpd
24 Obsoletes:      apache
25
26 %description
27 A high speed, lightweight web server (HTTP protocol). Based on direct
28 use of the select(2) system call, it internally multiplexes all
29 connections without forking, for maximum speed and minimum system
30 resource use.
31
32 %description -l pl
33 Niezwykle szybki i wysoko wydajny serwer WWW (protokó³ HTTP). Bazuje
34 na bezpo¶rednim u¿yciu funkcji systemowej select(2) dziêki czemu mo¿e
35 obs³ugiwaæ wiele po³±czeñ równocze¶nie bez fork()owania co w efekcie
36 znacznie zwiêksza szybko¶æ dzia³ania oraz zmniejsza zu¿ycie zasobów
37 systemowych.
38
39 %prep
40 %setup -q
41 %patch0 -p1
42
43 %build
44 cd src
45 CFLAGS="$RPM_OPT_FLAGS -DINET6"
46 %configure
47 %{__make}
48 (cd ../docs; make boa.html )
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,/var/log/httpd} \
53         $RPM_BUILD_ROOT/home/httpd/{cgi-bin,html} \
54         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man8}
55
56 install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}
57
58 install src/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
59 install examples/resolver.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
60 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
61
62 install boa.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
63
64 install docs/boa.8 $RPM_BUILD_ROOT%{_mandir}/man8/
65
66 touch $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
67
68 gzip -9nf README $RPM_BUILD_ROOT%{_mandir}/man*/*
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %pre
74 %{_sbindir}/groupadd -g 51 -f http > /dev/null 2>&1
75 %{_sbindir}/useradd -u 51 -f http -g http > /dev/null 2>&1
76
77 %postun
78 if [ "$1" = "0" ]; then
79         %{_sbindir}/userdel http > /dev/null 2>&1
80         %{_sbindir}/groupdel http > /dev/null 2>&1
81 fi
82
83 %post
84 /sbin/chkconfig -add %{name}
85
86 %preun
87 if [ "$1" = "0" ]; then
88         if [ -f /var/lock/subsys/boa ]; then
89                 /etc/rc.d/init.d/boa stop 1>&2
90         fi
91         /sbin/chkconfig --del boa
92 fi
93
94 %files
95 %defattr(644,root,root,755)
96 %doc README.gz docs/*.html docs/*.png docs/boa.{ps,sgml}
97 %attr(750, root,http) %dir %{_sysconfdir}
98 %attr(640, root,http) %config %{_sysconfdir}/*
99 %attr(755, root,http) /home/httpd/html
100 %attr(755, root,http) /home/httpd/cgi-bin
101 %attr(750, root,http) %dir /var/log/httpd/
102 %attr(640, root,http) %ghost /var/log/httpd/*
103 %attr(755, root,root) %{_sbindir}/*
104 %attr(754, root,root) /etc/rc.d/init.d/%{name}
105 %{_mandir}/man8/*
This page took 0.597663 seconds and 4 git commands to generate.