]> git.pld-linux.org Git - packages/boa.git/blob - boa.spec
- logrotate patch
[packages/boa.git] / boa.spec
1 #
2 # Conditional build:
3 # _without_ipv6 - IPv4-only version (doesn't require IPv6 in kernel)
4 #
5 Summary:        Boa high speed HTTP server
6 Summary(pl):    Boa - szybki serwer HTTP
7 Name:           boa
8 Version:        0.94.12
9 Release:        1
10 Epoch:          1
11 License:        GPL v2
12 Group:          Networking/Daemons
13 Source0:        http://www.boa.org/%{name}-%{version}.tar.gz
14 Source1:        %{name}.init
15 Patch0:         %{name}-PLD.patch
16 Patch1:         %{name}-logrotate.patch
17 URL:            http://www.boa.org/
18 BuildRequires:  autoconf
19 BuildRequires:  flex
20 BuildRequires:  sgml-tools
21 PreReq:         rc-scripts
22 Requires(pre):  /bin/id
23 Requires(pre):  /usr/bin/getgid
24 Requires(pre):  /usr/sbin/groupadd
25 Requires(pre):  /usr/sbin/useradd
26 Requires(postun):       /usr/sbin/groupdel
27 Requires(postun):       /usr/sbin/userdel
28 Requires(post,preun):   /sbin/chkconfig
29 Provides:       httpd
30 Provides:       webserver
31 Obsoletes:      apache
32 Obsoletes:      httpd
33 Obsoletes:      thttpd
34 Obsoletes:      webserver
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _sysconfdir     /etc/httpd
38
39 %description
40 A high speed, lightweight web server (HTTP protocol). Based on direct
41 use of the select(2) system call, it internally multiplexes all
42 connections without forking, for maximum speed and minimum system
43 resource use.
44
45 %description -l pl
46 Niezwykle szybki i wysoko wydajny serwer WWW (protokó³ HTTP). Bazuje
47 na bezpo¶rednim u¿yciu funkcji systemowej select(2) dziêki czemu mo¿e
48 obs³ugiwaæ wiele po³±czeñ równocze¶nie bez fork()owania co w efekcie
49 znacznie zwiêksza szybko¶æ dzia³ania oraz zmniejsza zu¿ycie zasobów
50 systemowych.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55 %patch1 -p1
56
57 %build
58 cd src
59 CFLAGS="%{rpmcflags} %{!?_without_ipv6:-DINET6}"
60 %{__autoconf}
61 %configure
62 %{__make}
63 cd ../docs
64 %{__make} boa.html
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d/ \
69         $RPM_BUILD_ROOT/var/log/httpd \
70         $RPM_BUILD_ROOT/home/httpd/{cgi-bin,html} \
71         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man8} \
72         $RPM_BUILD_ROOT/etc/logrotate.d
73
74
75 install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}/
76
77 install src/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin/
78 install examples/* $RPM_BUILD_ROOT/home/httpd/cgi-bin/
79 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
80
81 install boa.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
82 install contrib/redhat/boa.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
83
84 install docs/boa.8 $RPM_BUILD_ROOT%{_mandir}/man8/
85
86 touch $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
87
88 gzip -9nf README ChangeLog
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %pre
94 if [ -n "`getgid http`" ]; then
95         if [ "`getgid http`" != "51" ]; then
96                 echo "Error: group http doesn't have gid=51. Correct this before installing boa." 1>&2
97                 exit 1
98         fi
99 else
100         echo "Creating group http GID=51"
101         /usr/sbin/groupadd -g 51 -r -f http
102 fi
103 if [ -n "`id -u http 2>/dev/null`" ]; then
104         if [ "`id -u http`" != "51" ]; then
105                 echo "Error: user http doesn't have uid=51. Correct this before installing boa." 1>&2
106                 exit 1
107         fi
108 else
109         echo "Creating user http UID=51"
110         /usr/sbin/useradd -u 51 -r -d /home/httpd -s /bin/false -c "HTTP User" -g http http 1>&2
111 fi
112
113 %postun
114 if [ "$1" = "0" ]; then
115         echo "Removing user http UID=51"
116         /usr/sbin/userdel http > /dev/null 2>&1
117         echo "Removing group http GID=51"
118         /usr/sbin/groupdel http > /dev/null 2>&1
119 fi
120
121 %post
122 /sbin/chkconfig --add boa
123 if [ -f /var/lock/subsys/boa ]; then
124         /etc/rc.d/init.d/boa restart 1>&2
125 else
126         echo "Run \"/etc/rc.d/init.d/boa start\" to start boa http daemon."
127 fi
128
129 %preun
130 if [ "$1" = "0" ]; then
131         if [ -f /var/lock/subsys/boa ]; then
132                 /etc/rc.d/init.d/boa stop 1>&2
133         fi
134         /sbin/chkconfig --del boa
135 fi
136
137 %files
138 %defattr(644,root,root,755)
139 %doc *.gz docs/*.html docs/*.png
140 %attr(750, root,http) %dir %{_sysconfdir}
141 %attr(640, root,http) %config(noreplace) %{_sysconfdir}/*
142 %attr(640, root,http) %config(noreplace) /etc/logrotate.d/%{name}
143 %attr(755, root,http) /home/httpd/html
144 %attr(755, root,http) /home/httpd/cgi-bin
145 %attr(750, root,http) %dir /var/log/httpd/
146 %attr(640, root,http) %ghost /var/log/httpd/*
147 %attr(755, root,root) %{_sbindir}/*
148 %attr(754, root,root) /etc/rc.d/init.d/%{name}
149 %{_mandir}/man8/*
This page took 0.058918 seconds and 4 git commands to generate.