]> git.pld-linux.org Git - packages/boa.git/blob - boa.spec
- fixed requires (PR#29)
[packages/boa.git] / boa.spec
1 Summary:        Boa high speed HTTP server
2 Summary(pl):    Boa - szybki serwer HTTP
3 Name:           boa
4 Version:        0.93.16.1
5 Release:        1
6 Copyright:      GPL
7 Group:          Networking/Daemons
8 Source0:        http://www.cz.boa.org/updates/%{name}-%{version}.tar.gz
9 Source1:        boa.init
10 Patch0:         boa-PLD.patch
11 Patch1:         boa-0.93.16.1-ipv6-fix.patch
12 Provides:       httpd                                                           
13 Provides:       webserver                                                       
14 Prereq:         sh-utils
15 Prereq:         %{_sbindir}/groupadd
16 Prereq:         %{_sbindir}/groupdel
17 Prereq:         %{_sbindir}/useradd
18 Prereq:         %{_sbindir}/userdel
19 Requires:       rc-scripts
20 BuildRoot:      /tmp/%{name}-%{version}-root
21
22 %define         _sysconfdir     /etc/httpd
23
24 %description
25 A high speed, lightweight web server (HTTP protocol).
26 Based on direct use of the select(2) system call, it internally multiplexes 
27 all connections without forking, for maximum speed and minimum system 
28 resource use.
29
30 %description -l pl
31 Niezwykle szybki i wysoko wydajny serwer WWW (protokó³ HTTP).
32 Bazuje na bezpo¶rednim u¿yciu funkcji systemowej select(2)
33 dziêki czemu mo¿e obs³ugiwaæ wiele po³±czeñ równocze¶nie bez
34 fork()owania co w efekcje daje znacznie zwiêkszon± szybko¶æ
35 dzia³ania oraz mniejsze zu¿ycie zasobów systemowych.
36
37 %prep
38 %setup -q
39 %patch0 -p1
40 %patch1 -p1
41
42 %build
43 cd src
44 %configure
45 make
46 (cd ../util; make )
47 (cd ../docs; make boa.html )
48
49 %install
50 install -d              $RPM_BUILD_ROOT/etc/rc.d/init.d/
51 install -d              $RPM_BUILD_ROOT/var/log/httpd
52 install -d              $RPM_BUILD_ROOT/home/httpd/{cgi-bin,html}
53 install -d              $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man1}
54
55 install -s              src/boa $RPM_BUILD_ROOT%{_sbindir}
56 install -s              util/boa_indexer $RPM_BUILD_ROOT%{_sbindir}
57
58 install -s              util/cpsel $RPM_BUILD_ROOT/home/httpd/cgi-bin
59 install                 util/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
60 install %{SOURCE1}      $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
61
62 install examples/*.conf $RPM_BUILD_ROOT/etc/httpd/%{name}.conf
63 install docs/boa.1      $RPM_BUILD_ROOT%{_mandir}/man1/
64
65 touch                   $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
66 gzip -9nf               README $RPM_BUILD_ROOT%{_mandir}/man*/* || :
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %pre
72 %{_sbindir}/groupadd -g 51 -f http > /dev/null 2>&1
73 %{_sbindir}/useradd -u 51 -f http -g http > /dev/null 2>&1
74
75 %postun
76 if [ "$1" = "0" ]; then
77         %{_sbindir}/groupdel http > /dev/null 2>&1
78         %{_sbindir}/userdel http > /dev/null 2>&1
79 fi
80
81 %post
82 /sbin/chkconfig -add %{name}
83
84 %preun
85 if [ "$1" = "0" ]; then
86         if [ -f /var/lock/subsys/boa ]; then
87                 /etc/rc.d/init.d/boa stop 1>&2
88         fi
89         /sbin/chkconfig --del boa
90 fi
91
92 %files
93 %defattr(644,root,root,755)
94 %doc README.gz docs/*.html docs/*.gif
95 %attr(750, root,http) %dir /etc/httpd
96 %attr(640, root,http) %config /etc/httpd/*
97 %attr(755, root,http) /home/httpd/html
98 %attr(755, root,http) /home/httpd/cgi-bin
99 %attr(750, root,http) %dir /var/log/httpd/
100 %attr(640, root,http) %ghost /var/log/httpd/*
101 %attr(755, root,root) %{_sbindir}/*
102 %attr(754, root,root) /etc/rc.d/init.d/%{name}
103 %{_mandir}/man1/*
This page took 0.145836 seconds and 4 git commands to generate.