]> git.pld-linux.org Git - packages/boa.git/blob - boa.spec
- updated to 0.94.8.3,
[packages/boa.git] / boa.spec
1 Summary:        Boa high speed HTTP server
2 Summary(pl):    Boa - szybki serwer HTTP
3 Name:           boa
4 Version:        0.94.8.3
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Group(de):      Netzwerkwesen/Server
9 Group(pl):      Sieciowe/Serwery
10 Source0:        http://www.boa.org/%{name}-%{version}.tar.gz
11 Source1:        %{name}.init
12 Patch0:         %{name}-PLD.patch
13 Provides:       httpd                                                           
14 Provides:       webserver                                                       
15 Prereq:         sh-utils
16 Prereq:         %{_sbindir}/groupadd
17 Prereq:         %{_sbindir}/groupdel
18 Prereq:         %{_sbindir}/useradd
19 Prereq:         %{_sbindir}/userdel
20 BuildRequires:  flex
21 Requires:       rc-scripts
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23 Obsoletes:      apache
24
25 %define         _sysconfdir     /etc/httpd
26
27 %description
28 A high speed, lightweight web server (HTTP protocol). Based on direct
29 use of the select(2) system call, it internally multiplexes all
30 connections without forking, for maximum speed and minimum system
31 resource use.
32
33 %description -l pl
34 Niezwykle szybki i wysoko wydajny serwer WWW (protokó³ HTTP). Bazuje
35 na bezpo¶rednim u¿yciu funkcji systemowej select(2) dziêki czemu mo¿e
36 obs³ugiwaæ wiele po³±czeñ równocze¶nie bez fork()owania co w efekcie
37 znacznie zwiêksza szybko¶æ dzia³ania oraz zmniejsza zu¿ycie zasobów
38 systemowych.
39
40 %prep
41 %setup -q
42 %patch0 -p1
43
44 %build
45 cd src
46 CFLAGS="%{!?debug:$RPM_OPT_FLAGS}%{?debug:-O -g} -DINET6"
47 %configure
48 %{__make}
49 (cd ../docs; make boa.html )
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,/var/log/httpd} \
54         $RPM_BUILD_ROOT/home/httpd/{cgi-bin,html} \
55         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man8}
56
57 install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}
58
59 install src/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
60 install examples/resolver.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
61 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
62
63 install boa.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
64
65 install docs/boa.8 $RPM_BUILD_ROOT%{_mandir}/man8/
66
67 touch $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
68
69 gzip -9nf README
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %pre
75 %{_sbindir}/groupadd -g 51 -f http > /dev/null 2>&1
76 %{_sbindir}/useradd -u 51 -f http -g http > /dev/null 2>&1
77
78 %postun
79 if [ "$1" = "0" ]; then
80         %{_sbindir}/userdel http > /dev/null 2>&1
81         %{_sbindir}/groupdel http > /dev/null 2>&1
82 fi
83
84 %post
85 /sbin/chkconfig -add %{name}
86
87 %preun
88 if [ "$1" = "0" ]; then
89         if [ -f /var/lock/subsys/boa ]; then
90                 /etc/rc.d/init.d/boa stop 1>&2
91         fi
92         /sbin/chkconfig --del boa
93 fi
94
95 %files
96 %defattr(644,root,root,755)
97 %doc README.gz docs/*.html docs/*.png docs/boa.{ps,sgml}
98 %attr(750, root,http) %dir %{_sysconfdir}
99 %attr(640, root,http) %config %{_sysconfdir}/*
100 %attr(755, root,http) /home/httpd/html
101 %attr(755, root,http) /home/httpd/cgi-bin
102 %attr(750, root,http) %dir /var/log/httpd/
103 %attr(640, root,http) %ghost /var/log/httpd/*
104 %attr(755, root,root) %{_sbindir}/*
105 %attr(754, root,root) /etc/rc.d/init.d/%{name}
106 %{_mandir}/man8/*
This page took 0.046527 seconds and 4 git commands to generate.