]> git.pld-linux.org Git - packages/boa.git/blob - boa.spec
updated for IPv6 fix && init script
[packages/boa.git] / boa.spec
1 Summary:        Boa high speed HTTP server
2 Summary(pl):    Boa - szybki serwer HTTP
3 Name:           boa
4 Version:        0.93.16.1
5 Release:        1
6 Copyright:      GPL
7 Group:          Networking/Daemons
8 Source0:        http://www.cz.boa.org/updates/%{name}-%{version}.tar.gz
9 Source1:        boa.init
10 Patch0:         boa-PLD.patch
11 Patch1:         boa-0.93.16.1-ipv6-fix.patch
12 Provides:       httpd                                                           
13 Provides:       webserver                                                       
14 Prereq:         sh-utils
15 Prereq:         %{_sbindir}/groupadd
16 Prereq:         %{_sbindir}/groupdel
17 Prereq:         %{_sbindir}/useradd
18 Prereq:         %{_sbindir}/userdel
19 BuildRoot:      /tmp/%{name}-%{version}-root
20
21 %define         _sysconfdir     /etc/httpd
22
23 %description
24 A high speed, lightweight web server (HTTP protocol).
25 Based on direct use of the select(2) system call, it internally multiplexes 
26 all connections without forking, for maximum speed and minimum system 
27 resource use.
28
29 %description -l pl
30 Niezwykle szybki i wysoko wydajny serwer WWW (protokó³ HTTP).
31 Bazuje na bezpo¶rednim u¿yciu funkcji systemowej select(2)
32 dziêki czemu mo¿e obs³ugiwaæ wiele po³±czeñ równocze¶nie bez
33 fork()owania co w efekcje daje znacznie zwiêkszon± szybko¶æ
34 dzia³ania oraz mniejsze zu¿ycie zasobów systemowych.
35
36 %prep
37 %setup -q
38 %patch0 -p1
39 %patch1 -p1
40
41 %build
42 cd src
43 %configure
44 make
45 (cd ../util; make )
46 (cd ../docs; make boa.html )
47
48 %install
49 install -d              $RPM_BUILD_ROOT/etc/rc.d/init.d/
50 install -d              $RPM_BUILD_ROOT/var/log/httpd
51 install -d              $RPM_BUILD_ROOT/home/httpd/{cgi-bin,html}
52 install -d              $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man1}
53
54 install -s              src/boa $RPM_BUILD_ROOT%{_sbindir}
55 install -s              util/boa_indexer $RPM_BUILD_ROOT%{_sbindir}
56
57 install -s              util/cpsel $RPM_BUILD_ROOT/home/httpd/cgi-bin
58 install                 util/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
59 install %{SOURCE1}      $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
60
61 install examples/*.conf $RPM_BUILD_ROOT/etc/httpd/%{name}.conf
62 install docs/boa.1      $RPM_BUILD_ROOT%{_mandir}/man1/
63
64 touch                   $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
65 gzip -9nf               README $RPM_BUILD_ROOT%{_mandir}/man*/* || :
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %pre
71 %{_sbindir}/groupadd -g 51 -f http > /dev/null 2>&1
72 %{_sbindir}/useradd -u 51 -f http -g http > /dev/null 2>&1
73
74 %postun
75 if [ "$1" = "0" ]; then
76         %{_sbindir}/groupdel http > /dev/null 2>&1
77         %{_sbindir}/userdel http > /dev/null 2>&1
78 fi
79
80 %post
81 /sbin/chkconfig -add %{name}
82
83 %preun
84 if [ "$1" = "0" ]; then
85         if [ -f /var/lock/subsys/boa ]; then
86                 /etc/rc.d/init.d/boa stop 1>&2
87         fi
88         /sbin/chkconfig --del boa
89 fi
90
91 %files
92 %defattr(644,root,root,755)
93 %doc README.gz docs/*.html docs/*.gif
94 %attr(750, root,http) %dir /etc/httpd
95 %attr(640, root,http) %config /etc/httpd/*
96 %attr(755, root,http) /home/httpd/html
97 %attr(755, root,http) /home/httpd/cgi-bin
98 %attr(750, root,http) %dir /var/log/httpd/
99 %attr(640, root,http) %ghost /var/log/httpd/*
100 %attr(755, root,root) %{_sbindir}/*
101 %attr(754, root,root) /etc/rc.d/init.d/%{name}
102 %{_mandir}/man1/*
This page took 2.037268 seconds and 4 git commands to generate.