]> git.pld-linux.org Git - packages/boa.git/blob - boa.spec
- Prereq: /sbin/chkconfig
[packages/boa.git] / boa.spec
1 Summary:        Boa high speed HTTP server
2 Summary(pl):    Boa - szybki serwer HTTP
3 Name:           boa
4 Version:        0.94.9
5 Release:        2
6 License:        GPL
7 Group:          Networking/Daemons
8 Group(de):      Netzwerkwesen/Server
9 Group(pl):      Sieciowe/Serwery
10 Source0:        http://www.boa.org/%{name}-%{version}.tar.gz
11 Source1:        %{name}.init
12 Patch0:         %{name}-PLD.patch
13 Provides:       httpd                                                           
14 Provides:       webserver                                                       
15 Prereq:         sh-utils
16 Prereq:         %{_sbindir}/groupadd
17 Prereq:         %{_sbindir}/groupdel
18 Prereq:         %{_sbindir}/useradd
19 Prereq:         %{_sbindir}/userdel
20 Prereq:         rc-scripts
21 Prereq:         /sbin/chkconfig
22 BuildRequires:  flex
23 BuildRequires:  sgml-tools
24 BuildRequires:  autoconf
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26 Obsoletes:      apache
27
28 %define         _sysconfdir     /etc/httpd
29
30 %description
31 A high speed, lightweight web server (HTTP protocol). Based on direct
32 use of the select(2) system call, it internally multiplexes all
33 connections without forking, for maximum speed and minimum system
34 resource use.
35
36 %description -l pl
37 Niezwykle szybki i wysoko wydajny serwer WWW (protokó³ HTTP). Bazuje
38 na bezpo¶rednim u¿yciu funkcji systemowej select(2) dziêki czemu mo¿e
39 obs³ugiwaæ wiele po³±czeñ równocze¶nie bez fork()owania co w efekcie
40 znacznie zwiêksza szybko¶æ dzia³ania oraz zmniejsza zu¿ycie zasobów
41 systemowych.
42
43 %prep
44 %setup -q
45 %patch0 -p1
46
47 %build
48 cd src
49 CFLAGS="%{rpmcflags} -DINET6"
50 autoconf
51 %configure
52 %{__make}
53 (cd ../docs; make boa.html )
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,/var/log/httpd} \
58         $RPM_BUILD_ROOT/home/httpd/{cgi-bin,html} \
59         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man8}
60
61 install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}
62
63 install src/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
64 install examples/resolver.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
65 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
66
67 install boa.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
68
69 install docs/boa.8 $RPM_BUILD_ROOT%{_mandir}/man8/
70
71 touch $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
72
73 gzip -9nf README
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %pre
79 if [ -n "`getgid http`" ]; then
80         if [ "`getgid http`" != "51" ]; then
81                 echo "Warning:group http haven't gid=51. Correct this before install boa" 1>&2
82                 exit 1
83         fi
84 else
85         echo "Creating group http GID=51"
86         /usr/sbin/groupadd -g 51 -r -f http
87 fi
88 if [ -n "`id -u http 2>/dev/null`" ]; then
89         if [ "`id -u http`" != "51" ]; then
90                 echo "Warning:user http haven't uid=51. Correct this before install boa" 1>&2
91                 exit 1
92         fi
93 else
94         echo "Creating user http UID=51"
95         /usr/sbin/useradd -u 51 -r -d /home/httpd -s /bin/false -c "HTTP User" -g http http 1>&2
96 fi
97
98 %postun
99 if [ "$1" = "0" ]; then
100         echo "Removing user http UID=51"
101         %{_sbindir}/userdel http > /dev/null 2>&1
102         echo "Removing group http GID=51"
103         %{_sbindir}/groupdel http > /dev/null 2>&1
104 fi
105
106 %post
107 /sbin/chkconfig --add %{name}
108
109 if [ -f /var/lock/subsys/httpd ]; then
110         /etc/rc.d/init.d/httpd restart 1>&2
111 else
112         echo "Run \"/etc/rc.d/init.d/boa start\" to start boa http daemon."
113 fi
114
115 %preun
116 if [ "$1" = "0" ]; then
117         if [ -f /var/lock/subsys/boa ]; then
118                 /etc/rc.d/init.d/boa stop 1>&2
119         fi
120         /sbin/chkconfig --del boa
121 fi
122
123 %files
124 %defattr(644,root,root,755)
125 %doc README.gz docs/*.html docs/*.png docs/boa.{ps,sgml}
126 %attr(750, root,http) %dir %{_sysconfdir}
127 %attr(640, root,http) %config %{_sysconfdir}/*
128 %attr(755, root,http) /home/httpd/html
129 %attr(755, root,http) /home/httpd/cgi-bin
130 %attr(750, root,http) %dir /var/log/httpd/
131 %attr(640, root,http) %ghost /var/log/httpd/*
132 %attr(755, root,root) %{_sbindir}/*
133 %attr(754, root,root) /etc/rc.d/init.d/%{name}
134 %{_mandir}/man8/*
This page took 0.052707 seconds and 4 git commands to generate.