]> git.pld-linux.org Git - packages/boa.git/blob - boa.spec
perl -pi -e "s/^automake -a -c -f --foreing/\%\{__automake\}/; \
[packages/boa.git] / boa.spec
1 #
2 # Conditional build:
3 # _without_ipv6 - IPv4-only version (doesn't require IPv6 in kernel)
4 #
5 Summary:        Boa high speed HTTP server
6 Summary(pl):    Boa - szybki serwer HTTP
7 Name:           boa
8 Version:        0.94.12
9 Release:        1
10 Epoch:          1
11 License:        GPL v2
12 Group:          Networking/Daemons
13 Source0:        http://www.boa.org/%{name}-%{version}.tar.gz
14 Source1:        %{name}.init
15 Patch0:         %{name}-PLD.patch
16 URL:            http://www.boa.org/
17 BuildRequires:  autoconf
18 BuildRequires:  flex
19 BuildRequires:  sgml-tools
20 PreReq:         rc-scripts
21 Requires(pre):  /bin/id
22 Requires(pre):  /usr/bin/getgid
23 Requires(pre):  /usr/sbin/groupadd
24 Requires(pre):  /usr/sbin/useradd
25 Requires(postun):       /usr/sbin/groupdel
26 Requires(postun):       /usr/sbin/userdel
27 Requires(post,preun):   /sbin/chkconfig
28 Provides:       httpd
29 Provides:       webserver
30 Obsoletes:      apache
31 Obsoletes:      httpd
32 Obsoletes:      thttpd
33 Obsoletes:      webserver
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _sysconfdir     /etc/httpd
37
38 %description
39 A high speed, lightweight web server (HTTP protocol). Based on direct
40 use of the select(2) system call, it internally multiplexes all
41 connections without forking, for maximum speed and minimum system
42 resource use.
43
44 %description -l pl
45 Niezwykle szybki i wysoko wydajny serwer WWW (protokó³ HTTP). Bazuje
46 na bezpo¶rednim u¿yciu funkcji systemowej select(2) dziêki czemu mo¿e
47 obs³ugiwaæ wiele po³±czeñ równocze¶nie bez fork()owania co w efekcie
48 znacznie zwiêksza szybko¶æ dzia³ania oraz zmniejsza zu¿ycie zasobów
49 systemowych.
50
51 %prep
52 %setup -q
53 %patch0 -p1
54
55 %build
56 cd src
57 CFLAGS="%{rpmcflags} %{!?_without_ipv6:-DINET6}"
58 %{__autoconf}
59 %configure
60 %{__make}
61 cd ../docs
62 %{__make} boa.html
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d/ \
67         $RPM_BUILD_ROOT/var/log/httpd \
68         $RPM_BUILD_ROOT/home/httpd/{cgi-bin,html} \
69         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man8} \
70         $RPM_BUILD_ROOT/etc/logrotate.d
71
72
73 install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}/
74
75 install src/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin/
76 install examples/* $RPM_BUILD_ROOT/home/httpd/cgi-bin/
77 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
78
79 install boa.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
80 install contrib/redhat/boa.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
81
82 install docs/boa.8 $RPM_BUILD_ROOT%{_mandir}/man8/
83
84 touch $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
85
86 gzip -9nf README ChangeLog
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %pre
92 if [ -n "`getgid http`" ]; then
93         if [ "`getgid http`" != "51" ]; then
94                 echo "Error: group http doesn't have gid=51. Correct this before installing boa." 1>&2
95                 exit 1
96         fi
97 else
98         echo "Creating group http GID=51"
99         /usr/sbin/groupadd -g 51 -r -f http
100 fi
101 if [ -n "`id -u http 2>/dev/null`" ]; then
102         if [ "`id -u http`" != "51" ]; then
103                 echo "Error: user http doesn't have uid=51. Correct this before installing boa." 1>&2
104                 exit 1
105         fi
106 else
107         echo "Creating user http UID=51"
108         /usr/sbin/useradd -u 51 -r -d /home/httpd -s /bin/false -c "HTTP User" -g http http 1>&2
109 fi
110
111 %postun
112 if [ "$1" = "0" ]; then
113         echo "Removing user http UID=51"
114         /usr/sbin/userdel http > /dev/null 2>&1
115         echo "Removing group http GID=51"
116         /usr/sbin/groupdel http > /dev/null 2>&1
117 fi
118
119 %post
120 /sbin/chkconfig --add boa
121 if [ -f /var/lock/subsys/boa ]; then
122         /etc/rc.d/init.d/boa restart 1>&2
123 else
124         echo "Run \"/etc/rc.d/init.d/boa start\" to start boa http daemon."
125 fi
126
127 %preun
128 if [ "$1" = "0" ]; then
129         if [ -f /var/lock/subsys/boa ]; then
130                 /etc/rc.d/init.d/boa stop 1>&2
131         fi
132         /sbin/chkconfig --del boa
133 fi
134
135 %files
136 %defattr(644,root,root,755)
137 %doc *.gz docs/*.html docs/*.png
138 %attr(750, root,http) %dir %{_sysconfdir}
139 %attr(640, root,http) %config(noreplace) %{_sysconfdir}/*
140 %attr(640, root,http) %config(noreplace) /etc/logrotate.d/%{name}
141 %attr(755, root,http) /home/httpd/html
142 %attr(755, root,http) /home/httpd/cgi-bin
143 %attr(750, root,http) %dir /var/log/httpd/
144 %attr(640, root,http) %ghost /var/log/httpd/*
145 %attr(755, root,root) %{_sbindir}/*
146 %attr(754, root,root) /etc/rc.d/init.d/%{name}
147 %{_mandir}/man8/*
This page took 0.099187 seconds and 3 git commands to generate.