]> git.pld-linux.org Git - packages/boa.git/blob - boa.spec
Massive attack. We use -O0 instead -O flags while debug enabled.
[packages/boa.git] / boa.spec
1 Summary:        Boa high speed HTTP server
2 Summary(pl):    Boa - szybki serwer HTTP
3 Name:           boa
4 Version:        0.94.8.3
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Group(de):      Netzwerkwesen/Server
9 Group(pl):      Sieciowe/Serwery
10 Source0:        http://www.boa.org/%{name}-%{version}.tar.gz
11 Source1:        %{name}.init
12 Patch0:         %{name}-PLD.patch
13 Provides:       httpd                                                           
14 Provides:       webserver                                                       
15 Prereq:         sh-utils
16 Prereq:         %{_sbindir}/groupadd
17 Prereq:         %{_sbindir}/groupdel
18 Prereq:         %{_sbindir}/useradd
19 Prereq:         %{_sbindir}/userdel
20 BuildRequires:  flex
21 BuildRequires:  sgml-tools
22 Requires:       rc-scripts
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24 Obsoletes:      apache
25
26 %define         _sysconfdir     /etc/httpd
27
28 %description
29 A high speed, lightweight web server (HTTP protocol). Based on direct
30 use of the select(2) system call, it internally multiplexes all
31 connections without forking, for maximum speed and minimum system
32 resource use.
33
34 %description -l pl
35 Niezwykle szybki i wysoko wydajny serwer WWW (protokó³ HTTP). Bazuje
36 na bezpo¶rednim u¿yciu funkcji systemowej select(2) dziêki czemu mo¿e
37 obs³ugiwaæ wiele po³±czeñ równocze¶nie bez fork()owania co w efekcie
38 znacznie zwiêksza szybko¶æ dzia³ania oraz zmniejsza zu¿ycie zasobów
39 systemowych.
40
41 %prep
42 %setup -q
43 %patch0 -p1
44
45 %build
46 cd src
47 CFLAGS="%{?debug:-O0 -g}%{!?debug:$RPM_OPT_FLAGS} -DINET6"
48 %configure
49 %{__make}
50 (cd ../docs; make boa.html )
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,/var/log/httpd} \
55         $RPM_BUILD_ROOT/home/httpd/{cgi-bin,html} \
56         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man8}
57
58 install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}
59
60 install src/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
61 install examples/resolver.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
62 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
63
64 install boa.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
65
66 install docs/boa.8 $RPM_BUILD_ROOT%{_mandir}/man8/
67
68 touch $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
69
70 gzip -9nf README
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %pre
76 %{_sbindir}/groupadd -g 51 -f http > /dev/null 2>&1
77 %{_sbindir}/useradd -u 51 -f http -g http > /dev/null 2>&1
78
79 %postun
80 if [ "$1" = "0" ]; then
81         %{_sbindir}/userdel http > /dev/null 2>&1
82         %{_sbindir}/groupdel http > /dev/null 2>&1
83 fi
84
85 %post
86 /sbin/chkconfig -add %{name}
87
88 %preun
89 if [ "$1" = "0" ]; then
90         if [ -f /var/lock/subsys/boa ]; then
91                 /etc/rc.d/init.d/boa stop 1>&2
92         fi
93         /sbin/chkconfig --del boa
94 fi
95
96 %files
97 %defattr(644,root,root,755)
98 %doc README.gz docs/*.html docs/*.png docs/boa.{ps,sgml}
99 %attr(750, root,http) %dir %{_sysconfdir}
100 %attr(640, root,http) %config %{_sysconfdir}/*
101 %attr(755, root,http) /home/httpd/html
102 %attr(755, root,http) /home/httpd/cgi-bin
103 %attr(750, root,http) %dir /var/log/httpd/
104 %attr(640, root,http) %ghost /var/log/httpd/*
105 %attr(755, root,root) %{_sbindir}/*
106 %attr(754, root,root) /etc/rc.d/init.d/%{name}
107 %{_mandir}/man8/*
This page took 0.069837 seconds and 3 git commands to generate.