]> git.pld-linux.org Git - packages/boa.git/blob - boa.spec
cosmetics
[packages/boa.git] / boa.spec
1 #
2 # Conditional build:
3 # _without_ipv6 - IPv4-only version (doesn't require IPv6 in kernel)
4 #
5 Summary:        Boa high speed HTTP server
6 Summary(pl):    Boa - szybki serwer HTTP
7 Name:           boa
8 Version:        0.94.14
9 %define _rc     rc17
10 Release:        0.%{_rc}.1
11 Epoch:          1
12 License:        GPL v2
13 Group:          Networking/Daemons
14 Source0:        http://www.boa.org/%{name}-%{version}%{_rc}.tar.gz
15 # Source0-md5:  d668ef85b3d2df3dc9832555fdce8b70
16 Source1:        %{name}.init
17 Patch0:         %{name}-PLD.patch
18 Patch1:         %{name}-logrotate.patch
19 URL:            http://www.boa.org/
20 BuildRequires:  autoconf
21 BuildRequires:  flex
22 BuildRequires:  sgml-tools
23 PreReq:         rc-scripts
24 Requires(pre):  /usr/bin/getgid
25 Requires(pre):  /bin/id
26 Requires(pre):  /usr/sbin/groupadd
27 Requires(pre):  /usr/sbin/useradd
28 Requires(postun):       /usr/sbin/groupdel
29 Requires(postun):       /usr/sbin/userdel
30 Requires(post,preun):   /sbin/chkconfig
31 Provides:       httpd
32 Provides:       webserver
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34 Obsoletes:      apache
35 Obsoletes:      httpd
36 Obsoletes:      thttpd
37 Obsoletes:      webserver
38
39 %define         _sysconfdir     /etc/httpd
40
41 %description
42 A high speed, lightweight web server (HTTP protocol). Based on direct
43 use of the select(2) system call, it internally multiplexes all
44 connections without forking, for maximum speed and minimum system
45 resource use.
46
47 %description -l pl
48 Niezwykle szybki i wysoko wydajny serwer WWW (protokó³ HTTP). Bazuje
49 na bezpo¶rednim u¿yciu funkcji systemowej select(2) dziêki czemu mo¿e
50 obs³ugiwaæ wiele po³±czeñ równocze¶nie bez fork()owania co w efekcie
51 znacznie zwiêksza szybko¶æ dzia³ania oraz zmniejsza zu¿ycie zasobów
52 systemowych.
53
54 %prep
55 %setup -q -n %{name}-%{version}%{_rc}
56 cp examples/boa.conf .
57 %patch0 -p0
58 %patch1 -p0
59
60 %build
61 CFLAGS="%{rpmcflags} %{!?_without_ipv6:-DINET6} -DSERVER_ROOT='\"/etc/httpd\"'"
62 %{__autoconf}
63 %configure
64 %{__make}
65 %{__make} -C docs boa.html
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d/ \
70         $RPM_BUILD_ROOT/var/log/httpd \
71         $RPM_BUILD_ROOT/home/services/httpd/{cgi-bin,html} \
72         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man8} \
73         $RPM_BUILD_ROOT/etc/logrotate.d
74
75 install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}/
76
77 install src/*.pl $RPM_BUILD_ROOT/home/services/httpd/cgi-bin/
78 install examples/* $RPM_BUILD_ROOT/home/services/httpd/cgi-bin/
79 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
80
81 install boa.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
82 install contrib/redhat/boa.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
83
84 install docs/boa.8 $RPM_BUILD_ROOT%{_mandir}/man8/
85
86 touch $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %pre
92 if [ -n "`getgid http`" ]; then
93         if [ "`getgid http`" != "51" ]; then
94                 echo "Error: group http doesn't have gid=51. Correct this before installing boa." 1>&2
95                 exit 1
96         fi
97 else
98         echo "Creating group http GID=51"
99         /usr/sbin/groupadd -g 51 -r -f http
100 fi
101 if [ -n "`id -u http 2>/dev/null`" ]; then
102         if [ "`id -u http`" != "51" ]; then
103                 echo "Error: user http doesn't have uid=51. Correct this before installing boa." 1>&2
104                 exit 1
105         fi
106 else
107         echo "Creating user http UID=51"
108         /usr/sbin/useradd -u 51 -r -d /home/services/httpd -s /bin/false -c "HTTP User" -g http http 1>&2
109 fi
110
111 %postun
112 if [ "$1" = "0" ]; then
113         echo "Removing user http UID=51"
114         /usr/sbin/userdel http > /dev/null 2>&1
115         echo "Removing group http GID=51"
116         /usr/sbin/groupdel http > /dev/null 2>&1
117 fi
118
119 %post
120 /sbin/chkconfig --add boa
121 if [ -f /var/lock/subsys/boa ]; then
122         /etc/rc.d/init.d/boa restart 1>&2
123 else
124         echo "Run \"/etc/rc.d/init.d/boa start\" to start boa http daemon."
125 fi
126
127 %preun
128 if [ "$1" = "0" ]; then
129         if [ -f /var/lock/subsys/boa ]; then
130                 /etc/rc.d/init.d/boa stop 1>&2
131         fi
132         /sbin/chkconfig --del boa
133 fi
134
135 %files
136 %defattr(644,root,root,755)
137 %doc README ChangeLog docs/*.html docs/*.png
138 %attr(750,root,root) %dir %{_sysconfdir}
139 %attr(640,root,root) %config(noreplace) %{_sysconfdir}/*
140 %attr(640,root,root) %config(noreplace) /etc/logrotate.d/%{name}
141 %dir /home/services/httpd
142 %attr(755,root,root) /home/services/httpd/html
143 %attr(755,root,root) /home/services/httpd/cgi-bin
144 %attr(750,root,root) %dir /var/log/httpd/
145 %attr(640,root,root) %ghost /var/log/httpd/*
146 %attr(755,root,root) %{_sbindir}/*
147 %attr(754,root,root) /etc/rc.d/init.d/%{name}
148 %{_mandir}/man8/*
This page took 0.046052 seconds and 3 git commands to generate.