]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- missing BR: librsvg-devel
[packages/bmpx.git] / bmpx.spec
1 # TODO: use browser-plugins if plugin works with something else than firefox (e.g. seamonkey)
2 #
3 # Conditional build:
4 %bcond_without  gaim    # build without D-BUS gaim support
5 %bcond_without  sid     # build without sid support
6 %bcond_without  ofa     # build without MusicIP support
7 #
8 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
9 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+
10 Name:           bmpx
11 Version:        0.36.1
12 Release:        1
13 License:        GPL v2
14 Group:          X11/Applications/Sound
15 Source0:        http://files.beep-media-player.org/releases/0.36/%{name}-%{version}.tar.bz2
16 # Source0-md5:  03a55f8b5b3899f03d71ca9dd681545d
17 Source1:        mp3license
18 Patch0:         %{name}-desktop.patch
19 URL:            http://beep-media-player.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  bison
23 BuildRequires:  boost-bind-devel
24 BuildRequires:  boost-call_traits-devel
25 BuildRequires:  boost-devel
26 BuildRequires:  boost-filesystem-devel
27 BuildRequires:  boost-regex-devel
28 BuildRequires:  cdparanoia-III-devel
29 BuildRequires:  curl-devel
30 BuildRequires:  dbus-glib-devel >= 0.62
31 BuildRequires:  esound-devel >= 0.2.8
32 BuildRequires:  fam-devel
33 BuildRequires:  flex
34 %{?with_gaim:BuildRequires:     gaim-devel}
35 BuildRequires:  gcc-c++ >= 5:4.0.0
36 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.10
37 BuildRequires:  gtkmm-devel >= 2.9.8
38 BuildRequires:  hal-devel >= 0.5.7
39 BuildRequires:  libglademm-devel >= 2.6.2
40 BuildRequires:  libnotify-devel >= 0.4.2
41 BuildRequires:  libmusicbrainz-devel >= 2.1.1
42 %{?with_ofa:BuildRequires:      libofa-devel >= 0.9.3}
43 BuildRequires:  librsvg-devel >= 1:2.14.0
44 %{?with_sid:BuildRequires:      libsidplay-devel}
45 BuildRequires:  libtool
46 BuildRequires:  libvorbis-devel >= 1:1.0
47 BuildRequires:  libxml2-devel >= 1:2.6.26
48 BuildRequires:  mpeg4ip-devel
49 BuildRequires:  neon-devel >= 0.25.5
50 BuildRequires:  rpmbuild(macros) >= 1.311
51 BuildRequires:  rpm-pythonprov
52 BuildRequires:  startup-notification-devel >= 0.8
53 BuildRequires:  taglib-devel >= 1.4-2
54 BuildRequires:  unzip
55 Requires(post,postun):  desktop-file-utils
56 Requires(post,postun):  gtk+2 >= 2:2.10.0
57 Requires(post,postun):  hicolor-icon-theme
58 Requires(post,postun):  shared-mime-info
59 Requires:       gstreamer-audio-effects-base >= 0.10.10
60 Requires:       gstreamer-audio-formats >= 0.10.3
61 Requires:       gstreamer-audiosink
62 Obsoletes:      bmpx-curses
63 Obsoletes:      bmpx-libs
64 Obsoletes:      bmpx-plugin-container
65 Obsoletes:      bmpx-plugin-flow
66 Obsoletes:      bmpx-plugins-base
67 Obsoletes:      bmpx-plugin-transport
68 Obsoletes:      bmpx-remote
69 Obsoletes:      bmpx-remote-gtk
70 Obsoletes:      bmpx-static
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %define         _firefoxdir     %{_libdir}/mozilla-firefox
74 %define         _chromedir      %{_firefoxdir}/chrome
75
76 %description
77 BMPx is the follow-up of the BMP project with a codebase rewritten
78 from scratch and aims to maintain a stable audio player foundation,
79 and to provide a player with a consistent and easy to understand usage
80 experience.
81
82 %description -l pl
83 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
84 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
85 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
86
87 %package devel
88 Summary:        Header files for BMPx media player
89 Summary(pl):    Pliki nag³ówkowe odtwarzacza multimedialnego BMPx
90 Group:          X11/Development/Libraries
91 Requires:       dbus-glib-devel >= 0.62
92 Obsoletes:      libchroma-devel
93 Obsoletes:      libhrel-devel
94
95 %description devel
96 Header files required for compiling BMPx media player plugins.
97
98 %description devel -l pl
99 Pliki nag³ówkowe potrzebne do kompilowania wtyczek odtwarzacza
100 multimedialnego BMPx.
101
102 %package -n mozilla-firefox-plugin-bmpx
103 Summary:        BMPx plugin for Mozilla Firefox
104 Summary(pl):    Wtyczka BMPx dla Mozilli Firefox
105 Group:          X11/Applications
106 Requires:       %{name} = %{version}-%{release}
107 Requires:       mozilla-firefox
108
109 %description -n mozilla-firefox-plugin-bmpx
110 This plugin registers the lastfm:// protocol to BMPx.
111
112 %description -n mozilla-firefox-plugin-bmpx -l pl
113 Ta wtyczka rejestruje protokó³ lastfm:// do BMPx.
114
115 %prep
116 %setup -q
117 %patch0 -p1
118
119 %build
120 %{__libtoolize}
121 %{__aclocal} -I m4
122 %{__autoconf}
123 %{__autoheader}
124 %{__automake}
125 %configure \
126         --enable-hal \
127         --enable-gamin \
128         --enable-libnotify \
129         --enable-mp4v2 \
130         %{?with_ofa:--enable-ofa} \
131         %{?with_sid:--enable-sid} \
132         --enable-shared \
133         --enable-static \
134         %{?with_gaim:--enable-gaim} \
135         --with-dbus-services-dir=%{_datadir}/dbus-1/services
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 install -d $RPM_BUILD_ROOT%{_chromedir}
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT \
144         m4datadir=%{_aclocaldir}
145
146 unzip xpi/bmp.xpi -d $RPM_BUILD_ROOT%{_firefoxdir}
147 sed -e 's@chrome/bmp\.jar@bmp\.jar@' $RPM_BUILD_ROOT%{_firefoxdir}/chrome.manifest \
148         > $RPM_BUILD_ROOT%{_chromedir}/bmp.manifest
149
150 rm -f $RPM_BUILD_ROOT%{_firefoxdir}/{install.rdf,chrome.manifest}
151 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
152 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/{taglib,vfs/container,vfs/transport}/*.{a,la}
153 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/th_TH
154
155 %find_lang %{name}
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post
161 %update_desktop_database_post
162 %update_mime_database
163 %update_icon_cache hicolor
164
165 %banner %{name} -e << EOF
166 Remember to install appropriate GStreamer plugins for files
167 you want to play:
168 - gstreamer-cdparanoia (for Audio-CD)
169 - gstreamer-flac (for FLAC)
170 - gstreamer-mad (for MP3s)
171 - gstreamer-vorbis (for Ogg Vorbis)
172 EOF
173
174 %postun
175 %update_desktop_database_postun
176 %update_mime_database
177 %update_icon_cache hicolor
178
179 %files -f %{name}.lang
180 %defattr(644,root,root,755)
181 %doc AUTHORS ChangeLog NEWS README
182 %attr(755,root,root) %{_bindir}/beep-media-player-2
183 %attr(755,root,root) %{_bindir}/bmp-enqueue-files-2.0 
184 %attr(755,root,root) %{_bindir}/bmp-enqueue-uris-2.0
185 %attr(755,root,root) %{_bindir}/bmp-play-files-2.0
186 %attr(755,root,root) %{_bindir}/bmp-play-lastfm-2.0
187 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-bin
188 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-sentinel
189
190 %dir %{_libdir}/bmpx
191 %dir %{_libdir}/bmpx/plugins
192 %dir %{_libdir}/bmpx/plugins/taglib
193 %dir %{_libdir}/bmpx/plugins/vfs
194 %dir %{_libdir}/bmpx/plugins/vfs/container
195 %dir %{_libdir}/bmpx/plugins/vfs/transport
196 %attr(755,root,root) %{_libdir}/bmpx/plugins/taglib/*.so*
197 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/container/*.so*
198 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/transport/*.so*
199
200 %{_datadir}/bmpx
201 %{_datadir}/dbus-1/services/*.service
202 %{_mandir}/man*/*
203 %{_desktopdir}/*.desktop
204 %{_iconsdir}/hicolor/*/*/*.png
205
206 %files devel
207 %defattr(644,root,root,755)
208 %{_includedir}/bmp-2.0
209 %{_pkgconfigdir}/*.pc
210
211 %files -n mozilla-firefox-plugin-bmpx
212 %defattr(644,root,root,755)
213 %{_chromedir}/bmp.jar
214 %{_chromedir}/bmp.manifest
This page took 0.051579 seconds and 4 git commands to generate.