]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- rel 3
[packages/bmpx.git] / bmpx.spec
1 # TODO: use system libuuid instead of included one
2 # TODO: use browser-plugins if plugin works with something else than firefox (e.g. seamonkey)
3 #
4 # Conditional build:
5 %bcond_without  gaim    # build without D-BUS gaim support
6 %bcond_without  sid     # build without sid support
7 %bcond_without  ofa     # build without MusicIP support
8 #
9 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
10 Summary(pl.UTF-8):      Odtwarzacz dźwięku z interfejsem WinAmpa dla GTK+
11 Name:           bmpx
12 Version:        0.36.1
13 Release:        3
14 License:        GPL v2
15 Group:          X11/Applications/Sound
16 Source0:        http://files.beep-media-player.org/releases/0.36/%{name}-%{version}.tar.bz2
17 # Source0-md5:  03a55f8b5b3899f03d71ca9dd681545d
18 Source1:        mp3license
19 Patch0:         %{name}-desktop.patch
20 URL:            http://beep-media-player.org/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  bison
24 BuildRequires:  boost-bind-devel
25 BuildRequires:  boost-call_traits-devel
26 BuildRequires:  boost-devel
27 BuildRequires:  boost-filesystem-devel
28 BuildRequires:  boost-regex-devel
29 BuildRequires:  cdparanoia-III-devel
30 BuildRequires:  curl-devel
31 BuildRequires:  dbus-glib-devel >= 0.62
32 BuildRequires:  esound-devel >= 0.2.8
33 BuildRequires:  fam-devel
34 BuildRequires:  flex
35 %{?with_gaim:BuildRequires:     gaim-devel}
36 BuildRequires:  gcc-c++ >= 5:4.0.0
37 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.10
38 BuildRequires:  gtkmm-devel >= 2.9.8
39 BuildRequires:  hal-devel >= 0.5.7
40 BuildRequires:  libglademm-devel >= 2.6.2
41 BuildRequires:  libnotify-devel >= 0.4.2
42 BuildRequires:  libmusicbrainz-devel >= 2.1.1
43 %{?with_ofa:BuildRequires:      libofa-devel >= 0.9.3}
44 BuildRequires:  librsvg-devel >= 1:2.14.0
45 %{?with_sid:BuildRequires:      libsidplay-devel}
46 BuildRequires:  libtool
47 #BuildRequires: libuuid-devel
48 BuildRequires:  libvorbis-devel >= 1:1.0
49 BuildRequires:  libxml2-devel >= 1:2.6.26
50 BuildRequires:  mpeg4ip-devel
51 BuildRequires:  neon-devel >= 0.25.5
52 BuildRequires:  rpmbuild(macros) >= 1.311
53 BuildRequires:  rpm-pythonprov
54 BuildRequires:  startup-notification-devel >= 0.8
55 BuildRequires:  taglib-devel >= 1.4-2
56 BuildRequires:  unzip
57 Requires(post,postun):  desktop-file-utils
58 Requires(post,postun):  gtk+2 >= 2:2.10.0
59 Requires(post,postun):  hicolor-icon-theme
60 Requires(post,postun):  shared-mime-info
61 Requires:       gstreamer-audio-effects-base >= 0.10.10
62 Requires:       gstreamer-audio-formats >= 0.10.3
63 Requires:       gstreamer-audiosink
64 Obsoletes:      bmpx-curses
65 Obsoletes:      bmpx-libs
66 Obsoletes:      bmpx-plugin-container
67 Obsoletes:      bmpx-plugin-flow
68 Obsoletes:      bmpx-plugins-base
69 Obsoletes:      bmpx-plugin-transport
70 Obsoletes:      bmpx-remote
71 Obsoletes:      bmpx-remote-gtk
72 Obsoletes:      bmpx-static
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _firefoxdir     %{_libdir}/mozilla-firefox
76 %define         _chromedir      %{_firefoxdir}/chrome
77
78 %description
79 BMPx is the follow-up of the BMP project with a codebase rewritten
80 from scratch and aims to maintain a stable audio player foundation,
81 and to provide a player with a consistent and easy to understand usage
82 experience.
83
84 %description -l pl.UTF-8
85 BMPx jest następcą projektu BMP z przepisanym od zera kodem i skupia
86 się na utrzymaniu stabilnej podstawy odtwarzacza dźwięku, aby
87 udostępnić odtwarzacz ze spójną i łatwą do zrozumienia obsługą.
88
89 %package devel
90 Summary:        Header files for BMPx media player
91 Summary(pl.UTF-8):      Pliki nagłówkowe odtwarzacza multimedialnego BMPx
92 Group:          X11/Development/Libraries
93 Requires:       dbus-glib-devel >= 0.62
94 Obsoletes:      libchroma-devel
95 Obsoletes:      libhrel-devel
96
97 %description devel
98 Header files required for compiling BMPx media player plugins.
99
100 %description devel -l pl.UTF-8
101 Pliki nagłówkowe potrzebne do kompilowania wtyczek odtwarzacza
102 multimedialnego BMPx.
103
104 %package -n mozilla-firefox-plugin-bmpx
105 Summary:        BMPx plugin for Mozilla Firefox
106 Summary(pl.UTF-8):      Wtyczka BMPx dla Mozilli Firefox
107 Group:          X11/Applications
108 Requires:       %{name} = %{version}-%{release}
109 Requires:       mozilla-firefox
110
111 %description -n mozilla-firefox-plugin-bmpx
112 This plugin registers the lastfm:// protocol to BMPx.
113
114 %description -n mozilla-firefox-plugin-bmpx -l pl.UTF-8
115 Ta wtyczka rejestruje protokół lastfm:// do BMPx.
116
117 %prep
118 %setup -q
119 %patch0 -p1
120
121 %build
122 %{__libtoolize}
123 %{__aclocal} -I m4
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure \
128         --enable-hal \
129         --enable-gamin \
130         --enable-libnotify \
131         --enable-mp4v2 \
132         %{?with_ofa:--enable-ofa} \
133         %{?with_sid:--enable-sid} \
134         --enable-shared \
135         %{?with_gaim:--enable-gaim} \
136         --with-dbus-services-dir=%{_datadir}/dbus-1/services
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT%{_chromedir}
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT \
145         m4datadir=%{_aclocaldir}
146
147 unzip xpi/bmp.xpi -d $RPM_BUILD_ROOT%{_firefoxdir}
148 sed -e 's@chrome/bmp\.jar@bmp\.jar@' $RPM_BUILD_ROOT%{_firefoxdir}/chrome.manifest \
149         > $RPM_BUILD_ROOT%{_chromedir}/bmp.manifest
150
151 rm -f $RPM_BUILD_ROOT%{_firefoxdir}/{install.rdf,chrome.manifest}
152 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
153 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/{taglib,vfs/container,vfs/transport}/*.la
154 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/th_TH
155
156 %find_lang %{name}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post
162 %update_desktop_database_post
163 %update_mime_database
164 %update_icon_cache hicolor
165
166 %banner %{name} -e << EOF
167 Remember to install appropriate GStreamer plugins for files
168 you want to play:
169 - gstreamer-cdparanoia (for Audio-CD)
170 - gstreamer-flac (for FLAC)
171 - gstreamer-mad (for MP3s)
172 - gstreamer-vorbis (for Ogg Vorbis)
173 EOF
174
175 %postun
176 %update_desktop_database_postun
177 %update_mime_database
178 %update_icon_cache hicolor
179
180 %files -f %{name}.lang
181 %defattr(644,root,root,755)
182 %doc AUTHORS ChangeLog NEWS README
183 %attr(755,root,root) %{_bindir}/beep-media-player-2
184 %attr(755,root,root) %{_bindir}/bmp-enqueue-files-2.0 
185 %attr(755,root,root) %{_bindir}/bmp-enqueue-uris-2.0
186 %attr(755,root,root) %{_bindir}/bmp-play-files-2.0
187 %attr(755,root,root) %{_bindir}/bmp-play-lastfm-2.0
188 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-bin
189 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-sentinel
190
191 %dir %{_libdir}/bmpx
192 %dir %{_libdir}/bmpx/plugins
193 %dir %{_libdir}/bmpx/plugins/taglib
194 %dir %{_libdir}/bmpx/plugins/vfs
195 %dir %{_libdir}/bmpx/plugins/vfs/container
196 %dir %{_libdir}/bmpx/plugins/vfs/transport
197 %attr(755,root,root) %{_libdir}/bmpx/plugins/taglib/*.so*
198 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/container/*.so*
199 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/transport/*.so*
200
201 %{_datadir}/bmpx
202 %{_datadir}/dbus-1/services/*.service
203 %{_mandir}/man*/*
204 %{_desktopdir}/*.desktop
205 %{_iconsdir}/hicolor/*/*/*.png
206
207 %files devel
208 %defattr(644,root,root,755)
209 %{_includedir}/bmp-2.0
210 %{_pkgconfigdir}/*.pc
211
212 %files -n mozilla-firefox-plugin-bmpx
213 %defattr(644,root,root,755)
214 %{_chromedir}/bmp.jar
215 %{_chromedir}/bmp.manifest
This page took 0.0508 seconds and 4 git commands to generate.