]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- desktop patch added, unifications, banner support, require some audio
[packages/bmpx.git] / bmpx.spec
1 #
2 # Conditional build:
3 %bcond_with     gstreamer       # build with GStreamer support (instead of XINE)
4 #
5 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
6 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+
7 Name:           bmpx
8 Version:        0.12.1
9 Release:        1
10 License:        GPL v2
11 Group:          X11/Applications/Sound
12 Source0:        http://download.berlios.de/bmpx/%{name}-%{version}.tar.gz
13 # Source0-md5:  40965fe0e9707a49a773c91eff777fb2
14 Source1:        mp3license
15 Patch0:         %{name}-embedded-images.patch
16 Patch1:         %{name}-desktop.patch
17 URL:            http://bmpx.berlios.de/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  cairo-devel >= 1.0.0
21 BuildRequires:  curl-devel
22 BuildRequires:  dbus-glib-devel
23 BuildRequires:  esound-devel >= 0.2.8
24 BuildRequires:  fam-devel
25 BuildRequires:  gtk+2-devel >= 2:2.8.0
26 BuildRequires:  libglade2-devel >= 1:2.5.1
27 BuildRequires:  libvorbis-devel >= 1:1.0
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  taglib-devel
30 %if %{with gstreamer}
31 BuildRequires:  gstreamer-devel >= 0.9.1
32 %else
33 BuildRequires:  xine-lib-devel
34 %endif
35 Requires:       %{name}-plugin-flow = %{epoch}:%{version}-%{release}
36 Requires:       %{name}-plugin-container = %{epoch}:%{version}-%{release}
37 Requires:       %{name}-plugin-transport = %{epoch}:%{version}-%{release}
38 %if %{with gstreamer}
39 Requires:       gstreamer-audio-effects
40 Requires:       gstreamer-audio-formats
41 Requires:       gstreamer-audiosink
42 %else
43 Requires:       xine-plugin-audio
44 %endif
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 BMPx is the follow-up of the BMP project with a codebase rewritten
49 from scratch and aims to maintain a stable audio player foundation,
50 and to provide a player with a consistent and easy to understand usage
51 experience.
52
53 %description -l pl
54 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
55 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
56 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
57
58 %package devel
59 Summary:        Header files for BMPx media player
60 Summary(pl):    Pliki nag³ówkowe odtwarzacza multimedialnego BMPx
61 Group:          X11/Development/Libraries
62 # doesn't require base
63
64 %description devel
65 Header files required for compiling BMPx media player plugins.
66
67 %description devel -l pl
68 Pliki nag³ówkowe potrzebne do kompilowania wtyczek odtwarzacza
69 multimedialnego BMPx.
70
71 %package plugin-container
72 Summary:        Container plugin for BMPx
73 Summary(pl):    Wtyczka Container dla BMPx
74 Group:          X11/Applications/Sound
75 Requires:       %{name} = %{epoch}:%{version}-%{release}
76
77 %description plugin-container
78 Plugin providing support for folders, m3u & pls playlist files, etc.
79
80 %description plugin-container -l pl
81 Wtyczka dodaj±ca obs³ugê folderów, playlist w formacie m3u i pls, itp.
82
83 %package plugin-flow
84 Summary:        Flow plugin for BMPx
85 Summary(pl):    Wtyczka Flow dla BMPx
86 Group:          X11/Applications/Sound
87 Requires:       %{name} = %{epoch}:%{version}-%{release}
88
89 %description plugin-flow
90 Flow plugin for BMPx.
91
92 %description plugin-flow -l pl
93 Wtyczka Flow dla BMPx.
94
95 %package plugin-transport
96 Summary:        Transport plugin for BMPx
97 Summary(pl):    Wtyczka Transport dla BMPx
98 Group:          X11/Applications/Sound
99 Requires:       %{name} = %{epoch}:%{version}-%{release}
100
101 %description plugin-transport
102 Transport plugin for BMPx.
103
104 %description plugin-transport -l pl
105 Wtyczka Transport dla BMPx.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110 %patch1 -p1
111
112 %build
113 rm -rf autom4te.cache
114 %{__aclocal} -I m4
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118 %configure \
119 %if %{with gstreamer}
120         --enable-gst \
121         --disable-xine
122 %else
123         --enable-xine \
124 %endif
125         --enable-shared \
126         --disable-static
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT \
134         m4datadir=%{_aclocaldir}
135
136 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
137
138 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
139 mv -f $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/bmpx.png \
140         $RPM_BUILD_ROOT%{_pixmapsdir}
141
142 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/*/*.la
143
144 %find_lang %{name}
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 /sbin/ldconfig
151 umask 022
152 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
153
154 %if %{with gstreamer}
155 %banner %{name} -e << EOF
156 Remember to install appropriate GStreamer plugins for files
157 you want to play:
158 - gstreamer-flac (for FLAC)
159 - gstreamer-mad (for MP3s)
160 - gstreamer-vorbis (for Ogg Vorbis)
161 EOF
162 %else
163 %banner %{name} -e << EOF
164 Remember to install appropriate xine-decode plugins for files
165 you want to play:
166 - xine-decode-flac (for FLAC)
167 - xine-decode-ogg (for Ogg Vorbis)
168 EOF
169 %endif
170
171 %postun
172 /sbin/ldconfig
173 if [ $1 = 0 ]; then
174     umask 022
175     [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
176 fi
177
178 %files -f %{name}.lang
179 %defattr(644,root,root,755)
180 %doc AUTHORS ChangeLog NEWS README
181 %attr(755,root,root) %{_bindir}/bmp*
182 %attr(755,root,root) %{_libdir}/libskinned.so.*.*.*
183 %dir %{_libdir}/bmpx
184 %dir %{_libdir}/bmpx/plugins
185 %{_mandir}/man*/*
186 %{_desktopdir}/*
187 %{_datadir}/bmpx
188 %{_datadir}/bmp-remote
189 %{_pixmapsdir}/*
190
191 %files devel
192 %defattr(644,root,root,755)
193 %{_includedir}/bmpx
194
195 %files plugin-container
196 %defattr(644,root,root,755)
197 %dir %{_libdir}/bmpx/plugins/container
198 %attr(755,root,root) %{_libdir}/bmpx/plugins/container/*.so*
199
200 %files plugin-flow
201 %defattr(644,root,root,755)
202 %dir %{_libdir}/bmpx/plugins/flow
203 %attr(755,root,root) %{_libdir}/bmpx/plugins/flow/*.so*
204
205 %files plugin-transport
206 %defattr(644,root,root,755)
207 %dir %{_libdir}/bmpx/plugins/transport
208 %attr(755,root,root) %{_libdir}/bmpx/plugins/transport/*.so*
This page took 0.150008 seconds and 4 git commands to generate.