]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- unified bcond header
[packages/bmpx.git] / bmpx.spec
1
2 # TODO: add subpackage with bmpx.xpi (lastm:// URIs support in firefox)
3 #
4 # Conditional build:
5 %bcond_without  gaim    # build without D-BUS gaim support
6 %bcond_without  sid     # build without sid support
7 %bcond_without  ofa     # build without MusicIP support
8 #
9 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
10 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+
11 Name:           bmpx
12 Version:        0.32.0
13 Release:        1.1
14 License:        GPL v2
15 Group:          X11/Applications/Sound
16 Source0:        http://files.beep-media-player.org/releases/0.30/%{name}-%{version}.tar.bz2
17 # Source0-md5:  52c5694f2702c0fc1c9b6fdba603ba7c
18 Source1:        mp3license
19 Patch0:         %{name}-desktop.patch
20 URL:            http://beep-media-player.org/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  bison
24 BuildRequires:  boost-bind-devel
25 BuildRequires:  boost-call_traits-devel
26 BuildRequires:  boost-devel
27 BuildRequires:  boost-filesystem-devel
28 BuildRequires:  curl-devel
29 BuildRequires:  dbus-glib-devel >= 0.62
30 BuildRequires:  esound-devel >= 0.2.8
31 BuildRequires:  fam-devel
32 BuildRequires:  flex
33 %{?with_gaim:BuildRequires:     gaim-devel}
34 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.9
35 BuildRequires:  gtkmm-devel >= 2.9.8
36 BuildRequires:  hal-devel >= 0.5.7
37 BuildRequires:  libglademm-devel >= 2.6.2
38 BuildRequires:  libnotify-devel >= 0.4.2
39 BuildRequires:  libmusicbrainz-devel >= 2.1.1
40 %{?with_ofa:BuildRequires:      libofa-devel >= 0.9.3}
41 %{?with_sid:BuildRequires:      libsidplay-devel}
42 BuildRequires:  libtool
43 BuildRequires:  libvorbis-devel >= 1:1.0
44 BuildRequires:  libxml2-devel >= 1:2.6.26
45 BuildRequires:  mpeg4ip-devel
46 BuildRequires:  neon-devel >= 0.25.5
47 BuildRequires:  rpmbuild(macros) >= 1.311
48 BuildRequires:  rpm-pythonprov
49 BuildRequires:  startup-notification-devel >= 0.8
50 BuildRequires:  taglib-devel >= 1.4
51 Requires(post,postun):  desktop-file-utils
52 Requires(post,postun):  gtk+2 >= 2:2.10.0
53 Requires(post,postun):  hicolor-icon-theme
54 Requires(post,postun):  shared-mime-info
55 Requires:       gstreamer-audio-effects-base >= 0.10.9
56 Requires:       gstreamer-audio-formats >= 0.10.3
57 Requires:       gstreamer-audiosink
58 Obsoletes:      bmpx-curses
59 Obsoletes:      bmpx-libs
60 Obsoletes:      bmpx-plugin-container
61 Obsoletes:      bmpx-plugin-flow
62 Obsoletes:      bmpx-plugins-base
63 Obsoletes:      bmpx-plugin-transport
64 Obsoletes:      bmpx-remote
65 Obsoletes:      bmpx-remote-gtk
66 Obsoletes:      bmpx-static
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 BMPx is the follow-up of the BMP project with a codebase rewritten
71 from scratch and aims to maintain a stable audio player foundation,
72 and to provide a player with a consistent and easy to understand usage
73 experience.
74
75 %description -l pl
76 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
77 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
78 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
79
80 %package devel
81 Summary:        Header files for BMPx media player
82 Summary(pl):    Pliki nag³ówkowe odtwarzacza multimedialnego BMPx
83 Group:          X11/Development/Libraries
84 Requires:       dbus-glib-devel >= 0.62
85 Obsoletes:      libchroma-devel
86 Obsoletes:      libhrel-devel
87
88 %description devel
89 Header files required for compiling BMPx media player plugins.
90
91 %description devel -l pl
92 Pliki nag³ówkowe potrzebne do kompilowania wtyczek odtwarzacza
93 multimedialnego BMPx.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 %{__libtoolize}
101 %{__aclocal} -I m4
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         --enable-hal \
107         --enable-gamin \
108         --enable-libnotify \
109         --enable-mp4v2 \
110         %{?with_ofa:--enable-ofa} \
111         %{?with_sid:--enable-sid} \
112         --enable-shared \
113         --enable-static \
114         %{?with_gaim:--enable-gaim} \
115         --with-dbus-services-dir=%{_datadir}/dbus-1/services
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT \
123         m4datadir=%{_aclocaldir}
124
125 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
126 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/{flow,vfs/container,vfs/transport}/*.{a,la}
127 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/th_TH
128
129 %find_lang %{name}
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post
135 %update_desktop_database_post
136 %update_mime_database
137 %update_icon_cache hicolor
138
139 %banner %{name} -e << EOF
140 Remember to install appropriate GStreamer plugins for files
141 you want to play:
142 - gstreamer-cdparanoia (for Audio-CD)
143 - gstreamer-flac (for FLAC)
144 - gstreamer-mad (for MP3s)
145 - gstreamer-vorbis (for Ogg Vorbis)
146 EOF
147
148 %postun
149 %update_desktop_database_postun
150 %update_mime_database
151 %update_icon_cache hicolor
152
153 %files -f %{name}.lang
154 %defattr(644,root,root,755)
155 %doc AUTHORS ChangeLog NEWS README
156 %attr(755,root,root) %{_bindir}/beep-media-player-2
157 %attr(755,root,root) %{_bindir}/bmp-enqueue-files-2.0 
158 %attr(755,root,root) %{_bindir}/bmp-enqueue-uris-2.0
159 %attr(755,root,root) %{_bindir}/bmp-play-files-2.0
160 %attr(755,root,root) %{_bindir}/bmp-play-lastfm-2.0
161 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-bin
162
163 %dir %{_libdir}/bmpx
164 %dir %{_libdir}/bmpx/plugins
165 #%dir %{_libdir}/bmpx/plugins/flow
166 %dir %{_libdir}/bmpx/plugins/vfs
167 %dir %{_libdir}/bmpx/plugins/vfs/container
168 %dir %{_libdir}/bmpx/plugins/vfs/transport
169 #%attr(755,root,root) %{_libdir}/bmpx/plugins/flow/*.so*
170 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/container/*.so*
171 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/transport/*.so*
172
173 %{_datadir}/bmpx
174 %{_datadir}/dbus-1/services/*.service
175 %{_datadir}/mime/packages/*.xml
176 %{_mandir}/man*/*
177 %{_desktopdir}/*
178 %{_iconsdir}/hicolor/*/*/*.png
179
180 %files devel
181 %defattr(644,root,root,755)
182 %{_includedir}/bmp-2.0
183 %{_pkgconfigdir}/*.pc
This page took 0.046422 seconds and 4 git commands to generate.