]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- use gstreamer 0.10 package naming style
[packages/bmpx.git] / bmpx.spec
1 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
2 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+
3 Name:           bmpx
4 Version:        0.14
5 Release:        0.1
6 License:        GPL v2
7 Group:          X11/Applications/Sound
8 Source0:        http://dl.sourceforge.net/beepmp/%{name}-%{version}.tar.bz2
9 # Source0-md5:  d049ec4c59ec5a0596eab32b1a70b2a9
10 Source1:        mp3license
11 Patch0:         %{name}-desktop.patch
12 URL:            http://beep-media-player.org/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  curl-devel
16 BuildRequires:  dbus-glib-devel
17 BuildRequires:  esound-devel >= 0.2.8
18 BuildRequires:  fam-devel
19 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.4
20 BuildRequires:  gtk+2-devel >= 2:2.8.0
21 BuildRequires:  libglade2-devel >= 1:2.5.1
22 BuildRequires:  libmusicbrainz-devel >= 2.1.1
23 BuildRequires:  libtool
24 BuildRequires:  libvorbis-devel >= 1:1.0
25 BuildRequires:  libxml2-devel >= 2.6.1
26 BuildRequires:  neon-devel >= 0.25.5
27 BuildRequires:  rpmbuild(macros) >= 1.194
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  startup-notification-devel >= 0.8
30 BuildRequires:  taglib-devel >= 1.4
31 Requires:       %{name}-libs = %{version}-%{release}
32 Requires:       %{name}-plugins-base = %{version}-%{release}
33 Requires:       gstreamer-audio-effects-base
34 Requires:       gstreamer-audio-formats
35 Requires:       gstreamer-audiosink
36 Obsoletes:      bmpx-curses
37 Obsoletes:      bmpx-remote
38 Obsoletes:      bmpx-remote-gtk
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 BMPx is the follow-up of the BMP project with a codebase rewritten
43 from scratch and aims to maintain a stable audio player foundation,
44 and to provide a player with a consistent and easy to understand usage
45 experience.
46
47 %description -l pl
48 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
49 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
50 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
51
52 %package libs
53 Summary:        BMPx player libraries
54 Summary(pl):    Biblioteki odtwarzacza BMPx
55 Group:          X11/Libraries
56 Obsoletes:      libchroma
57 Obsoletes:      libhrel
58
59 %description libs
60 BMPx player libraries.
61
62 %description libs -l pl
63 Biblioteki odtwarzacza BMPx.
64
65 %package devel
66 Summary:        Header files for BMPx media player
67 Summary(pl):    Pliki nag³ówkowe odtwarzacza multimedialnego BMPx
68 Group:          X11/Development/Libraries
69 Requires:       %{name}-libs = %{version}-%{release}
70 Requires:       gtk+2-devel >= 2:2.8.0
71 Obsoletes:      libchroma-devel
72 Obsoletes:      libhrel-devel
73
74 %description devel
75 Header files required for compiling BMPx media player plugins.
76
77 %description devel -l pl
78 Pliki nag³ówkowe potrzebne do kompilowania wtyczek odtwarzacza
79 multimedialnego BMPx.
80
81 %package static
82 Summary:        Static BMPx library
83 Summary(pl):    Statyczna biblioteka BMPx
84 Group:          X11/Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86 Obsoletes:      libchroma-static
87 Obsoletes:      libhrel-static
88
89 %description static
90 Static BMPx library.
91
92 %description static -l pl
93 Statyczna biblioteka BMPx.
94
95 %package plugins-base
96 Summary:        Base plugins for BMPx
97 Summary(pl):    Podstawowe wtyczki dla BMPx
98 Group:          X11/Applications/Sound
99 Requires:       %{name} = %{version}-%{release}
100 Obsoletes:      bmpx-plugin-container
101 Obsoletes:      bmpx-plugin-flow
102 Obsoletes:      bmpx-plugin-transport
103
104 %description plugins-base
105 Base plugins for BMPx.
106
107 %description plugins-base -l pl
108 Podstawowe wtyczki dla BMPx.
109
110 %prep
111 %setup -q
112 %patch0 -p1
113
114 %build
115 %{__libtoolize}
116 %{__aclocal} -I m4
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120
121 %configure \
122         --enable-shared \
123         --enable-static \
124         --with-dbus-services-dir=%{_datadir}/dbus-1/services
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT \
132         m4datadir=%{_aclocaldir}
133
134 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
135
136 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
137 mv -f $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/bmpx.png \
138         $RPM_BUILD_ROOT%{_pixmapsdir}
139
140 rm -f $RPM_BUILD_ROOT%{_libdir}/bmp-2.0/plugins/*/*.{a,la}
141
142 %find_lang %{name}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 umask 022
149 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
150
151 %banner %{name} -e << EOF
152 Remember to install appropriate GStreamer plugins for files
153 you want to play:
154 - gstreamer-flac (for FLAC)
155 - gstreamer-mad (for MP3s)
156 - gstreamer-vorbis (for Ogg Vorbis)
157 EOF
158
159 %postun
160 if [ $1 = 0 ]; then
161     umask 022
162     [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
163 fi
164
165 %post   libs -p /sbin/ldconfig
166 %postun libs -p /sbin/ldconfig
167
168 %files -f %{name}.lang
169 %defattr(644,root,root,755)
170 %doc AUTHORS ChangeLog NEWS README
171 %attr(755,root,root) %{_bindir}/beep-media-player-2
172 %attr(755,root,root) %{_bindir}/bmp-enqueue-files-2.0 
173 %attr(755,root,root) %{_bindir}/bmp-enqueue-uris-2.0
174 %attr(755,root,root) %{_bindir}/bmp-play-files-2.0
175 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-bin
176 %dir %{_libdir}/bmp-2.0
177 %dir %{_libdir}/bmp-2.0/plugins
178 %{_datadir}/bmpx
179 %{_datadir}/dbus-1/services/*.service
180 %{_mandir}/man*/*
181 %{_desktopdir}/*
182 %{_pixmapsdir}/*
183
184 %files libs
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
187
188 %files devel
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/lib*.so
191 %{_libdir}/lib*.la
192 %{_includedir}/bmp-2.0
193 %{_includedir}/libchroma
194 %{_includedir}/libhrel
195 %{_pkgconfigdir}/*.pc
196
197 %files static
198 %defattr(644,root,root,755)
199 %{_libdir}/lib*.a
200
201 %files plugins-base
202 %defattr(644,root,root,755)
203 %dir %{_libdir}/bmp-2.0/plugins/container
204 %dir %{_libdir}/bmp-2.0/plugins/flow
205 %dir %{_libdir}/bmp-2.0/plugins/transport
206 %attr(755,root,root) %{_libdir}/bmp-2.0/plugins/container/*.so*
207 %attr(755,root,root) %{_libdir}/bmp-2.0/plugins/flow/*.so*
208 %attr(755,root,root) %{_libdir}/bmp-2.0/plugins/transport/*.so*
This page took 0.071189 seconds and 4 git commands to generate.