]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- up to 0.12.1
[packages/bmpx.git] / bmpx.spec
1 #
2 # Conditional build:
3 %bcond_with     gstreamer       # build with GStreamer support (instead of XINE)
4
5 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+2
6 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+2
7 Name:           bmpx
8 Version:        0.12.1
9 Release:        1
10 License:        GPL v2
11 Group:          X11/Applications/Sound
12 Source0:        http://download.berlios.de/bmpx/%{name}-%{version}.tar.gz
13 # Source0-md5:  40965fe0e9707a49a773c91eff777fb2
14 Source1:        mp3license
15 Patch0:         %{name}-embedded-images.patch
16 URL:            http://bmpx.berlios.de/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  cairo-devel >= 1.0.0
20 BuildRequires:  curl-devel
21 BuildRequires:  dbus-glib-devel
22 BuildRequires:  esound-devel >= 0.2.8
23 BuildRequires:  fam-devel
24 BuildRequires:  gtk+2-devel >= 2:2.8.0
25 BuildRequires:  libglade2-devel >= 1:2.5.1
26 BuildRequires:  libvorbis-devel >= 1:1.0
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  taglib-devel
29 %if %{with gstreamer}
30 BuildRequires:  gstreamer-devel >= 0.9.1
31 %else
32 BuildRequires:  xine-lib-devel
33 %endif
34 Requires:       %{name}-plugin-flow = %{epoch}:%{version}-%{release}
35 Requires:       %{name}-plugin-container = %{epoch}:%{version}-%{release}
36 Requires:       %{name}-plugin-transport = %{epoch}:%{version}-%{release}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 BMPx is the follow-up of the BMP project with a codebase rewritten
41 from scratch and aims to maintain a stable audio player foundation,
42 and to provide a player with a consistent and easy to understand usage
43 experience.
44
45 %description -l pl
46 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
47 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
48 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
49
50 %package devel
51 Summary:        Header files for BMPx media player
52 Summary(pl):    Pliki nag³ówkowe odtwarzacza multimedialnego BMPx
53 Group:          X11/Development/Libraries
54 #Requires:      %{name} = %{epoch}:%{version}-%{release}
55
56 %description devel
57 Header files required for compiling BMPx media player plugins.
58
59 %description devel -l pl
60 Pliki nag³ówkowe potrzebne do kompilowania wtyczek odtwarzacza
61 multimedialnego BMPx.
62
63 %package plugin-container
64 Summary:        Container plugin for BMPx
65 Summary(pl):    Wtyczka Container dla BMPx
66 Group:          X11/Applications/Sound
67 Requires:       %{name} = %{epoch}:%{version}-%{release}
68
69 %description plugin-container
70 Plugin providing support for folders, m3u & pls playlist files, etc.
71
72 %description plugin-container -l pl
73 Wtyczka dodaj±ca obs³ugê folderów, playlist w formacie m3u i pls, itp.
74
75 %package plugin-flow
76 Summary:        Flow plugin for BMPx
77 Summary(pl):    Wtyczka Flow dla BMPx
78 Group:          X11/Applications/Sound
79 Requires:       %{name} = %{epoch}:%{version}-%{release}
80
81 %description plugin-flow
82 Flow plugin for BMPx.
83
84 %description plugin-flow -l pl
85 Wtyczka Flow dla BMPx.
86
87 %package plugin-transport
88 Summary:        Transport plugin for BMPx
89 Summary(pl):    Wtyczka Transport dla BMPx
90 Group:          X11/Applications/Sound
91 Requires:       %{name} = %{epoch}:%{version}-%{release}
92
93 %description plugin-transport
94 Transport plugin for BMPx.
95
96 %description plugin-transport -l pl
97 Wtyczka Transport dla BMPx.
98
99 %prep
100 %setup -q -n %{name}-%{version}
101 %patch0 -p1
102
103 %build
104 rm -rf autom4te.cache
105 %{__aclocal} -I m4
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110 %if %{with gstreamer}
111         --enable-gst \
112         --disable-xine
113 %else
114         --enable-xine \
115 %endif
116         --enable-shared \
117         --disable-static
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT \
125         m4datadir=%{_aclocaldir}
126
127 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
128
129 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
130 mv -f $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/bmpx.png \
131         $RPM_BUILD_ROOT%{_pixmapsdir}
132
133 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/*/*.la
134
135 %find_lang %{name}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post
141 umask 022
142 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
143
144 /sbin/ldconfig
145
146 %postun
147 umask 022
148 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
149
150 /sbin/ldconfig
151
152 %files -f %{name}.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog NEWS README
155 %attr(755,root,root) %{_bindir}/bmp*
156 %attr(755,root,root) %{_libdir}/libskinned.so.*.*.*
157 %dir %{_libdir}/bmpx
158 %dir %{_libdir}/bmpx/plugins
159 %{_mandir}/man*/*
160 %{_desktopdir}/*
161 %{_datadir}/bmpx
162 %{_datadir}/bmp-remote
163 %{_pixmapsdir}/*
164
165 %files devel
166 %defattr(644,root,root,755)
167 %{_includedir}/bmpx
168
169 %files plugin-container
170 %defattr(644,root,root,755)
171 %dir %{_libdir}/bmpx/plugins/container
172 %attr(755,root,root) %{_libdir}/bmpx/plugins/container/*.so*
173
174 %files plugin-flow
175 %defattr(644,root,root,755)
176 %dir %{_libdir}/bmpx/plugins/flow
177 %attr(755,root,root) %{_libdir}/bmpx/plugins/flow/*.so*
178
179 %files plugin-transport
180 %defattr(644,root,root,755)
181 %dir %{_libdir}/bmpx/plugins/transport
182 %attr(755,root,root) %{_libdir}/bmpx/plugins/transport/*.so*
This page took 0.044466 seconds and 4 git commands to generate.