]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- enabled some extensions
[packages/bmpx.git] / bmpx.spec
1
2 # TODO: add subpackage with bmpx.xpi (lastm:// URIs support in firefox)
3
4 %bcond_without  gaim    # build without D-BUS gaim support
5 %bcond_without  sid     # build without sid support
6 %bcond_without  ofa     # build without MusicIP support
7
8 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
9 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+
10 Name:           bmpx
11 Version:        0.32.0
12 Release:        1.1
13 License:        GPL v2
14 Group:          X11/Applications/Sound
15 Source0:        http://files.beep-media-player.org/releases/0.30/%{name}-%{version}.tar.bz2
16 # Source0-md5:  52c5694f2702c0fc1c9b6fdba603ba7c
17 Source1:        mp3license
18 Patch0:         %{name}-desktop.patch
19 URL:            http://beep-media-player.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  bison
23 BuildRequires:  boost-bind-devel
24 BuildRequires:  boost-call_traits-devel
25 BuildRequires:  boost-devel
26 BuildRequires:  boost-filesystem-devel
27 BuildRequires:  curl-devel
28 BuildRequires:  dbus-glib-devel >= 0.62
29 BuildRequires:  esound-devel >= 0.2.8
30 BuildRequires:  fam-devel
31 BuildRequires:  flex
32 %{?with_gaim:BuildRequires:     gaim-devel}
33 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.9
34 BuildRequires:  gtkmm-devel >= 2.9.8
35 BuildRequires:  hal-devel >= 0.5.7
36 BuildRequires:  libglademm-devel >= 2.6.2
37 BuildRequires:  libnotify-devel >= 0.4.2
38 BuildRequires:  libmusicbrainz-devel >= 2.1.1
39 %{?with_ofa:BuildRequires:      libofa-devel >= 0.9.3}
40 %{?with_sid:BuildRequires:      libsidplay-devel}
41 BuildRequires:  libtool
42 BuildRequires:  libvorbis-devel >= 1:1.0
43 BuildRequires:  libxml2-devel >= 1:2.6.26
44 BuildRequires:  mpeg4ip-devel
45 BuildRequires:  neon-devel >= 0.25.5
46 BuildRequires:  rpmbuild(macros) >= 1.311
47 BuildRequires:  rpm-pythonprov
48 BuildRequires:  startup-notification-devel >= 0.8
49 BuildRequires:  taglib-devel >= 1.4
50 Requires(post,postun):  desktop-file-utils
51 Requires(post,postun):  gtk+2 >= 2:2.10.0
52 Requires(post,postun):  hicolor-icon-theme
53 Requires(post,postun):  shared-mime-info
54 Requires:       gstreamer-audio-effects-base >= 0.10.9
55 Requires:       gstreamer-audio-formats >= 0.10.3
56 Requires:       gstreamer-audiosink
57 Obsoletes:      bmpx-curses
58 Obsoletes:      bmpx-libs
59 Obsoletes:      bmpx-plugin-container
60 Obsoletes:      bmpx-plugin-flow
61 Obsoletes:      bmpx-plugins-base
62 Obsoletes:      bmpx-plugin-transport
63 Obsoletes:      bmpx-remote
64 Obsoletes:      bmpx-remote-gtk
65 Obsoletes:      bmpx-static
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 BMPx is the follow-up of the BMP project with a codebase rewritten
70 from scratch and aims to maintain a stable audio player foundation,
71 and to provide a player with a consistent and easy to understand usage
72 experience.
73
74 %description -l pl
75 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
76 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
77 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
78
79 %package devel
80 Summary:        Header files for BMPx media player
81 Summary(pl):    Pliki nag³ówkowe odtwarzacza multimedialnego BMPx
82 Group:          X11/Development/Libraries
83 Requires:       dbus-glib-devel >= 0.62
84 Obsoletes:      libchroma-devel
85 Obsoletes:      libhrel-devel
86
87 %description devel
88 Header files required for compiling BMPx media player plugins.
89
90 %description devel -l pl
91 Pliki nag³ówkowe potrzebne do kompilowania wtyczek odtwarzacza
92 multimedialnego BMPx.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97
98 %build
99 %{__libtoolize}
100 %{__aclocal} -I m4
101 %{__autoconf}
102 %{__autoheader}
103 %{__automake}
104 %configure \
105         --enable-hal \
106         --enable-gamin \
107         --enable-libnotify \
108         --enable-mp4v2 \
109         %{?with_ofa:--enable-ofa} \
110         %{?with_sid:--enable-sid} \
111         --enable-shared \
112         --enable-static \
113         %{?with_gaim:--enable-gaim} \
114         --with-dbus-services-dir=%{_datadir}/dbus-1/services
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT \
122         m4datadir=%{_aclocaldir}
123
124 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
125 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/{flow,vfs/container,vfs/transport}/*.{a,la}
126 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/th_TH
127
128 %find_lang %{name}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post
134 %update_desktop_database_post
135 %update_mime_database
136 %update_icon_cache hicolor
137
138 %banner %{name} -e << EOF
139 Remember to install appropriate GStreamer plugins for files
140 you want to play:
141 - gstreamer-cdparanoia (for Audio-CD)
142 - gstreamer-flac (for FLAC)
143 - gstreamer-mad (for MP3s)
144 - gstreamer-vorbis (for Ogg Vorbis)
145 EOF
146
147 %postun
148 %update_desktop_database_postun
149 %update_mime_database
150 %update_icon_cache hicolor
151
152 %files -f %{name}.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog NEWS README
155 %attr(755,root,root) %{_bindir}/beep-media-player-2
156 %attr(755,root,root) %{_bindir}/bmp-enqueue-files-2.0 
157 %attr(755,root,root) %{_bindir}/bmp-enqueue-uris-2.0
158 %attr(755,root,root) %{_bindir}/bmp-play-files-2.0
159 %attr(755,root,root) %{_bindir}/bmp-play-lastfm-2.0
160 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-bin
161
162 %dir %{_libdir}/bmpx
163 %dir %{_libdir}/bmpx/plugins
164 #%dir %{_libdir}/bmpx/plugins/flow
165 %dir %{_libdir}/bmpx/plugins/vfs
166 %dir %{_libdir}/bmpx/plugins/vfs/container
167 %dir %{_libdir}/bmpx/plugins/vfs/transport
168 #%attr(755,root,root) %{_libdir}/bmpx/plugins/flow/*.so*
169 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/container/*.so*
170 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/transport/*.so*
171
172 %{_datadir}/bmpx
173 %{_datadir}/dbus-1/services/*.service
174 %{_datadir}/mime/packages/*.xml
175 %{_mandir}/man*/*
176 %{_desktopdir}/*
177 %{_iconsdir}/hicolor/*/*/*.png
178
179 %files devel
180 %defattr(644,root,root,755)
181 %{_includedir}/bmp-2.0
182 %{_pkgconfigdir}/*.pc
This page took 0.05072 seconds and 4 git commands to generate.