]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- updated BR
[packages/bmpx.git] / bmpx.spec
1 # TODO: use browser-plugins if plugin works with something else than firefox (e.g. seamonkey)
2 #
3 # Conditional build:
4 %bcond_without  gaim    # build without D-BUS gaim support
5 %bcond_without  sid     # build without sid support
6 %bcond_without  ofa     # build without MusicIP support
7 #
8 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
9 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+
10 Name:           bmpx
11 Version:        0.36.0
12 Release:        0.1
13 License:        GPL v2
14 Group:          X11/Applications/Sound
15 Source0:        http://files.beep-media-player.org/releases/0.36/%{name}-%{version}.tar.bz2
16 # Source0-md5:  4755c38432dd912dc8156ad217c2e5bf
17 Source1:        mp3license
18 Patch0:         %{name}-desktop.patch
19 URL:            http://beep-media-player.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  bison
23 BuildRequires:  boost-bind-devel
24 BuildRequires:  boost-call_traits-devel
25 BuildRequires:  boost-devel
26 BuildRequires:  boost-filesystem-devel
27 BuildRequires:  cdparanoia-III-devel
28 BuildRequires:  curl-devel
29 BuildRequires:  dbus-glib-devel >= 0.62
30 BuildRequires:  esound-devel >= 0.2.8
31 BuildRequires:  fam-devel
32 BuildRequires:  flex
33 %{?with_gaim:BuildRequires:     gaim-devel}
34 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.9
35 BuildRequires:  gtkmm-devel >= 2.9.8
36 BuildRequires:  hal-devel >= 0.5.7
37 BuildRequires:  libglademm-devel >= 2.6.2
38 BuildRequires:  libnotify-devel >= 0.4.2
39 BuildRequires:  libmusicbrainz-devel >= 2.1.1
40 %{?with_ofa:BuildRequires:      libofa-devel >= 0.9.3}
41 %{?with_sid:BuildRequires:      libsidplay-devel}
42 BuildRequires:  libtool
43 BuildRequires:  libvorbis-devel >= 1:1.0
44 BuildRequires:  libxml2-devel >= 1:2.6.26
45 BuildRequires:  mpeg4ip-devel
46 BuildRequires:  neon-devel >= 0.25.5
47 BuildRequires:  rpmbuild(macros) >= 1.311
48 BuildRequires:  rpm-pythonprov
49 BuildRequires:  startup-notification-devel >= 0.8
50 BuildRequires:  taglib-devel >= 1.4
51 BuildRequires:  unzip
52 Requires(post,postun):  desktop-file-utils
53 Requires(post,postun):  gtk+2 >= 2:2.10.0
54 Requires(post,postun):  hicolor-icon-theme
55 Requires(post,postun):  shared-mime-info
56 Requires:       gstreamer-audio-effects-base >= 0.10.9
57 Requires:       gstreamer-audio-formats >= 0.10.3
58 Requires:       gstreamer-audiosink
59 Obsoletes:      bmpx-curses
60 Obsoletes:      bmpx-libs
61 Obsoletes:      bmpx-plugin-container
62 Obsoletes:      bmpx-plugin-flow
63 Obsoletes:      bmpx-plugins-base
64 Obsoletes:      bmpx-plugin-transport
65 Obsoletes:      bmpx-remote
66 Obsoletes:      bmpx-remote-gtk
67 Obsoletes:      bmpx-static
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %define         _firefoxdir     %{_libdir}/mozilla-firefox
71 %define         _chromedir      %{_firefoxdir}/chrome
72
73 %description
74 BMPx is the follow-up of the BMP project with a codebase rewritten
75 from scratch and aims to maintain a stable audio player foundation,
76 and to provide a player with a consistent and easy to understand usage
77 experience.
78
79 %description -l pl
80 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
81 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
82 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
83
84 %package devel
85 Summary:        Header files for BMPx media player
86 Summary(pl):    Pliki nag³ówkowe odtwarzacza multimedialnego BMPx
87 Group:          X11/Development/Libraries
88 Requires:       dbus-glib-devel >= 0.62
89 Obsoletes:      libchroma-devel
90 Obsoletes:      libhrel-devel
91
92 %description devel
93 Header files required for compiling BMPx media player plugins.
94
95 %description devel -l pl
96 Pliki nag³ówkowe potrzebne do kompilowania wtyczek odtwarzacza
97 multimedialnego BMPx.
98
99 %package -n mozilla-firefox-plugin-bmpx
100 Summary:        BMPx plugin for Mozilla Firefox
101 Summary(pl):    Wtyczka BMPx dla Mozilli Firefox
102 Group:          X11/Applications
103 Requires:       %{name} = %{version}-%{release}
104 Requires:       mozilla-firefox
105
106 %description -n mozilla-firefox-plugin-bmpx
107 This plugin registers the lastfm:// protocol to BMPx.
108
109 %description -n mozilla-firefox-plugin-bmpx -l pl
110 Ta wtyczka rejestruje protokó³ lastfm:// do BMPx.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115
116 %build
117 %{__libtoolize}
118 %{__aclocal} -I m4
119 %{__autoconf}
120 %{__autoheader}
121 %{__automake}
122 %configure \
123         --enable-hal \
124         --enable-gamin \
125         --enable-libnotify \
126         --enable-mp4v2 \
127         %{?with_ofa:--enable-ofa} \
128         %{?with_sid:--enable-sid} \
129         --enable-shared \
130         --enable-static \
131         %{?with_gaim:--enable-gaim} \
132         --with-dbus-services-dir=%{_datadir}/dbus-1/services
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 install -d $RPM_BUILD_ROOT%{_chromedir}
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT \
141         m4datadir=%{_aclocaldir}
142
143 unzip xpi/bmp.xpi -d $RPM_BUILD_ROOT%{_firefoxdir}
144 sed -e 's@chrome/bmp\.jar@bmp\.jar@' $RPM_BUILD_ROOT%{_firefoxdir}/chrome.manifest \
145         > $RPM_BUILD_ROOT%{_chromedir}/bmp.manifest
146
147 rm -f $RPM_BUILD_ROOT%{_firefoxdir}/{install.rdf,chrome.manifest}
148 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
149 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/{taglib,vfs/container,vfs/transport}/*.{a,la}
150 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/th_TH
151
152 %find_lang %{name}
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post
158 %update_desktop_database_post
159 %update_mime_database
160 %update_icon_cache hicolor
161
162 %banner %{name} -e << EOF
163 Remember to install appropriate GStreamer plugins for files
164 you want to play:
165 - gstreamer-cdparanoia (for Audio-CD)
166 - gstreamer-flac (for FLAC)
167 - gstreamer-mad (for MP3s)
168 - gstreamer-vorbis (for Ogg Vorbis)
169 EOF
170
171 %postun
172 %update_desktop_database_postun
173 %update_mime_database
174 %update_icon_cache hicolor
175
176 %files -f %{name}.lang
177 %defattr(644,root,root,755)
178 %doc AUTHORS ChangeLog NEWS README
179 %attr(755,root,root) %{_bindir}/beep-media-player-2
180 %attr(755,root,root) %{_bindir}/bmp-enqueue-files-2.0 
181 %attr(755,root,root) %{_bindir}/bmp-enqueue-uris-2.0
182 %attr(755,root,root) %{_bindir}/bmp-play-files-2.0
183 %attr(755,root,root) %{_bindir}/bmp-play-lastfm-2.0
184 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-bin
185 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-sentinel
186
187 %dir %{_libdir}/bmpx
188 %dir %{_libdir}/bmpx/plugins
189 %dir %{_libdir}/bmpx/plugins/taglib
190 %dir %{_libdir}/bmpx/plugins/vfs
191 %dir %{_libdir}/bmpx/plugins/vfs/container
192 %dir %{_libdir}/bmpx/plugins/vfs/transport
193 %attr(755,root,root) %{_libdir}/bmpx/plugins/taglib/*.so*
194 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/container/*.so*
195 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/transport/*.so*
196
197 %{_datadir}/bmpx
198 %{_datadir}/dbus-1/services/*.service
199 %{_mandir}/man*/*
200 %{_desktopdir}/*.desktop
201 %{_iconsdir}/hicolor/*/*/*.png
202
203 %files devel
204 %defattr(644,root,root,755)
205 %{_includedir}/bmp-2.0
206 %{_pkgconfigdir}/*.pc
207
208 %files -n mozilla-firefox-plugin-bmpx
209 %defattr(644,root,root,755)
210 %{_chromedir}/bmp.jar
211 %{_chromedir}/bmp.manifest
This page took 0.058722 seconds and 4 git commands to generate.